Имеется последовательность чисел 0, 5, 50, 55, 500, 505, 550, 555, 5000, 5005, 5050 и так далее (числа состоят только из 0 и 5, числа записаны в порядке возрастания)?

Информатика | 10 - 11 классы

Имеется последовательность чисел 0, 5, 50, 55, 500, 505, 550, 555, 5000, 5005, 5050 и так далее (числа состоят только из 0 и 5, числа записаны в порядке возрастания).

Написать программу, которая при вводе n - го числа выводит по порядку в этой последовательности число.

Например, при вводе числа 8, программа должна выводить 555.

При вводе числа 5, программа должны выводить 500.

Ответить на вопрос
Ответы (1)
Rkrasotkin 24 февр. 2021 г., 03:30:26

/ / PascalABC.

NET

uses System ;

begin write(Convert.

ToString(ReadInteger - 1, 2).

Replace('1', '5')) ;

end.

Yurik12238 31 мар. 2021 г., 20:15:32 | 10 - 11 классы

Написать программу Pascal, которая выводила бы число в обратной последовательности?

Написать программу Pascal, которая выводила бы число в обратной последовательности.

Gjandossova 21 янв. 2021 г., 06:41:37 | 5 - 9 классы

Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры?

Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры.

Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.

Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если - 8 и - 3, то « - 6 –4».

Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит.

Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.

Diman17114 29 мая 2021 г., 11:10:09 | 5 - 9 классы

Напишите программу, которая вводит трехзначное число и разбивает его на цифры?

Напишите программу, которая вводит трехзначное число и разбивает его на цифры.

Например, при вводе числа 123 программа должна вывести “1 2 3” (Python).

Aleksandrakind 2 июн. 2021 г., 18:06:31 | 10 - 11 классы

Имеется последовательность чисел 0, 5, 50, 55, 500, 505, 550, 555, 5000, 5005, 5050 и так далее (числа состоят только из 0 и 5, числа записаны в порядке возрастания)?

Имеется последовательность чисел 0, 5, 50, 55, 500, 505, 550, 555, 5000, 5005, 5050 и так далее (числа состоят только из 0 и 5, числа записаны в порядке возрастания).

Написать программу, которая при вводе n - го числа выводит по порядку в этой последовательности число.

Например, при вводе числа 8, программа должна выводить 555.

При вводе числа 5, программа должны выводить 500.

Mariya221197 10 мая 2021 г., 10:42:30 | 10 - 11 классы

Вводится последовательность целых чисел до тех пор, пока не будет введено число 0?

Вводится последовательность целых чисел до тех пор, пока не будет введено число 0.

После ввода числа 0 программа должна вывести минимальное число.

Интересует только JAVA или C#.

Katushka16 8 дек. 2021 г., 13:43:17 | 5 - 9 классы

Составьте программу, которая вводит с клавиатуры два числа и выводит их сумму, разность, произведение и частное?

Составьте программу, которая вводит с клавиатуры два числа и выводит их сумму, разность, произведение и частное.

1kara2190 10 окт. 2021 г., 10:55:10 | 10 - 11 классы

1) Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

1) Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

С + +

2) Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ].

C + +

3) Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b .

С + +.

Kirik223 5 мая 2021 г., 14:42:59 | 10 - 11 классы

Написать программу, которая выводит числа от 1 до К (К - натуральное число) в убывающем порядке?

Написать программу, которая выводит числа от 1 до К (К - натуральное число) в убывающем порядке.

Serzhzid 1 июн. 2021 г., 02:20:15 | 5 - 9 классы

Составить программу Pascal, которая вводит четырёхзначное число и выводит число - перевертыш (пример : 1234 - 4321)?

Составить программу Pascal, которая вводит четырёхзначное число и выводит число - перевертыш (пример : 1234 - 4321).

Nastya3592558 12 нояб. 2021 г., 04:14:59 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и выводит первые N четных натуральных чисел?

Напишите программу, которая вводит натуральное число N и выводит первые N четных натуральных чисел.

На этой странице находится вопрос Имеется последовательность чисел 0, 5, 50, 55, 500, 505, 550, 555, 5000, 5005, 5050 и так далее (числа состоят только из 0 и 5, числа записаны в порядке возрастания)?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.