Составте алгоритм для определения количества цифр в записи числа произвольного натурального числа?

Информатика | 5 - 9 классы

Составте алгоритм для определения количества цифр в записи числа произвольного натурального числа.

Ответить на вопрос
Ответы (1)
Walle764 8 нояб. 2020 г., 14:08:24

Program n1 ;

var n, m, p, k : longint ;

begin

write('введите n : ') ;

readln(n) ;

m : = n ;

k : = 0 ;

while m0 do begin

p : = m mod 10 ;

K : = K + 1 ;

m : = m div 10 ;

end ;

writeln('кол - во цифр : ', K) ;

end.

Ееуу 7 нояб. 2020 г., 06:35:32 | 5 - 9 классы

Составте алгоритм для определения количества цифр в записи числа произвольного натурального числа?

Составте алгоритм для определения количества цифр в записи числа произвольного натурального числа.

Reginaskibina 8 авг. 2020 г., 16:55:48 | 10 - 11 классы

Составьте программу, которая для произвольного натурального двузначного числа определяет число, образованное перестановкой цифр исходного числа?

Составьте программу, которая для произвольного натурального двузначного числа определяет число, образованное перестановкой цифр исходного числа.

Gulchatayogly 26 апр. 2020 г., 08:30:02 | 5 - 9 классы

Напишите программу на языке программирования (или составьте алгоритм)?

Напишите программу на языке программирования (или составьте алгоритм).

Дано натуральное число n.

Определите, сколько раз цифра «7» встречается в записи данного числа.

Путинцев 25 мар. 2020 г., 13:38:19 | 5 - 9 классы

С числом разрешается проводить только два действия : умножать на 2 и стирать последнюю цифру?

С числом разрешается проводить только два действия : умножать на 2 и стирать последнюю цифру.

Составте алгоритм получения из числа 458 числа 14.

София2003Софико 13 авг. 2020 г., 20:52:15 | 5 - 9 классы

Нарисуйте мне как вот это будет плес?

Нарисуйте мне как вот это будет плес.

Блок - схему нужно var a : integer ; b : string ; begin readln(a) ; b : = inttostr(a) ; writeln(length(b)) ; end.

Или по своему решите задачу : составьте алгоритм для определения количества цифр в записи произвольного натурального числа.

Только пжлс на листочке и фотографируйте.

Или напишите как то.

Попонятнее.

Физика9клас 14 дек. 2020 г., 14:38:56 | 5 - 9 классы

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа?

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа.

Eqorqeiko 11 мар. 2020 г., 07:55:46 | 10 - 11 классы

Код программы в PASCAL, СРОЧНО?

Код программы в PASCAL, СРОЧНО!

Условие : Вводятся 3 натуральных числа.

Найти сумму цифр каждого из них (создать функцию для нахождения суммы цифр произвольного натурального числа).

Надежжжжжж 13 дек. 2020 г., 19:28:04 | 5 - 9 классы

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль)?

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль).

Улка1 29 мар. 2020 г., 10:07:58 | 5 - 9 классы

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа?

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа.

Aidarchic100 7 мар. 2020 г., 10:46:51 | 5 - 9 классы

Составь алгоритм для опрееделения колва цифр в записи произвального натурального числа помогите )?

Составь алгоритм для опрееделения колва цифр в записи произвального натурального числа помогите ).

На этой странице находится вопрос Составте алгоритм для определения количества цифр в записи числа произвольного натурального числа?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.