Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N?

Информатика | 5 - 9 классы

Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N.

Ответить на вопрос
Ответы (1)
Aspire2001 3 нояб. 2020 г., 13:56:16

Var i, n, s, k : integer ;

begin readln(n) ; for i : = 100 to 999 do begin s : = 0 ; k : = i ; while k > 0 do begin s : = s + k mod 10 ; k : = k div 10 ; end ; if s = n then writeln(i) ; end ;

end.

Пашок99 29 нояб. 2020 г., 16:48:27 | 5 - 9 классы

Пожалуйста помогите решить желательно все или хотя бы одну (P?

Пожалуйста помогите решить желательно все или хотя бы одну (P.

S. программа для программы Turbo Pascal) 1.

Написать программу, которая предлагает ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот.

(123 - 321) 3.

Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Ramazanovrifat 23 июн. 2020 г., 12:39:58 | 5 - 9 классы

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа?

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа.

(Pascal).

Tofkovamasha 26 мар. 2020 г., 23:18:30 | 5 - 9 классы

Напишите программу поиска всех трёхзначных чисел, сумма цифр которых и само число кратны 7 Paskal?

Напишите программу поиска всех трёхзначных чисел, сумма цифр которых и само число кратны 7 Paskal.

Sabrinakotsk1 27 сент. 2020 г., 00:02:27 | 5 - 9 классы

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC?

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу, которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.

Lubavapopovar 27 дек. 2020 г., 01:10:11 | 5 - 9 классы

Составить программу на Pascal ABC?

Составить программу на Pascal ABC.

Составить программу которая вычисляет сумму всех нечетных и кол - во четных чисел от 10 до 99.

Саид55 28 мар. 2020 г., 02:25:50 | 5 - 9 классы

Составить программу Pascal : Найти произведение цифр заданого 3х значного числа ?

Составить программу Pascal : Найти произведение цифр заданого 3х значного числа .

RIKA555 9 июн. 2020 г., 10:08:41 | 5 - 9 классы

Составить программу для нахождения количества таких трехзначных чисел Фибоначчи, которые делятся на сумму своих цифр нацело?

Составить программу для нахождения количества таких трехзначных чисел Фибоначчи, которые делятся на сумму своих цифр нацело.

Программа - Pascal ABC.

Викасмешная 8 апр. 2020 г., 11:36:36 | 5 - 9 классы

Составить программу поиска первых n чисел, равных сумме кубов своих цифр?

Составить программу поиска первых n чисел, равных сумме кубов своих цифр.

Программа - Паскаль АBC.

JohnLenon 23 нояб. 2020 г., 18:25:06 | 5 - 9 классы

1) Составить программу вывода на экран первых 10 натуральных чисел2) Составить программу вычисления суммы N первых чисел В Pascal?

1) Составить программу вывода на экран первых 10 натуральных чисел

2) Составить программу вычисления суммы N первых чисел В Pascal.

Milanka20021 7 окт. 2020 г., 10:11:45 | 5 - 9 классы

Cоставить программу, которая определяет, является ли 2 * N значное число "счастливым" (сумма цифр первой половины равна сумме цифр второй половины), где 1?

Cоставить программу, которая определяет, является ли 2 * N значное число "счастливым" (сумма цифр первой половины равна сумме цифр второй половины), где 1.

Перед вами страница с вопросом Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.