Решить в паскале : Написать программу, определяющую, является ли фигура квадратом?

Информатика | 10 - 11 классы

Решить в паскале : Написать программу, определяющую, является ли фигура квадратом.

Вершины квадрата задаются координатами точек.

Ответить на вопрос
Ответы (1)
Orbita 29 нояб. 2020 г., 05:08:25

/ / PascalABC.

NET 3.

2, сборка 1356 от 04.

12. 2016 / / Внимание!

Если программа не работает, обновите версию!

Type Point = record x, y : real ; name : char end ; Vector = record x, y, l : real ; end ;

function CreatePoint(px, py : real) : Point ;

begin With Result do begin x : = px ; y : = py ; end

end ;

function CreateVector(A, B : Point) : Vector ;

begin With Result do begin x : = B.

X - A.

X ; y : = B.

Y - A.

Y ; l : = Sqrt(x * x + y * y) end

end ;

function IsNormal(A, B : Vector) : = Abs(B.

X * A.

X + B.

Y * A.

Y)< ; = 1e - 6 ;

begin var x, y : real ; Write('Введите координаты x и y точки A : ') ; Read(x, y) ; var A : = CreatePoint(x, y) ; Write('Введите координаты x и y точки B : ') ; Read(x, y) ; var B : = CreatePoint(x, y) ; var AB : = CreateVector(A, B) ; Write('Введите координаты x и y точки C : ') ; Read(x, y) ; var C : = CreatePoint(x, y) ; var BC : = CreateVector(B, C) ; if Abs(AB.

L - BC.

L)> ; 1e - 6 then begin Writeln('Стороны AB и BC не равны') ; Exit end ; if not IsNormal(AB, BC) then begin Writeln('Стороны AB и BC не перпендикулярны') ; Exit end ; Write('Введите координаты x и y точки D : ') ; Read(x, y) ; var D : = CreatePoint(x, y) ; var CD : = CreateVector(C, D) ; if Abs(AB.

L - CD.

L)> ; 1e - 6 then begin Writeln('Стороны AB и CD не равны') ; Exit end ; var AD : = CreateVector(D, A) ; if Abs(AB.

L - AD.

L)> ; 1e - 6 then Writeln('Стороны AB и ADC не равны') else Writeln('Точки образуют квадрат с точностью не ниже 0.

000001')

end.

Пример

Здесь заданы координаты квадрата, сдвинутого относительно осей координат и повернутого на угол 30 градусов против часовой стрелки.

Поэтому числа такие "некруглые".

Введите координаты x и y точки A : - 0.

4641 - 4.

4641

Введите координаты x и y точки B : 3.

5359 2.

4641

Введите координаты x и y точки C : 10.

4641 - 1.

5359

Введите координаты x и y точки D : 6.

4641 - 8.

4641

Точки образуют квадрат с точностью не ниже 0.

000001.

SnakeGame 7 авг. 2020 г., 08:05:46 | 10 - 11 классы

Написать программу, определяющую по координатам трёх точек длины биссектрис треугольника, если таковой существует?

Написать программу, определяющую по координатам трёх точек длины биссектрис треугольника, если таковой существует.

(PascalABC).

IrishaT 26 мая 2020 г., 14:52:10 | 5 - 9 классы

Решить задачу в Паскале?

Решить задачу в Паскале.

Даны координаты противоположных вершин А и С квадрата ABCD.

Найти координаты вершин B и D.

Данные для ввода : А(1, 1), С(3, 3).

Milenniumarch 13 апр. 2020 г., 13:10:47 | 10 - 11 классы

Помогите ПЛИИИЗ)Даны радиус круга и сторона квадрата написать программу определяющую у какой фигуры площадь больше?

Помогите ПЛИИИЗ)Даны радиус круга и сторона квадрата написать программу определяющую у какой фигуры площадь больше?

Nikneim777 12 февр. 2020 г., 14:49:35 | 10 - 11 классы

Написать программу для Паскаля?

Написать программу для Паскаля.

Даны координаты вершин треугольника АВС.

Найти его площадь.

Russkiy1413 31 мая 2020 г., 10:31:35 | 10 - 11 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

В ПАСКАЛЕ!

Littlemonster29 7 июл. 2020 г., 17:39:16 | 10 - 11 классы

Написать програму для ПАСКАЛЬ на уравнение ах(в квадрате) + bx + c = 0?

Написать програму для ПАСКАЛЬ на уравнение ах(в квадрате) + bx + c = 0.

Нужна только программа, чтобы я ввела в ПАСКАЛЬ.

777grisha05 18 июл. 2020 г., 19:39:57 | 10 - 11 классы

Написать программу на паскале Треугольник задан координатами (x1, y1), (x2, y2), (x3, y3) своих вершин?

Написать программу на паскале Треугольник задан координатами (x1, y1), (x2, y2), (x3, y3) своих вершин.

Вычислить радиус окружности, вписанной в треугольник.

Islam27061997 1 мая 2020 г., 14:57:44 | 10 - 11 классы

Программа на языке С Написать рекурсивную функцию, определяющую, является ли заданное натуральное число простым?

Программа на языке С Написать рекурсивную функцию, определяющую, является ли заданное натуральное число простым.

Elchenkovdima 17 июл. 2020 г., 09:17:09 | 5 - 9 классы

Даны сторона квадрата и радиус окружности?

Даны сторона квадрата и радиус окружности.

Составить программу определяющую у какой фигуры площадь больше.

LerkaLeraWaleria 15 июн. 2020 г., 23:28:29 | 5 - 9 классы

1. Составьте алгоритм, определяющий является ли прямоугольник квадратом, если заданы две стороны?

1. Составьте алгоритм, определяющий является ли прямоугольник квадратом, если заданы две стороны.

Алгоритм должен так же определять периметр прямоугольника, если он не является квадратом, и площадь фигуры, если это квадрат.

2. Нарисуйте блок - схему составленного алгоритма.

Вы зашли на страницу вопроса Решить в паскале : Написать программу, определяющую, является ли фигура квадратом?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.