ПАСКАЛЬ, помогите пожалуйста отсортировать по возрастанию отрицательные элементы массива?

Информатика | 10 - 11 классы

ПАСКАЛЬ, помогите пожалуйста отсортировать по возрастанию отрицательные элементы массива.

Вывести исходный массив и измененный массив.

Можно использовать любой метод сортировки.

Массив заполнить случайными положительными и отрицательными числами.

Ответить на вопрос
Ответы (1)
Lilusha9617 18 апр. 2020 г., 15:35:23

Const n = 10 ;

var a, b, c : array[1.

N] of integer ; i, j, kb, kc, t : integer ;

begin Randomize ; Writeln('Исходный массив') ; kb : = 0 ; kc : = 0 ; for i : = 1 to n do begin a[i] : = random(101) - 50 ; Write(a[i] : 4) ; if a[i] < ; 0 then begin Inc(kb) ; b[kb] : = a[i] end else begin Inc(kc) ; c[kc] : = a[i] end end ; Writeln ; { теперь массив b содержит отрицательныые элементы, с - остальные } for i : = 1 to kb - 1 do for j : = 1 to kb - 1 do if b[j] > ; b[j + 1] then begin t : = b[j] ; b[j] : = b[j + 1] ; b[j + 1] : = t end ; { сливаем массивы b и c в массив а} i : = 0 ; for j : = 1 to kb do begin i : = i + 1 ; a[i] : = b[j] end ; for j : = 1 to kc do begin i : = i + 1 ; a[i] : = c[j] end ; Writeln('Результирующий массив') ; for i : = 1 to n do Write(a[i] : 4) ; Writeln

end.

Тестовое решение :

Исходный массив - 32 - 8 43 - 24 8 - 45 - 13 40 17 46

Результирующий массив - 45 - 32 - 24 - 13 - 8 43 8 40 17 46.

Olegolegru 5 янв. 2020 г., 20:30:44 | 10 - 11 классы

Заполнить массив случайными числами из интервала [ - 50 ; 50] , вывести массив на экран, посчитать сумму отрицательных элементов?

Заполнить массив случайными числами из интервала [ - 50 ; 50] , вывести массив на экран, посчитать сумму отрицательных элементов.

Anastetion99 2 мая 2020 г., 02:12:51 | 10 - 11 классы

В паскале?

В паскале.

Отсортировать исходный одномерный массив по возрастанию методом поиска максимума и обмена.

АрПлон 5 апр. 2020 г., 19:49:59 | 5 - 9 классы

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25?

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25.

Tusha06 28 июн. 2020 г., 17:36:54 | 5 - 9 классы

Помогите, пожалуйста, СРОЧНО?

Помогите, пожалуйста, СРОЧНО!

Составить программу : Заполнить массив из 10 элементов с клавиатуры целыми положительными и отрицательными числами и вывести на экран в строчку только отрицательные числа.

Helz 21 июл. 2020 г., 13:49:40 | 10 - 11 классы

Дан массив из 50 чисел?

Дан массив из 50 чисел.

Заполните его случайными числами.

Вывести на экран сначала все положительные его элементы, а затем все отрицательные.

Ivansmirnov0201 30 апр. 2020 г., 21:36:19 | 10 - 11 классы

Заполнить массив из 10 элементов случайными числами от - 10 до 5?

Заполнить массив из 10 элементов случайными числами от - 10 до 5.

Произвести сортировку методом прямого обмена по возрастанию.

(Код нужен на паскаль).

Iliea0033 10 нояб. 2020 г., 02:33:37 | 5 - 9 классы

Помогите пожалуйста составить программуЗаполнить массив из 500 элементов случайными числами в интервале [0?

Помогите пожалуйста составить программу

Заполнить массив из 500 элементов случайными числами в интервале [0.

100].

Отсортировать его по возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» .

Вывести на экран число перестановок элементов массива в том и в другом случае.

Массив выводить на экран не нужно.

Аааааа53 6 дек. 2020 г., 11:35:41 | 10 - 11 классы

1. Заполнить одномерный массив B вещественными числами из промежутка от - 20 до 5?

1. Заполнить одномерный массив B вещественными числами из промежутка от - 20 до 5.

Найти сумму и среднее положительных и четных элементов массива.

Найти произведение отрицательных элементов массива.

Найти минимальный элемент массива.

Отсортировать массив по убыванию.

2. Заполнить одномерный массив А целыми числами из промежутка от - 12 до 7.

Вывести элементы массива, значения которых больше заданного числа Н и кратны числу К.

Найти максимальный элемент массива.

Отсортировать массив по возрастанию.

На паскале.

СветЛана9910 3 мая 2020 г., 09:11:59 | 10 - 11 классы

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона?

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона.

Вывести созданный массив на экран, расположив элементы в одну строку через пробелы.

Заменить все отрицательные элементы квадратом соответствующего индекса.

Raevskiy2001 2 янв. 2020 г., 17:24:56 | 10 - 11 классы

Дан массив, наполненный отрицательными, положительными числами и нулями?

Дан массив, наполненный отрицательными, положительными числами и нулями.

Найти индекс первого нуля после сортировки массива по возрастанию.

На этой странице сайта размещен вопрос ПАСКАЛЬ, помогите пожалуйста отсортировать по возрастанию отрицательные элементы массива? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.