В одном массиве целых чисел найти сумму max и min элементов массива?

Информатика | 5 - 9 классы

В одном массиве целых чисел найти сумму max и min элементов массива.

Ответить на вопрос
Ответы (1)
Aleksandp2077 24 дек. 2020 г., 16:03:52

Var

n, k, i, max, sum, min : integer ;

a : array [1.

100] of integer ;

begin

writeln ('vvedi n') ;

read (n) ;

writeln (n) ;

k : = 0 ;

for i : = 1 to n do

read (a[i]) ;

max : = a[1] ;

min : = a[1] ;

for i : = 1 to n do

begin

if a[i]< ; min then min : = a[i] ;

if a[i]> ; max then max : = a[i] ;

end ;

sum : = min + max ;

writeln ('sum = ', sum) ;

end.

Abdusalamova99 8 апр. 2020 г., 20:11:35 | 10 - 11 классы

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0?

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0.

2)В массиве М из 10 целых чисел найти количество элементов равных 3.

3)В массиве из 8 целых найти номер массива с наибольшим значением.

4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента.

5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

IlyaBro 31 авг. 2020 г., 11:07:49 | 10 - 11 классы

Даны два одномерных массива из целых чисел, разной размерности?

Даны два одномерных массива из целых чисел, разной размерности.

Найти целую часть среднего арифмитического элементов каждого массива и их сумму.

Миньон4 2 янв. 2020 г., 08:46:10 | 10 - 11 классы

Дан массив всех целых чисел ?

Дан массив всех целых чисел .

Найти сумму элементов в массиве.

(Паскаль).

Kerik612 28 сент. 2020 г., 08:08:23 | 10 - 11 классы

1) Найти сумму отрицательных элементов массива целых чисел?

1) Найти сумму отрицательных элементов массива целых чисел.

Размерность массива 10 .

Заполнение массива осуществить случайными числами от - 20 до 20 .

2) Найдите сумму чётных элементов массива целых чисел.

Размерность массива 20.

Заполнения массива осуществляется случайными числами от 15 до 25 .

Anastasiamakar 27 янв. 2020 г., 00:10:36 | 10 - 11 классы

Дан массив из 100 целых чисел и найти сумму элементов массива?

Дан массив из 100 целых чисел и найти сумму элементов массива.

Nastyakochkina 12 авг. 2020 г., 22:02:10 | 5 - 9 классы

ПОЖАЛУЙСТА, ПОМОГИТЕ?

ПОЖАЛУЙСТА, ПОМОГИТЕ.

ОЧЕНЬ НАДО!

Одномерный массив размером [10]заполнить числами с клавиатуры, найти max и min элементы и сумму четных элементов массива.

Aleksey2123 3 апр. 2020 г., 17:23:28 | 10 - 11 классы

В МАССИВЕ ИЗ 10 НАЙТИ СУММУ ПОЛОЖИТЕЛЬНЫХ ЧИСЕЛ, ОКАНЧИВАЮЩИХСЯ НА 4 ЭЛЕМЕНТЫ МАССИВА ЦЕЛЫЕ ЧИСЛА?

В МАССИВЕ ИЗ 10 НАЙТИ СУММУ ПОЛОЖИТЕЛЬНЫХ ЧИСЕЛ, ОКАНЧИВАЮЩИХСЯ НА 4 ЭЛЕМЕНТЫ МАССИВА ЦЕЛЫЕ ЧИСЛА.

Аrtemka 1 авг. 2020 г., 20:03:36 | 5 - 9 классы

Найти сумму первых k элементов массива А(20) ; сколько чисел массива не превышает среднее значение суммы n элементов массива?

Найти сумму первых k элементов массива А(20) ; сколько чисел массива не превышает среднее значение суммы n элементов массива.

Bambucci 17 июл. 2020 г., 10:23:45 | 5 - 9 классы

Найти сумму четных элементов массива целых чисел?

Найти сумму четных элементов массива целых чисел.

Размерность массива - 20.

Заполнение массива осуществить случайными числами от 100 до 200.

Дюймовочкa123 4 мая 2020 г., 21:39:21 | 10 - 11 классы

ВВЕСТИ МАССИВ А(n) ЦЕЛЫХ ЧИСЕЛ?

ВВЕСТИ МАССИВ А(n) ЦЕЛЫХ ЧИСЕЛ.

НАЙТИ MAX СРЕДИ ЭЛЕМЕНТОВ МАССИВА.

ЗАМЕНИТЬ ПЕРВЫЙ И ПОСЛЕДНИЙ ЭЛЕМЕНТЫ УДВОЕННЫМ ЗНАЧЕНИЕМ MAX.

На этой странице находится вопрос В одном массиве целых чисел найти сумму max и min элементов массива?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.