В числовую переменную последовательно вводятся целые числа, не равные нулю?

Информатика | 10 - 11 классы

В числовую переменную последовательно вводятся целые числа, не равные нулю.

Кол - во вводимых чисел n неизвестно.

Найти сумму тех чисел, в которых встречаются ровно две цифры 5.

(в паскале написать программу).

Ответить на вопрос
Ответы (2)
Yana123y 6 янв. 2021 г., 17:04:44

= = = = = = = = = = 1 вариант через строку = = = = = = = = = =

var n, a, k, sum, i, j : integer ; s : string ;

begin sum : = 0 ; write ('Введите количество чисел : ') ; readln (n) ; for i : = 1 to n do begin write ('Введите число : ') ; readln (a) ; Str(a, s) ; k : = 0 ; for j : = 1 to length(s) do if s[j] = '5' then k : = k + 1 ; if k = 2 then sum : = sum + a ; end ; writeln ('Sum = ', sum) ;

end.

= = = = = = = = = = 2 вариант через div и mod = = = = = = = = = =

var n, a, x, k, sum, i : integer ;

begin sum : = 0 ; write ('Введите количество чисел : ') ; readln (n) ; for i : = 1 to n do begin write ('Введите число : ') ; readln (a) ; x : = abs(a) ; k : = 0 ; while x>0 do begin if x mod 10 = 5 then k : = k + 1 ; x : = x div 10 ; end ; if k = 2 then sum : = sum + a ; end ; writeln ('Sum = ', sum) ;

end.

= = = = = = = = = = пример результата : = = = = = = = = = =

Введите количество чисел : 3

Введите число : 550001

Введите число : - 550000

Введите число : 123456

Sum = 1.

Zenyska 6 янв. 2021 г., 17:04:48

/ / PascalABC.

NET версия 3.

2, сборка 1367

begin var sum : = 0 ; for var i : = 1 to ReadInteger('n = ') do begin var num : = ReadInteger('Введите число = ') ; if num.

ToString().

ToCharArray.

Count(c - > c = '5') = 2 then sum + = num ; end ; Writeln(sum) ;

end.

Dvoewnik 29 янв. 2021 г., 12:34:08 | 5 - 9 классы

1. Дана непустая последовательность целых чисел, оканчивающаяся нулем?

1. Дана непустая последовательность целых чисел, оканчивающаяся нулем.

Найти сумму всех чисел последовательности.

Паскаль.

Svetlana516298 23 янв. 2021 г., 04:11:51 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

Creeper82 25 февр. 2021 г., 07:58:12 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

ОЧЕНЬ СРОЧНО.

DariyaP 2 авг. 2021 г., 14:44:31 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность

СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

Llloookkk 14 июл. 2021 г., 23:56:16 | 5 - 9 классы

Напишите программу которая вводит последовательность целых чисел, заканчивающуюся нулем, и определяет кол - во четных положительных чисел в этой последовательности(паскаль, питон)?

Напишите программу которая вводит последовательность целых чисел, заканчивающуюся нулем, и определяет кол - во четных положительных чисел в этой последовательности(паскаль, питон).

Pylypivam 9 окт. 2021 г., 04:37:41 | 5 - 9 классы

1. Написать программу, которая выводит количество нулей во вводимой с клавиатуры последовательности из 100 целых чисел?

1. Написать программу, которая выводит количество нулей во вводимой с клавиатуры последовательности из 100 целых чисел.

1234ал1 2 мар. 2021 г., 06:22:14 | 5 - 9 классы

Напишите программу которая вводит последовательность целых чисел, заканчивающуюся нулем, и определяет кол - во четных положительных чисел в этой последовательности(паскаль)?

Напишите программу которая вводит последовательность целых чисел, заканчивающуюся нулем, и определяет кол - во четных положительных чисел в этой последовательности(паскаль).

Срочно!

Пожалуйста!

1.

Окси358 6 мая 2021 г., 19:58:31 | 5 - 9 классы

Помогите пожалуйстаСоставить программу для последовательного произведения вводимых с клавиатуры целых чисел , предусмотреть выход из произведения при вводе нуля?

Помогите пожалуйста

Составить программу для последовательного произведения вводимых с клавиатуры целых чисел , предусмотреть выход из произведения при вводе нуля.

Аминаоз 3 сент. 2021 г., 22:36:39 | 5 - 9 классы

Помогите пожалуйстаСоставить программу для последовательного произведения вводимых с клавиатуры целых чисел , предусмотреть выход из произведения при вводе нуля?

Помогите пожалуйста

Составить программу для последовательного произведения вводимых с клавиатуры целых чисел , предусмотреть выход из произведения при вводе нуля.

Язык Паскаль.

TimaVA 15 февр. 2021 г., 17:58:35 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

ПАСКАЛЬ!

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, последняя цифра которых равна А и все число делится на В.

Последовательность чисел заканчивается числом 0.

Числа А и В вводятся до цикла.

(должен быть цикл while).

Вы зашли на страницу вопроса В числовую переменную последовательно вводятся целые числа, не равные нулю?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.