ОЧЕНЬ СРОЧНО?

Информатика | 10 - 11 классы

ОЧЕНЬ СРОЧНО!

ПОЖАЛУЙСТА РЕШИТЕ ЗАДАЧУ!

ЗАРАНЕЕ СПАСИБО!

Используя строковый и символьный типы данных, составьте программу для решения задачи : Дано предложение.

Найдите кол - во слов в предложении (слова разделены пробелом).

Ответить на вопрос
Ответы (1)
Kostiya2002 19 февр. 2020 г., 06:53:42

PascalABC.

NET

Программа сработает некорректно если слова будут разделены несколькими пробелами или строка будет заканчиваться пробелом

const c = ' ' ;

var

s : string ;

k, p : integer ;

begin

writeln ('Введите строку') ;

readln (s) ;

k : = - 1 ;

p : = 1 ;

if (s < ; > ; '') and (s < ; > ; ' ') then

begin

while p < ; > ; 0 do

begin

k : = k + 1 ;

p : = PosEx (c, s, p + 1) ;

end ;

writeln (k + 1, ' word')

end

else

writeln ('error string') ;

end.

Ktivtsova 13 янв. 2020 г., 07:43:47 | 10 - 11 классы

Помогите пожалуйста решить две задачи?

Помогите пожалуйста решить две задачи!

1 задача) Дан массив.

Найти сумму и произведение нечетных элементов кратных 3 2 задача) Дан массив.

Найти кол - во положительных в нем элементов Заранее огромное спасибо!

Serg1587 8 нояб. 2020 г., 03:17:48 | 10 - 11 классы

Используя операции и функции для строковых типов данных, написать программу, где из слова РАДОСТЬ получиться слово ССОРА?

Используя операции и функции для строковых типов данных, написать программу, где из слова РАДОСТЬ получиться слово ССОРА.

Nik1998shch 25 авг. 2020 г., 10:22:53 | 10 - 11 классы

Строковый тип паскаль : Дана строка?

Строковый тип паскаль : Дана строка.

Определить сколько в ней слов оканчиваются на букву «н».

Skyline241 5 нояб. 2020 г., 05:20:51 | 10 - 11 классы

Даны натуральное число n, символы S1?

Даны натуральное число n, символы S1.

Sn, определить число вхождений группы букв abc.

Символьный и строковый тип.

Помогите пожалуйста.

Очень прошу.

В паскале.

Valera1316 28 янв. 2020 г., 05:59:53 | 5 - 9 классы

Составьте программу нахождения количество слов в предложении?

Составьте программу нахождения количество слов в предложении.

Предложение состоит из слов, отделёный друг от друга одним пробелом, вводится с клавиатуры.

Vikaviking 12 янв. 2020 г., 10:53:41 | 10 - 11 классы

Cтроки?

Cтроки.

Паскаль.

1. Задано слово - последовательность произвольных символов.

Сделать программу, в которой составляется слово перевертыш к данному ( символы записываются в обратной последовательности.

) 2. Дана символьная строка.

Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.

Составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Аликеся 21 авг. 2020 г., 04:01:29 | 10 - 11 классы

В паскале решите задачу : ) 1?

В паскале решите задачу : ) 1.

В строке слова разделены пробелами.

Определить на какую букву оканчивается четвертое слово в предложении.

2. Дана последовательность слов.

Напечатать те слова последовательности, которые отличны от первого слова и удовлетворяют следующему свойству : в слове нет повторяющихся букв.

Nastasia007TWIX 11 дек. 2020 г., 17:07:16 | 10 - 11 классы

Решить задачу на языке программирования Pascal : Дано предложение в котором между словами 2 или несколько пробелов : "Мама моет Машу"?

Решить задачу на языке программирования Pascal : Дано предложение в котором между словами 2 или несколько пробелов : "Мама моет Машу".

Сколько сочетаний букв "Ma" в предложении.

Lenokmalyshok 1 мая 2020 г., 18:53:58 | 1 - 4 классы

Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов?

Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов.

Предложения вводятся в одну строку.

Программа должна переписать введенную строку, оставив полько по одному пробелу между словами.

Andromeda00 27 июн. 2020 г., 14:20:38 | 5 - 9 классы

Помогите решить задачи)) пожалуйста ) через дано и решение заранее спасибо?

Помогите решить задачи)) пожалуйста ) через дано и решение заранее спасибо.

На этой странице находится ответ на вопрос ОЧЕНЬ СРОЧНО?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.