Помогите по Паскалю срочно?

Информатика | 10 - 11 классы

Помогите по Паскалю срочно!

Нужно написать код в паскале который будет делить число на разряды к примеру.

Ввод 12345678 вывод 12, 345, 678.

Ответить на вопрос
Ответы (1)
Рахимчик 6 нояб. 2020 г., 17:37:56

Var s : string ; i : integer ;

begin Write('Введите натуральное число : ') ; Readln(s) ; i : = Length(s) - 2 ; while i> ; 1 do begin Insert(', ', s, i) ; i : = i - 3 end ; Writeln(s)

end.

Пример

Введите натуральное число : 12345678

12, 345, 678.

Temasan1998 11 авг. 2020 г., 05:07:05 | 5 - 9 классы

Паскаль : «Введите с клавиатуры число x?

Паскаль : «Введите с клавиатуры число x.

Определите, является ли данное число дробным.

Пример ввода : 3.

5 Пример вывода : Число дробное».

Madam1violi 19 дек. 2020 г., 02:16:46 | 5 - 9 классы

В Паскале написать программу?

В Паскале написать программу.

Вводите число и по ней таблица умножения выводится.

Пустой 15 мар. 2020 г., 10:32:37 | 5 - 9 классы

Найти количество делителей натурального числа А, больших К?

Найти количество делителей натурального числа А, больших К.

(А и К вводятся с клавиатуры, K< ; = A).

Код должен быть написан на языке Паскаля (Pascal).

Megumiya 11 июн. 2020 г., 18:35:24 | 5 - 9 классы

Представьте четное число n (2 Пример ввода : 110 Вывод : 7 + 103 Составьте Паскаль программы срочно нужно плиииз?

Представьте четное число n (2 Пример ввода : 110 Вывод : 7 + 103 Составьте Паскаль программы срочно нужно плиииз.

Аня1210 5 июн. 2020 г., 08:29:44 | 5 - 9 классы

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом?

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом.

Safolur74 7 июн. 2020 г., 11:44:24 | 5 - 9 классы

Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа?

Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа.

Паскаль.

Ponamarevat1 6 сент. 2020 г., 10:47:57 | 5 - 9 классы

Вводятся два числа А и В (В> ; А)?

Вводятся два числа А и В (В> ; А).

Вывести на экран числа, которые делятся на 3, но не делятся на 5 и их количество.

(Паскаль).

Ученик2884 14 янв. 2020 г., 00:47:41 | 5 - 9 классы

Введите три числа a b c найдите сумму двух наибольших из них Пример ввода 6 4 9 Пример вывода 15 На паскале?

Введите три числа a b c найдите сумму двух наибольших из них Пример ввода 6 4 9 Пример вывода 15 На паскале.

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

Алина886980 6 дек. 2020 г., 14:00:50 | 10 - 11 классы

Нужна помощь ребят, в паскале нужно написать программу которая вводит 5 фамилий ( с клавиатуры) и выводит их в порядке возрастания?

Нужна помощь ребят, в паскале нужно написать программу которая вводит 5 фамилий ( с клавиатуры) и выводит их в порядке возрастания.

Вы зашли на страницу вопроса Помогите по Паскалю срочно?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.