Составьте пожалуйста программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты?

Информатика | 5 - 9 классы

Составьте пожалуйста программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты.

Результат выводится в строку.

В Pascal ABC.

Ответить на вопрос
Ответы (1)
Lizkalove89 30 авг. 2020 г., 17:29:23

Var

b : array[1.

5] of real ;

i : integer ;

begin

for i : = 1 to 5 do begin

write('Введите размер ', i, ' - го файла в байтах : ') ;

readln(a[i]) ;

end ;

for i : = 1 to 5 do

if a[i]> ; 1024 then a[i] : = a[i] / 1024 ;

for i : = 1 to 5 do

write(a[i] : 4 : 1) ;

end.

Natalyadedux 19 нояб. 2020 г., 19:01:27 | 5 - 9 классы

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты?

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты.

Результат выводится в строку.

Itiga 18 нояб. 2020 г., 13:01:11 | 5 - 9 классы

30 килобайт = байт 9 бит = байт 6 килобайт = бит 288 бит = байт 5242880 терабайт = килобайт?

30 килобайт = байт 9 бит = байт 6 килобайт = бит 288 бит = байт 5242880 терабайт = килобайт.

Nikimirzoev20 29 дек. 2020 г., 12:33:26 | 5 - 9 классы

После преобразования растрового 128 - цветного графического файла в 4 - хцветный формат его размер уменьшился на 50 байт?

После преобразования растрового 128 - цветного графического файла в 4 - хцветный формат его размер уменьшился на 50 байт.

Каков был размер исходного файла в байтах?

GlebovichPolinka 22 дек. 2020 г., 15:42:26 | 10 - 11 классы

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и ch?

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и chr).

Miheeva1997 6 сент. 2020 г., 01:13:56 | 1 - 4 классы

25 байт = ?

25 байт = .

Бит

30 килобайт = .

Байт

9 мегабайт.

Байт

6 килобайт.

Бит

288 бит.

Байт

5242880 терабайт.

Килобайт!

Помогите плиз!

Nurzhan111 2 мар. 2020 г., 22:47:13 | 10 - 11 классы

Помогите пожалуйста по С# Сишарп Дан размер файла в байтах?

Помогите пожалуйста по С# Сишарп Дан размер файла в байтах.

Используя операцию деления нацело, найти кол - во полных килобайтов, которые занимает данный файл (1килобайт = 1024байта).

Dakota002 13 мая 2020 г., 17:46:41 | 5 - 9 классы

Написать программу на с + + , которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей?

Написать программу на с + + , которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей.

Человечек12 23 янв. 2020 г., 03:49:52 | 5 - 9 классы

В массив вводят размеры n файлов (в байтах) от 100 до 9000?

В массив вводят размеры n файлов (в байтах) от 100 до 9000.

Преобразовать все значения превышающие 1024 байта в килобайты.

Сулим2005 14 окт. 2020 г., 21:11:40 | 5 - 9 классы

Переведите в килобайты 7168 байт?

Переведите в килобайты 7168 байт.

54мб.

27гб.

700000 байт.

Amilaev67 25 сент. 2020 г., 05:57:59 | 5 - 9 классы

Слово «неожиданно» может быть сохранено в файле размером байтов?

Слово «неожиданно» может быть сохранено в файле размером байтов.

Ответить!

На этой странице сайта вы найдете ответы на вопрос Составьте пожалуйста программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.