В массив вводят размеры n файлов (в байтах) от 100 до 9000?

Информатика | 5 - 9 классы

В массив вводят размеры n файлов (в байтах) от 100 до 9000.

Преобразовать все значения превышающие 1024 байта в килобайты.

Ответить на вопрос
Ответы (1)
Эльвиравик 23 янв. 2020 г., 03:49:53

Var a : array[1.

250] of string ; size : real ; i, n : integer ; text : string ;

begin writeln('daite N') ; readln(n) ; for i : = 1 to n do begin readln(size) ; if (size> ; 1024) or (size = 1024) then begin size : = size / 1024 ; str(size : 0 : 2, text) ; a[i] : = text + ' kb' ; text : = '' ; size : = 0 ; end else begin str(size, text) ; a[i] : = text + ' bytes' ; text : = '' ; size : = 0 ; end ; end ; for i : = 1 to n do write(a[i], ' ') ; readln ;

end.

Natalyadedux 19 нояб. 2020 г., 19:01:27 | 5 - 9 классы

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты?

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты.

Результат выводится в строку.

Itiga 18 нояб. 2020 г., 13:01:11 | 5 - 9 классы

30 килобайт = байт 9 бит = байт 6 килобайт = бит 288 бит = байт 5242880 терабайт = килобайт?

30 килобайт = байт 9 бит = байт 6 килобайт = бит 288 бит = байт 5242880 терабайт = килобайт.

Лолbich 18 июл. 2020 г., 23:44:27 | 5 - 9 классы

Скорость передачи данных через ADSL - соединение равно 9216 байт / с?

Скорость передачи данных через ADSL - соединение равно 9216 байт / с.

Передача файла через это соединение заняла 1 минуту.

Запишите размер файла в килобайтах.

Nikimirzoev20 29 дек. 2020 г., 12:33:26 | 5 - 9 классы

После преобразования растрового 128 - цветного графического файла в 4 - хцветный формат его размер уменьшился на 50 байт?

После преобразования растрового 128 - цветного графического файла в 4 - хцветный формат его размер уменьшился на 50 байт.

Каков был размер исходного файла в байтах?

Miheeva1997 6 сент. 2020 г., 01:13:56 | 1 - 4 классы

25 байт = ?

25 байт = .

Бит

30 килобайт = .

Байт

9 мегабайт.

Байт

6 килобайт.

Бит

288 бит.

Байт

5242880 терабайт.

Килобайт!

Помогите плиз!

Nurzhan111 2 мар. 2020 г., 22:47:13 | 10 - 11 классы

Помогите пожалуйста по С# Сишарп Дан размер файла в байтах?

Помогите пожалуйста по С# Сишарп Дан размер файла в байтах.

Используя операцию деления нацело, найти кол - во полных килобайтов, которые занимает данный файл (1килобайт = 1024байта).

Діма50 4 окт. 2020 г., 22:36:34 | 5 - 9 классы

Первый файл на 3 мегабайта больше, чем второй файл?

Первый файл на 3 мегабайта больше, чем второй файл.

Второй файл на 4096 байтов больше, чем третий файл.

На сколько килобайт третий файл меньше, чем первый?

В ответе укажите только число, слово "килобайт" писать не надо.

Dmitrievazheny 30 авг. 2020 г., 17:29:18 | 5 - 9 классы

Составьте пожалуйста программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты?

Составьте пожалуйста программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты.

Результат выводится в строку.

В Pascal ABC.

Сулим2005 14 окт. 2020 г., 21:11:40 | 5 - 9 классы

Переведите в килобайты 7168 байт?

Переведите в килобайты 7168 байт.

54мб.

27гб.

700000 байт.

Amilaev67 25 сент. 2020 г., 05:57:59 | 5 - 9 классы

Слово «неожиданно» может быть сохранено в файле размером байтов?

Слово «неожиданно» может быть сохранено в файле размером байтов.

Ответить!

На этой странице сайта размещен вопрос В массив вводят размеры n файлов (в байтах) от 100 до 9000? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.