Как в Pascal Abc сделать контроль ввода данных?

Информатика | 10 - 11 классы

Как в Pascal Abc сделать контроль ввода данных?

Так, что бы при вводе любого символа, кроме числа выдавало не ошибку, а говорила что "Введено не число" и возвращалось, чтоб заменить этот символ на цифру.

Ответить на вопрос
Ответы (1)
TeodorYT 25 дек. 2020 г., 21:40:31

Могу предложить такой вариант - в цикле repeat число вводится как строка и посимвольно проверяется.

Если введено неправильно - возвращает на ввод, если правильно - преобразует строку в число для дальнейшей работы.

Var a, err : integer ; s : string ; i : byte ; error : boolean ;

begin repeat error : = true ; writeln ('введите число') ; readln (s) ; for i : = 1 to length(s) do begin if (ord(s[i])< ; 48) or (ord(s[i])> ; 57) then begin error : = false ; writeln ('введено не число') ; break ; end end ; until error = true ; val(s, a, err) ; writeln ('введено число ', a) ;

end.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Пример :

введите число

12O

введено не число

введите число

120

введено число 120.

Rybyska 12 мар. 2020 г., 10:21:47 | 5 - 9 классы

1. С клавиатуры вводят слово и символ?

1. С клавиатуры вводят слово и символ.

Составьте программу , которая определяет позицию данного символа.

Алена160897 12 февр. 2020 г., 19:56:25 | 5 - 9 классы

Помогите сделать по информатике (СИМВОЛ : ?

Помогите сделать по информатике (СИМВОЛ : !

- как он вводится, и все остальные символы " № : % ; ?

* ( ) срочно нужно прямо сегодня и прямо сейчас.

Laisrem13 8 дек. 2020 г., 23:51:41 | 10 - 11 классы

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов)?

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов).

Evelinakotova 27 окт. 2020 г., 12:03:08 | 5 - 9 классы

Типы данных, условный оператор, операторы ввода / вывода, написать программу сложения 3 цифр, которые будут вводиться с клавиатуры?

Типы данных, условный оператор, операторы ввода / вывода, написать программу сложения 3 цифр, которые будут вводиться с клавиатуры.

(pascal abc).

ЭВАНЖЕЛИНКА 3 нояб. 2020 г., 19:28:30 | 10 - 11 классы

Pascal Вводится случайное число, вывести все цифры этого числа, которые встречаются в нем не менее двух раз?

Pascal Вводится случайное число, вывести все цифры этого числа, которые встречаются в нем не менее двух раз.

SofArkadiu 12 нояб. 2020 г., 19:12:02 | 5 - 9 классы

PASCAL ABC, программа?

PASCAL ABC, программа!

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

200287 10 авг. 2020 г., 20:28:44 | 5 - 9 классы

С клавиатуры вводится трехзначное число?

С клавиатуры вводится трехзначное число.

Вывести на экран удвоенную цифру единиц Pascal.

GlebovichPolinka 22 дек. 2020 г., 15:42:26 | 10 - 11 классы

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и ch?

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и chr).

Borzyy001 16 авг. 2020 г., 02:00:39 | 10 - 11 классы

Составить программу которая вводит с клавиатуры любое число от 150 до 255 и выводит символ соответствующий этому коду?

Составить программу которая вводит с клавиатуры любое число от 150 до 255 и выводит символ соответствующий этому коду.

Luneva281983 5 мая 2020 г., 18:59:18 | 5 - 9 классы

С клавиатуры вводится целое положительное число?

С клавиатуры вводится целое положительное число.

Определить, сколько в этом числе чётных цифр.

(PASCAL).

Вы открыли страницу вопроса Как в Pascal Abc сделать контроль ввода данных?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.