Даны три целых числа?

Информатика | 5 - 9 классы

Даны три целых числа.

Найти количество положительных и отрицательных в исходном наборе.

Ответить на вопрос
Ответы (1)
KatyufkaB 20 авг. 2020 г., 04:03:06

Если не разделять понятия неотрицательных и положительных, то этот код :

Var

A, B, C, P, O : integer ;

Begin

P : = 0 ;

O : = 0 ;

WriteLn('Введи три числа') ;

ReadLn(A, B, C) ;

if A> ; = 0 then P : = P + 1

else O : = O + 1 ;

if B> ; = 0 then P : = P + 1

else O : = O + 1 ;

if C> ; = 0 then P : = P + 1

else O : = O + 1 ;

WriteLn('Положительных чисел ', P) ;

WriteLn('Отрицательных чисел ', O)

End.

Если разделять, то этот :

Var A, B, C, P, O, N : integer ;

Begin

P : = 0 ;

O : = 0 ;

N : = 0 ;

WriteLn('Введи три числа') ;

ReadLn(A, B, C) ;

if A = 0 then N : = N + 1

else

if A> ; 0 then P : = P + 1

else O : = O + 1 ;

if B = 0 then N : = N + 1

else

if B> ; 0 then P : = P + 1

else O : = O + 1 ;

if C = 0 then N : = N + 1

else

if C> ; 0 then P : = P + 1

else O : = O + 1 ;

WriteLn('Положительных чисел ', P) ;

WriteLn('Отрицательных чисел ', O) ;

WriteLn('Нулей ', N)

End.

Marsikjane 21 янв. 2020 г., 13:29:52 | 5 - 9 классы

Pascal, задания на min max Дано целое число N и набор из N целых чисел?

Pascal, задания на min max Дано целое число N и набор из N целых чисел.

Найти количество элементов, расположенных после последнего максимального элемента.

Valeri2004 7 мар. 2020 г., 05:28:51 | 5 - 9 классы

Дан массив положительных и отрицательных чисел?

Дан массив положительных и отрицательных чисел.

Вывести количество положительных и отрицательных чисел, стоящих на нечетных местах.

Срочно!

Vikaclapps555 29 июн. 2020 г., 01:38:37 | 10 - 11 классы

ДАНЫ ЧИСЛА ОТ - 10 ДО 15?

ДАНЫ ЧИСЛА ОТ - 10 ДО 15.

НАЙТИ СУММУ ПОЛОЖИТЕЛЬНЫХ И ПРОИЗВЕДЕНИЕ ОТРИЦАТЕЛЬНЫХ.

ПОМОГИТЕ ПОЖАЛУУУУУЙСТА.

Mirysa230902 6 дек. 2020 г., 07:15:14 | 10 - 11 классы

Найти количество положительных и отрицательных элементов в одномерном массиве?

Найти количество положительных и отрицательных элементов в одномерном массиве.

RomkaNorin 12 янв. 2020 г., 18:29:51 | 5 - 9 классы

Пожалуйста решите на языке C + + : Series8?

Пожалуйста решите на языке C + + : Series8.

Дано целое число N и набор из N целых чисел.

Вывести в том же порядке все четные числа из данного набора и количество K таких чисел.

Enerhdu45gdhhd 25 июн. 2020 г., 09:45:52 | 10 - 11 классы

Нужно составить программу С + + , - даны действительные числа А1, А2?

Нужно составить программу С + + , - даны действительные числа А1, А2.

Аn и натуральный число n, n - количество чисел, найти сумму отрицательных и количество положительных членов последовательности.

Mahamusatova 29 дек. 2020 г., 20:31:57 | 10 - 11 классы

Пожалуйста, помогите?

Пожалуйста, помогите!

Срочно!

В ПАСКАЛЕ : 1) найти количество положительных целых чисел от 45 до 215 ; 2) Найти сумму положительных целых чисел от - 50 до 200, кратных 5 и 8 ; 3) Найти сумму и количество отрицательных четных целых чисел, введенных с клавиатуры.

Печать результата по вводу числа 0.

Altapkinpavel 19 сент. 2020 г., 14:24:41 | 10 - 11 классы

Дан массив?

Дан массив.

Нужно посчитать количество положительных и отрицательных элементов.

Юляффка12 17 дек. 2020 г., 15:18:27 | 5 - 9 классы

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел?

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел.

КонфФфета 19 окт. 2020 г., 17:22:51 | 10 - 11 классы

Дан массив целых чисел , определить в нем количество положительных и отрицательных?

Дан массив целых чисел , определить в нем количество положительных и отрицательных.

На этой странице находится вопрос Даны три целых числа?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.