Назовем число праздничным, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 6?

Информатика | 5 - 9 классы

Назовем число праздничным, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 6.

Найти сумму всех новогодних чисел.

Ответить на вопрос
Ответы (1)
Марианна47 13 июн. 2021 г., 17:02:26

/ / Dev - C + + 5.

11

#include < ; stdio.

H> ;

int main(void)

{long long int i, j, sum = 0, currsum, curr, flag ;

for(i = 6 ; i< ; = 111111 ; i + + ) {curr = i ; flag = 0 ; currsum = 0 ; while (curr!

= 0 & ; & ; flag = = 0) {if (curr%10 = = 0) flag = 1 ; else {currsum + = curr%10 ; curr / = 10 ; }} if(flag = = 0 & ; & ; currsum = = 6) sum + = i ; }

printf("%d", sum) ;

return 0 ; } / / Как - то слишком в лоб, но на скорую руку ничего в голову не приходит.

Nikita380856 7 февр. 2021 г., 01:24:30 | 5 - 9 классы

Найти сумму всех трехзначных чисел у которых вторая цифра равна 5?

Найти сумму всех трехзначных чисел у которых вторая цифра равна 5.

Отлиснник 21 апр. 2021 г., 16:47:44 | 10 - 11 классы

Назовем число новогодним, если его запись не содержит цифры 0, а сумма всех цифр равна 8?

Назовем число новогодним, если его запись не содержит цифры 0, а сумма всех цифр равна 8.

Найти сумму всех чисел.

Bogdan1143 1 июн. 2021 г., 03:13:18 | 10 - 11 классы

С клавиатуры вводятся два трехзначных числа ?

С клавиатуры вводятся два трехзначных числа .

Выяснить , образуют ли сумма цифр сотен, сумма цифр десятков , сумма цифр единиц введенных чисел убывающую последовательность.

14031987 25 авг. 2021 г., 07:20:11 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Найти сумму и произведение его цифр.

Число 28.

Дарья3471 11 авг. 2021 г., 06:17:32 | 10 - 11 классы

Назовем число новогодним, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 8?

Назовем число новогодним, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 8.

Найти сумму всех новогодних чисел.

Boskolya 1 авг. 2021 г., 09:33:19 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Назовём число новогодним, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 8.

Найти сумму всех новогодних чисел.

Tima8866 21 июн. 2021 г., 05:58:15 | 5 - 9 классы

Назовем число новогодним, если его запись не содержит цифры 0, а сумма всех цифр равна 7?

Назовем число новогодним, если его запись не содержит цифры 0, а сумма всех цифр равна 7.

Найти сумму всех чисел.

Азя1111 27 июн. 2021 г., 11:33:58 | 5 - 9 классы

Из чисел от 10 до 99 вывести те, сумма цифр которых равна S(0 < S < 18)?

Из чисел от 10 до 99 вывести те, сумма цифр которых равна S(0 < S < 18).

{Обозначим : k - это просматриваемое число ; p1 - это первая цифра числа k, р2 - это вторая цифра числа k ; s - это сумма цифр данного числа k.

Число k будем выписывать только в том случае, когда сумма p1 и р2 будет равна s.

}

PASCAL ABC.

Ddvpenza 10 мая 2021 г., 11:28:20 | 5 - 9 классы

Среди всех двузначных чисел указать те, сумма цифр которых равна числу К?

Среди всех двузначных чисел указать те, сумма цифр которых равна числу К.

Irisha9294 17 мая 2021 г., 20:36:23 | 10 - 11 классы

Составить программу в Pascal :Найти все трехзначные числа, обладающие следующими свойствами : - сумма цифр числа А делится на 4 ; - сумма цифр числа А + 2 также делится на 4?

Составить программу в Pascal :

Найти все трехзначные числа, обладающие следующими свойствами : - сумма цифр числа А делится на 4 ; - сумма цифр числа А + 2 также делится на 4.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Назовем число праздничным, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 6?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.