Из чисел от 10 до 99 вывести те, сумма цифр которых равна S(0 < S < 18)?

Информатика | 5 - 9 классы

Из чисел от 10 до 99 вывести те, сумма цифр которых равна S(0 < S < 18).

{Обозначим : k - это просматриваемое число ; p1 - это первая цифра числа k, р2 - это вторая цифра числа k ; s - это сумма цифр данного числа k.

Число k будем выписывать только в том случае, когда сумма p1 и р2 будет равна s.

}

PASCAL ABC.

Ответить на вопрос
Ответы (1)
Ден2710 27 июн. 2021 г., 11:34:03

Var i, s : integer ;

begin write('s = ') ; readln(s) ; if s.

Лена638 13 июн. 2021 г., 17:02:25 | 5 - 9 классы

Назовем число праздничным, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 6?

Назовем число праздничным, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 6.

Найти сумму всех новогодних чисел.

Наташа384 24 янв. 2021 г., 10:44:40 | 10 - 11 классы

Написать функцию для нахождения суммы цифр целого числа Используя эту функцию, вывести на экран : 1)трехзначные нечетные числа, суммы цифр которых кратна 8 ; 2)те из n введенных с клавиатуры целых чис?

Написать функцию для нахождения суммы цифр целого числа Используя эту функцию, вывести на экран : 1)трехзначные нечетные числа, суммы цифр которых кратна 8 ; 2)те из n введенных с клавиатуры целых чисел, сумма цифр которых больше десяти.

Sonikpanasonik33 26 мая 2021 г., 11:04:28 | 10 - 11 классы

Дано n натуральное?

Дано n натуральное.

Найти и вывести все числа в интервале от 10 до n - 1, у которых произведение всех цифр совпадает с суммой цифр данного числа.

Если таких чисел нет вывести "Нет".

Паскаль.

Iskandarian 24 июл. 2021 г., 01:44:50 | 5 - 9 классы

Программа в Pascal ABC : Дано натуральное число?

Программа в Pascal ABC : Дано натуральное число.

Определить : а) количество цифр в нем ; б) сумму его цифр ; б) сумму квадратов его цифр.

Дарья3471 11 авг. 2021 г., 06:17:32 | 10 - 11 классы

Назовем число новогодним, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 8?

Назовем число новогодним, если его запись не содержит цифры 0, а сумма всех цифр этого числа равна 8.

Найти сумму всех новогодних чисел.

Lenica777 17 мар. 2021 г., 21:43:46 | 10 - 11 классы

На языке программирования?

На языке программирования.

Даны два двухзначных числа определить у кого сумма цифр больше.

Вывести это число.

Ddvpenza 10 мая 2021 г., 11:28:20 | 5 - 9 классы

Среди всех двузначных чисел указать те, сумма цифр которых равна числу К?

Среди всех двузначных чисел указать те, сумма цифр которых равна числу К.

Arslan12342 4 окт. 2021 г., 23:14:59 | 5 - 9 классы

1 Дано трехзначное число?

1 Дано трехзначное число.

Определить какая из его цифр больше первая или вторая.

2 Дано четырехзначное число.

Определить кратна ли 3 сумма его цифр.

Это по Информатике.

В паскале.

Пж срочно.

Tereshkovavika 5 сент. 2021 г., 21:18:35 | 5 - 9 классы

Помогите составить программу в Pascal ABC ?

Помогите составить программу в Pascal ABC !

Дано натуральное число

1)Программа, которая находит сумму цифр этого числа

2)которая определяет, что число начинается и заканчивается одной и той же цифрой.

Ира448 10 апр. 2021 г., 14:57:52 | 10 - 11 классы

Буду очень благодарна за помощь?

Буду очень благодарна за помощь!

1)Вводятся натуральные числа, не превосходящие N.

Вычислить произведение всех чисел, кратных 6.

2) Вывести все трехзначные числа, в которых сумма первых двух цифр равна сумме двух последних цифр.

Вы открыли страницу вопроса Из чисел от 10 до 99 вывести те, сумма цифр которых равна S(0 < S < 18)?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.