Написать программу, которая на вход получает два целых числа и определяет делится ли одно на другое нацело?

Информатика | 5 - 9 классы

Написать программу, которая на вход получает два целых числа и определяет делится ли одно на другое нацело.

На выходе программа печатает False, если числа не делятся нацело и результат деления иначе.

Все в паскале.

Ответить на вопрос
Ответы (1)
Buryata484 9 мар. 2020 г., 03:08:44

Var a, b : integer ;

begin

write('a = ') ; readln(a) ;

write('b = ') ; readln(b) ;

if a mod b = 0

then writeln(a, ' / ', b, ' = ', a div b)

else writeln(a mod b = 0) ;

end.

Пример 1 :

a = 20

b = 5

20 / 5 = 4

Пример 2 :

a = 20

b = 6

False.

Svetlana3012642 23 дек. 2020 г., 01:36:59 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.

Программа получает на вход целые числа, количество введенных данных неизвестно, последовательность чисел заканчивается числом 0.

На Паскале.

Jenyaaa1999 20 дек. 2020 г., 09:51:05 | 10 - 11 классы

Дано целое число N (> ; 0)?

Дано целое число N (> ; 0).

Используя операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр.

Решить в паскале.

Написать программу от начала до конца.

Napalkoff 10 дек. 2020 г., 11:31:45 | 10 - 11 классы

Заданы 2 целых числа?

Заданы 2 целых числа.

Напечатать, делится ли большее на меньшее нацело.

123456789макимаки 30 июн. 2020 г., 09:43:43 | 10 - 11 классы

Написать программу?

Написать программу.

Задано натуральное число.

Определить делится ли оно на два.

Примечание : проверка делимости на 2 осуществляется следующим образом : пусть N - натуральное число.

Если N / 2 = N \ 2, то число делится на 2, иначе нет.

(N / 2 - обычное деление, N \ 2 - деление нацело).

Mkaterinae 25 нояб. 2020 г., 17:22:59 | 5 - 9 классы

Напечатать минимальное число больше 200, которое нацело делится на 17?

Напечатать минимальное число больше 200, которое нацело делится на 17.

ANUBISS 17 февр. 2020 г., 06:59:22 | 10 - 11 классы

C + + как записать эту программу?

C + + как записать эту программу?

Напишите функцию bool f(int x, int y), которая возвращает true, если x делится нацело на y, или наоборот, y делится нацело на x, иначе возвращает false.

Предполагается, что значения параметров больше нуля.

EKG55556 29 авг. 2020 г., 11:28:24 | 5 - 9 классы

Написать программу на паскале, по которой можно было узнать делится ли число на 5 без остатка и на 4 без остатка?

Написать программу на паскале, по которой можно было узнать делится ли число на 5 без остатка и на 4 без остатка.

Vredina1995 29 нояб. 2020 г., 09:48:52 | 10 - 11 классы

Даны два натуральных числа n и m ?

Даны два натуральных числа n и m .

Если одно из них делится на другое нацело , вывести 1 , иначе вывести любое другое целое число.

Нужно сделать на python.

Natasha02 19 дек. 2020 г., 02:53:05 | 10 - 11 классы

Написать программу, которая печатает значение логического выражения (TRUE или FALSE)в Паскале : Первая и последняя цифры трехзначного числа равны?

Написать программу, которая печатает значение логического выражения (TRUE или FALSE)в Паскале : Первая и последняя цифры трехзначного числа равны.

Plinkca 27 сент. 2020 г., 01:31:15 | 5 - 9 классы

Написать программу которая задумывает число и печатает его наоборот?

Написать программу которая задумывает число и печатает его наоборот.

( пример : 341 и 143) в паскаль.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Написать программу, которая на вход получает два целых числа и определяет делится ли одно на другое нацело?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.