1) Вводится три числа?

Информатика | 5 - 9 классы

1) Вводится три числа.

Найти среднее арифметическое и вывести его.

2) вводится три числа.

Найти сумму четных чисел.

3) Вводится три числа, найти среднее арифметическое число максимального, минимального элемента.

( Оформить все правильно, со знакамИ, точками с запятой и т.

Д).

Ответить на вопрос
Ответы (1)
Лена63123 9 апр. 2020 г., 04:15:21

1)

var a, b, c : integer ; sr : real ;

begin

write('a = ') ; readln(a) ;

write('b = ') ; readln(b) ;

write('c = ') ; readln(c) ;

sr : = (a + b + c) / 3 ;

writeln('Среднее арифметическое = ', sr) ;

end.

Пример :

a = 5

b = 2

c = 8

Среднее арифметическое = 5

2)

var a, b, c, s : integer ;

begin

write('a = ') ; readln(a) ;

write('b = ') ; readln(b) ;

write('c = ') ; readln(c) ;

s : = 0 ;

if a mod 2 = 0 then s : = s + a ;

if b mod 2 = 0 then s : = s + b ;

if c mod 2 = 0 then s : = s + c ;

writeln('Сумма четных чисел = ', s) ;

end.

Пример :

a = 8

b = 5

c = 2

Сумма четных чисел = 10

3)

var a, b, c, max, min : integer ;

begin

write('a = ') ; readln(a) ;

write('b = ') ; readln(b) ;

write('c = ') ; readln(c) ;

if a> ; b then max : = a else max : = b ;

if c> ; max then max : = c ;

if a< ; b then min : = a else min : = b ;

if c< ; min then min : = c ;

writeln('max = ', max, ' min = ', min, ' Среднее = ', (max + min) / 2) ;

end.

Пример :

a = 5

b = 2

c = 8

max = 8 min = 2 Среднее = 5.

ШХС 24 апр. 2020 г., 02:02:21 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

: ) Последовательно вводятся N целых чисел.

Найти среднее арифметическое этих чисел.

Татьяна821 22 окт. 2020 г., 01:31:31 | 10 - 11 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти минимальное и максимальное число и вычислить их среднее арифметическое.

Иииааа 9 янв. 2020 г., 18:20:47 | 10 - 11 классы

Помогите, пожалуйста, с задачей по программированию?

Помогите, пожалуйста, с задачей по программированию.

С клавиатуры вводится неограниченная последовательность чисел.

Ввод последовательности заканчивается 0.

Найти максимальное и минимальное число этой последовательности.

Diana20050111 15 окт. 2020 г., 06:11:03 | 5 - 9 классы

Найти среднее арифметическое чисел от 1 до N, N - вводит пользователь?

Найти среднее арифметическое чисел от 1 до N, N - вводит пользователь.

Ilimavtovaz 6 февр. 2020 г., 04:57:11 | 5 - 9 классы

Массив А вводится с клавиатуры?

Массив А вводится с клавиатуры.

Найти среднее арифметическое его элементов с нечетными номерами.

Размер вводим с клавиатуры (< ; = 20).

Kirilacs 21 янв. 2020 г., 18:21:52 | 10 - 11 классы

1. пользователь вводит натуральное число?

1. пользователь вводит натуральное число.

Определить среднее арифметическое цифр этого числа.

2. пользователь вводит натуральное число N.

Найти сумму всех натуральных чисел от 1 до N.

Валерия123123 20 июл. 2020 г., 11:14:21 | 10 - 11 классы

С клавиатуры вводятся 3 числа?

С клавиатуры вводятся 3 числа.

Найти количество и сумму четных чисел среди них.

Если среди введенных четных нет, то вывести соответствующее сообщение.

RAW2002 12 февр. 2020 г., 05:22:29 | 10 - 11 классы

Очень прошу помогите с Паскалем?

Очень прошу помогите с Паскалем!

) Натуральное число вводятся с клавиатуры до тех пор, пока не будет введено число 0.

Найти среднее арифметическое введенных чисел, а также максимальное минимальное значение.

Изобразить графически алгоритм и напишите программу для решения этой задачи.

Olegro123 27 дек. 2020 г., 18:16:16 | 5 - 9 классы

С клавиатуры вводится целое число N?

С клавиатуры вводится целое число N.

Затем вводится N целых чисел.

Перед вводом каждого из чисел должно появляться сообщение вида "Введите i - е число", где i - номер очередного числа.

Найдите среднее арифметическое вводимых чисел.

ТошаКотов 4 нояб. 2020 г., 06:42:34 | 1 - 4 классы

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО?

Вводится натуральное число n требуется найти сумму четных цифр числа 2) найти количество цифр 2 в числе 3) найти максимальную нечетную цифру в числе ПАСКАЛЬ СРОЧНО!

Перед вами страница с вопросом 1) Вводится три числа?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.