Помогите с алгоритмом?

Информатика | 10 - 11 классы

Помогите с алгоритмом.

Написать программу сложения пяти переменных каждая из которых может принимать или числовое значение или строковое.

Программа должна отдельно просуммировать числа среди этих переменных и отдельно строки.

Ответить на вопрос
Ответы (2)
Шико2 28 мая 2020 г., 21:35:45

Текст на VBA (Microsoft Excel из состава Office 2003)

Sub aaa() a = Range("A1 : A5") sn = 0 : ss = "" For Each e In a If IsNumeric(e) Then sn = sn + e Else ss = ss + e End If Next Cells(7, 2) = sn Cells(8, 2) = ss

End Sub

Во вложении приведен вид листа рабочей книги после выполнения тестового решения.

Olegvavilov20 28 мая 2020 г., 21:35:46

{На самом деле они все строковые, но так как некоторые можно преобразовать в числовому значению, можно, я думаю, об этом забыть.

Если мне покажут какой - то смежный тип(не char!

), я буду крайне благодарен} / / Pascal ABC.

NET 3.

1 сборка 1256

Const

n = 5 ;

Var

i, k : integer ;

r : real ;

rs : string ;

arsom : array[1.

N] of string ;

se : set of char ;

begin

se : = ['0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '.

', ' - '] ;

k : = 0 ;

for i : = 1 to n do

begin readln(arsom[i]) ; foreach var x in arsom[i] do if x in se then inc(k) ; if k = length(arsom[i]) then r + = strtofloat(arsom[i]) else rs + = arsom[i] ; k : = 0 ;

end ;

writeln('Сумма чисел : ', r) ;

write('Сумма строк : ', rs) ;

end.

Пример ввода : - 1.

1

Sample

2

text

1.

2

Пример вывода :

Сумма чисел : 2.

1

Сумма строк : Sample text.

Kos382 30 июл. 2020 г., 13:17:51 | 5 - 9 классы

Переменные – это : величины, которые могут менять свое значение в процессе выполнения программы величины, которые не могут менять своего значения в процессе выполнения программы обозначают строки прог?

Переменные – это : величины, которые могут менять свое значение в процессе выполнения программы величины, которые не могут менять своего значения в процессе выполнения программы обозначают строки программы, на которые передается управление во время выполнение программы Верного ответа нет.

Bsbannerok 7 дек. 2020 г., 15:41:03 | 1 - 4 классы

Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые?

Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые.

Даны три переменные вещественного типа : A, B, C.

Если их значения упорядочены по возрастанию или убыванию, то удвоить их ; в противном случае заменить значение каждой переменной на противоположное.

Вывести новые значения переменных A, B, C.

Izon836 24 февр. 2020 г., 01:30:25 | 1 - 4 классы

Написать программу, которая меняет знак у значения переменной R?

Написать программу, которая меняет знак у значения переменной R.

Romodo 26 июл. 2020 г., 20:36:37 | 10 - 11 классы

Напишите программу, которая вводит значение трёх переменных и выводит их произведение?

Напишите программу, которая вводит значение трёх переменных и выводит их произведение.

Ввод каждого значения производится с отдельной строки.

Danja97 3 апр. 2020 г., 06:26:22 | 5 - 9 классы

Составьте программу, которая считывает с клавиатуры значения переменных а и b, затем меняет между собой значения этих переменных и выводит их на экран, без использования третьей переменной?

Составьте программу, которая считывает с клавиатуры значения переменных а и b, затем меняет между собой значения этих переменных и выводит их на экран, без использования третьей переменной.

Donya1911 3 февр. 2020 г., 00:11:01 | 10 - 11 классы

Напишите программу , которая запрашивает значения четырех переменных (A, B, C, D) типа integer и выводит их сумму?

Напишите программу , которая запрашивает значения четырех переменных (A, B, C, D) типа integer и выводит их сумму.

Ввод первой пары значений (A, B) произведите на одной строке , ввод другой пары.

(C, D) ; на другой строке.

Результат выведите на отдельную строку и курсор оставьте на той же строке.

Эту рограмму надо написать на языке pascal.

Ника880 7 нояб. 2020 г., 08:48:12 | 5 - 9 классы

Написать программу в паскале Даны две переменных с некоторыми значениями?

Написать программу в паскале Даны две переменных с некоторыми значениями.

Поменять местами значения этих переменных.

Матрин1 22 июл. 2020 г., 03:16:26 | 5 - 9 классы

1. напишите программу которая вводит значения 3 переменных a и b с приглашениями к ввожу каждой переменной и выводит их разность?

1. напишите программу которая вводит значения 3 переменных a и b с приглашениями к ввожу каждой переменной и выводит их разность.

Приглашение и ввод каждого значения произвести в отдельных строках.

Ввод сопроводить пояснениями.

2. Нипишите программу ввода значений A, B, C в одной строке и выведите результат выражения A * (B / 3, 14) + (C * 3) в отдельной строке.

3. написать программу а : = 5 ; b : = 6 найти : сумму, разность, частное и произведение.

Mashynia2013 8 нояб. 2020 г., 23:09:48 | 1 - 4 классы

Написать программу, с помощью которой робот может попасть в точку Б, если длины этих стен не известны Для каждого лабиринта, написать отдельную программу?

Написать программу, с помощью которой робот может попасть в точку Б, если длины этих стен не известны Для каждого лабиринта, написать отдельную программу.

Ayanalken 28 окт. 2020 г., 22:54:58 | 5 - 9 классы

Написать программу нахождения наибольшего значения их пяти переменных?

Написать программу нахождения наибольшего значения их пяти переменных.

На этой странице сайта вы найдете ответы на вопрос Помогите с алгоритмом?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.