Var x, L, M : integer ; begin readln(x) ; L : = x - 16 ; M : = x + 16 ; while L < ; > ; M do if L > ; M then L : = L - M else M : = M – L ; writeln(M) ; end?

Информатика | 10 - 11 классы

Var x, L, M : integer ; begin readln(x) ; L : = x - 16 ; M : = x + 16 ; while L < ; > ; M do if L > ; M then L : = L - M else M : = M – L ; writeln(M) ; end.

20 (№ 424) Ниже записан алгоритм.

Получив на вход число x, этот алгоритм печатает число M.

Известно, что x > ; 100.

Укажите наименьшее такое (т.

Е. большее 100) число x, при вводе которого алгоритм печатает 16.

Ответить на вопрос
Ответы (1)
Шник 27 февр. 2020 г., 04:29:47

В данной программе реализуется алгоритм поиска наибольшего общего делителя двух чисел (L иM).

При этом M большеL на 32, а наибольший делитель чиселравен 16.

Первое число > ; 100, кратное 16 - это 112, но наибольший общий делитель чисел 112 - 16 и 112 + 16 (96 и 128) равен 32.

Следующее число, кратное 16 - это 128.

Наибольший общий делитель 128 - 16 и 128 + 16 (112 и 144) = 16.

Ответ : 128.

08041982 19 мар. 2020 г., 10:40:00 | 10 - 11 классы

Ниже записан алгоритм?

Ниже записан алгоритм.

Получив на вход число х, этот алгоритм печатает два числа L и M.

Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.

Var х, L, M : integer ;

begin

readln (x) ;

L : = 0 ; M : = 1 ;

while x> ; 0 do

begin

L : = L + 1 ;

M : = M * (x mod 8) ;

х : = x div 8 ;

end ;

writeln(L) ; write(M) ;

end.

Mstanyatn 13 мая 2020 г., 20:23:49 | 10 - 11 классы

Получив на вход число х , этот алгоритм печатает два числа а и b?

Получив на вход число х , этот алгоритм печатает два числа а и b.

Скажите наибольшее из таких чисел х , при вводе которых алгоритм печатает сначала 2 потом 63

din x, a, b as integer

input x

a = 0 : b = 1

while x> ; 0

a = a + 1

b = b * (x mod 10)

x = x \ 10

wend

print a

print b.

Hdbvd 26 мая 2020 г., 01:21:08 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа, L и M.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 ; if (M< ; x) and (x mod 2 = 0) then begin M : = x mod 10 ; end ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Egorchugunov 2 мая 2020 г., 08:11:51 | 10 - 11 классы

Получив на вход число х , этот алгоритм печатает два числа а и b?

Получив на вход число х , этот алгоритм печатает два числа а и b.

Скажите наибольшее из таких чисел х , при вводе которых алгоритм печатает сначала 2 потом 63

din x, a, b as integer

input x

a = 0 : b = 1

while x> ; 0

a = a + 1

b = b * (x mod 10)

x = x \ 10

wend

print a

print b.

Ulka8 20 февр. 2020 г., 05:17:15 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО?

ПОМОГИТЕ СРОЧНО!

Ниже написана программа.

Получив на вход число x, эта программа печатает два числа, a и b.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 9.

ПОЖАЛУЙСТА С РЕШЕНИЕМ!

Var x, a, b : integer ; begin readln (x) ; a : = 0 ; b : = 1 ; while x > ; 0 do begin a : = a + 1 ; b : = b * (x mod 5) ; x : = x div 5 ; end ; writeln (a) ; write (b) ; end.

Robert777 10 апр. 2020 г., 01:30:01 | 10 - 11 классы

Пожалуйста, помогите?

Пожалуйста, помогите!

Не понимаю даже, как к заданию подступиться.

На языке программирования Паскаль написан текст программы.

Получив на вход число x, этот алгоритм печатает два числа a и b.

Укажите наименьшее из таких чисел x, при котрых алгоритм печатает сначала 3, а потом 7.

​var x, a, b : integer ; begin ​readln(x) ; ​a : = 0 ; b : = 0 ; ​while x> ; 0 do ​begin ​a : = a + 1 ; ​b : = b + (x mod 10) ; ​x : = x div 10 ; ​end ; ​writeln(a) ; write(b) ; end.

Fityuzka 24 янв. 2020 г., 07:56:14 | 10 - 11 классы

Получив на вход число x, этот алгоритм печатает число M?

Получив на вход число x, этот алгоритм печатает число M.

Известно, что x > ; 100.

Укажите наименьшее такое (т.

Е. большее 100) число x, при вводе которого алгоритм печатает 2.

Var x, L, M : integer ; begin readln(x) ; L : = x - 12 ; M : = x + 12 ; while L < ; > ; M do if L > ; M then L : = L - M else M : = M – L ; writeln(M) ; end.

Ответ нужен с пояснением плиииззз.

ЭммаМяф 8 февр. 2020 г., 20:31:35 | 10 - 11 классы

56) Получив на вход число х, этот алгоритм печатает два числа a и b?

56) Получив на вход число х, этот алгоритм печатает два числа a и b.

Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 2, а потом 15.

Var x, a, b : integer ; begin readln(x) ; a : = 0 ; b : = 0 ; while x > ; 0 do begin a : = a + 1 ; b : = b + (x mod 100) ; x : = x div 100 ; end ; writeln(a) ; write(b) ; end.

Ольгамясникова678930 6 апр. 2020 г., 19:41:35 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа.

Укажите набольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 24.

Var x, a, b : integer ; begin readln(x) ; a : = 0 ; b : = 1 ; while x > ; 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ; end.

Emelyanovadasha 12 мая 2020 г., 12:15:14 | 10 - 11 классы

Ниже записан алгоритм?

Ниже записан алгоритм.

Получив на вход число X, этот алгоритм печатает два числа : a и b.

Укажите наименьшее из таких чисел X при вводе которого алгоритм печатает сначала 15, а потом 7.

Паскаль var x, a, b, k : integer ; begin readln(x) ; a : = 0 ; b : = 10 ; while x> ; 0 do begin k : = x mod 10 ; a : = a + k ; If k< ; b : = k ; x : = x div 10 end ; writeln(a) ; writeln(b) ; end.

Вопрос Var x, L, M : integer ; begin readln(x) ; L : = x - 16 ; M : = x + 16 ; while L &lt ; &gt ; M do if L &gt ; M then L : = L - M else M : = M – L ; writeln(M) ; end?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.