У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем?

Информатика | 5 - 9 классы

У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем?

Ответить на вопрос
Ответы (1)
Люба4922 26 нояб. 2020 г., 19:51:29

Задачу можно решать различными способами.

Можно рассуждениями - вычислениями, а можно просто написать программу, в которой вычисляется нужное значение :

var i, a, s, k : integer ;

begin

k : = 0 ;

for i : = 1 to 1024 do

begin

a : = i ; s : = 0 ;

while a< ; > ; 0 do begin s : = s + a mod 10 ; a : = a div 10 ; end ;

if s mod 4 = 0 then k : = k + 1 ;

end ;

writeln('k = ', k) ;

end.

Результат :

k = 253.

Stasevanne26 5 янв. 2020 г., 18:55:45 | 5 - 9 классы

Среди четырёхзначных чисел найти все числа сумма цифр, которых кратно 3 и больше 15?

Среди четырёхзначных чисел найти все числа сумма цифр, которых кратно 3 и больше 15.

Jmjmjmjmj500 27 февр. 2020 г., 16:12:32 | 10 - 11 классы

Дан массив натуральных чисел ?

Дан массив натуральных чисел .

Найти сумму элементов , кратных заданному К.

Полина0801 10 сент. 2020 г., 09:16:48 | 5 - 9 классы

Среди всех натуральных четырехзначных чисел подсчитать количество таких, сумма квадратов цифр, которых кратна двум или трем?

Среди всех натуральных четырехзначных чисел подсчитать количество таких, сумма квадратов цифр, которых кратна двум или трем.

Ответ дайте целым числом.

01алим 13 нояб. 2020 г., 16:18:54 | 10 - 11 классы

Составить программу вычисления суммы и произведения натуральных чисел кратных 9 Очень надо?

Составить программу вычисления суммы и произведения натуральных чисел кратных 9 Очень надо!

Polyagrig 9 февр. 2020 г., 09:02:45 | 5 - 9 классы

Дано четырехзначное натуральное число?

Дано четырехзначное натуральное число.

Определить является ли сумма первой и последней цифр кратной 3 Паскаль.

Naonna 15 июн. 2020 г., 22:43:47 | 10 - 11 классы

Среди всех натуральных чентырехзначных чисел подсчитать кол - во таких, сумма квадратов цифр, которых кратна двум или трем?

Среди всех натуральных чентырехзначных чисел подсчитать кол - во таких, сумма квадратов цифр, которых кратна двум или трем.

Madina57 20 мар. 2020 г., 06:06:40 | 10 - 11 классы

Среди всех натуральных четырехзначных чиселподсчитать количество таких,сумма квадратов цифр которыхкратна двум или трем?

Среди всех натуральных четырехзначных чисел

подсчитать количество таких,

сумма квадратов цифр которых

кратна двум или трем.

Ответ записать целым числом.

190596 26 сент. 2020 г., 06:43:45 | 5 - 9 классы

У скольких натуральных чисел от 1 до 2 в степени 12 сумма цифр кратна четырем?

У скольких натуральных чисел от 1 до 2 в степени 12 сумма цифр кратна четырем?

Миха7979 3 июн. 2020 г., 18:28:25 | 5 - 9 классы

Напишите программу пожалуйста В последовательности натуральных чисел определить сумму чисел кратных 5?

Напишите программу пожалуйста В последовательности натуральных чисел определить сумму чисел кратных 5.

Ltarieva06 10 янв. 2020 г., 12:20:13 | 5 - 9 классы

Составить программу которая выводит на экран сумму n первых натуральных чисел , кратных 3?

Составить программу которая выводит на экран сумму n первых натуральных чисел , кратных 3.

Вы перешли к вопросу У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.