Pascal 1?

Информатика | 5 - 9 классы

Pascal 1.

Найти среднее арифметическое положительных элементов одномерного массива.

2. Найти минимальный элемент одномерного массива.

Ответить на вопрос
Ответы (1)
Aslansovetov 6 нояб. 2020 г., 19:51:19

1. Современное решение / / PascalABC.

NET 3.

2, сборка 1356 от 04.

12. 2016 / / Внимание!

Если программа не работает, обновите версию!

Begin var a : = ArrRandom(ReadInteger('n = '), - 50, 50) ; a.

Println ; Writeln('Среднее положительных ', a.

Where(x - > ; x> ; 0).

Average) ; Writeln('Минимум ', a.

Min)

end.

Пример

n = 15

35 27 - 7 - 1 20 13 6 50 - 9 23 - 38 46 30 27 14

Среднее положительных 26.

4545454545455

Минимум - 38

2.

Школьный вариант на древних версиях

program Ex1 ;

const nn = 100 ; { ограничение на длину массива }

var i, n, s, k : integer ; a : array[1.

Nn] of integer ;

begin Randomize ; Write('n = ') ; Read(n) ; k : = 0 ; for i : = 1 to n do begin a[i] : = Random(101) - 50 ; Write(a[i], ' ') ; if a[i]> ; 0 then begin k : = k + 1 ; s : = s + a[i] end end ; Writeln ; Writeln('Среднее положительных ', s / k)

end.

Program Ex2 ;

const nn = 100 ; { ограничение на длину массива }

var i, n, min : integer ; a : array[1.

Nn] of integer ;

begin Randomize ; Write('n = ') ; Read(n) ; min : = 100 ; { больше максимально возможного } for i : = 1 to n do begin a[i] : = Random(101) - 50 ; Write(a[i], ' ') ; if a[i]< ; min then min : = a[i] end ; Writeln ; Writeln('Минимум ', min)

end.

Выводы о том, чему и как учат в школе, делайте самостоятельно.

Saalaus 17 апр. 2020 г., 21:09:47 | 10 - 11 классы

Найти среднее арифметическое всех положительных элементов одномерного массива?

Найти среднее арифметическое всех положительных элементов одномерного массива.

В Delphi.

Mirysa230902 6 дек. 2020 г., 07:15:14 | 10 - 11 классы

Найти количество положительных и отрицательных элементов в одномерном массиве?

Найти количество положительных и отрицательных элементов в одномерном массиве.

Mariusik 22 июн. 2020 г., 23:41:38 | 5 - 9 классы

Как сложить все элементы одномерного массива в Pascal?

Как сложить все элементы одномерного массива в Pascal?

Aigami192001 19 мар. 2020 г., 23:04:44 | 10 - 11 классы

Найти в одномерном массиве А10 количество положительных элементов, кратных трём?

Найти в одномерном массиве А10 количество положительных элементов, кратных трём.

Таантя 26 сент. 2020 г., 19:41:16 | 5 - 9 классы

1. Дан одномерный массив из N элементов?

1. Дан одномерный массив из N элементов.

Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2.

Дан одномерный массив из Н элементов.

Найти среднее арифметическое положительных четных элементов данного массива.

Vikavizsa 13 сент. 2020 г., 02:37:20 | 10 - 11 классы

В одномерном массиве от нуля до 10 заполненный случайным образом найти среднее арифметическое элементов массива?

В одномерном массиве от нуля до 10 заполненный случайным образом найти среднее арифметическое элементов массива.

Krimordvinova8 29 янв. 2020 г., 05:06:08 | 10 - 11 классы

Найти среднее арифметическое элементов одномерного массива А10?

Найти среднее арифметическое элементов одномерного массива А10.

Составить программу.

Mint2009 19 дек. 2020 г., 18:48:29 | 10 - 11 классы

Дан одномерный массив, состоящий из 20 элементов?

Дан одномерный массив, состоящий из 20 элементов.

Найти сумму элементов массива, принадлежащих промежутку от А до В PASCAL.

Dracula666 4 нояб. 2020 г., 05:05:36 | 10 - 11 классы

Заполнить матрицу А 5х5 случайными числами до 20 и далее выполнить задание : 1?

Заполнить матрицу А 5х5 случайными числами до 20 и далее выполнить задание : 1.

Найти максимальный элемент на побочной диагонали ; 2.

Составить одномерный массив В из минимальных элементов каждой строки ; 3.

В одномерном массиве В найти среднее арифметическое и вывести на экран элементы массива В, которые больше среднего арифметического.

Artem1918 1 янв. 2020 г., 05:23:47 | 10 - 11 классы

Создать два одномерных массива, состоящих из целых чисел?

Создать два одномерных массива, состоящих из целых чисел.

Элементы массива вводятся с клавиатуры.

В первом массиве найти номер первого нечетного элемента массива.

Во втором массиве найти первый четный элемент массива.

Решить на Pascal ABC (При решении задач обязательно использовать одномерные массивы и процедуры или функции работы с одномерными массивами.

).

На этой странице сайта вы найдете ответы на вопрос Pascal 1?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.