Дан массив из n целых чисел?

Информатика | 5 - 9 классы

Дан массив из n целых чисел.

Составить алгоритм, определяющий номера всех нулевых элементов и их количество.

Ответить на вопрос
Ответы (1)
Swift29 19 мая 2020 г., 09:28:51

/ / PascalABC.

NET 3.

1, сборка 1201 от 18.

03. 2016

begin var a : = ArrRandom(ReadInteger('n = '), - 5, 5) ; a.

Println ; var b : = a.

Select((x, i) - > ; x = 0?

I + 1 : 0).

Where(i - > ; i> ; 0) ; if b.

Count> ; 0 then begin b.

Println(', ') ; Writeln('Кол - во : ', b.

Count) end else Writeln('Нет нулевых элементов')

end.

Тестовое решение :

n = 20 - 4 2 5 - 2 0 5 4 4 - 3 - 2 - 5 2 1 0 - 2 0 4 1 - 2 3

5, 14, 16

Кол - во : 3.

Dankovmaxim20 15 дек. 2020 г., 10:25:50 | 10 - 11 классы

Помогите составить программу?

Помогите составить программу.

Вот она.

Даны К и массив Т(к).

Найти сумму и количество элементов в массиве Т после первого нулевого элемента.

Седдааа 7 апр. 2020 г., 01:01:43 | 5 - 9 классы

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три?

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Angelinagavril12 20 февр. 2020 г., 07:23:54 | 5 - 9 классы

Дан массив из N целых элементов и целое число B?

Дан массив из N целых элементов и целое число B.

Написать программу, определяющую, сколько в массиве чисел, меньших В.

Smirnowka2016 26 июл. 2020 г., 08:55:25 | 5 - 9 классы

Дан массив из n целых чисел составить алгоритм который все элементы оканчивающиеся цифрой 4 уменьшает вдвое?

Дан массив из n целых чисел составить алгоритм который все элементы оканчивающиеся цифрой 4 уменьшает вдвое.

Laranastua 1 июл. 2020 г., 10:53:31 | 1 - 4 классы

Плииз?

Плииз.

Нужен алгоритм решения задачи дан массив целых чисел.

Найти номера элементов, окончивающихся цифрой 0.

Wolves48 6 июл. 2020 г., 19:32:02 | 10 - 11 классы

Срочно помогите?

Срочно помогите!

Дан массив из 10ти целых чисел , введенных с клавиатуры.

Найти и заменить все нулевые элементы на минимальный элемент массива.

Мерипопенс 20 сент. 2020 г., 02:15:23 | 5 - 9 классы

Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке?

Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке.

Ксюха7777 7 апр. 2020 г., 08:53:50 | 5 - 9 классы

Дан массив целых чисел из N элементов, введенных с клавиатуры?

Дан массив целых чисел из N элементов, введенных с клавиатуры.

Посчитать сколько в нем отрицательных, положительных и нулевых чисел?

57557 16 нояб. 2020 г., 04:40:06 | 5 - 9 классы

Составить массив из 10 целых случайных чисел на промежутке от - 30 до 30?

Составить массив из 10 целых случайных чисел на промежутке от - 30 до 30.

Вывести массив.

Найти количество чётных элементов и вывести их номера.

Вы перешли к вопросу Дан массив из n целых чисел?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.