4. Сформировать целочисленный массив их 15 произвольных чисел?

Информатика | 5 - 9 классы

4. Сформировать целочисленный массив их 15 произвольных чисел.

Подсчитать сумму и произведение элементов с нечетными индексами.

Ответить на вопрос
Ответы (1)
NIlya 6 мая 2020 г., 14:13:27

Program arr ;

var a : array[1.

15] of integer ; count, count_odd, num, sum, mult : integer ;

begin count : = 1 ; count_odd : = 1 ; num : = 3 ; sum : = 0 ; mult : = 1 ; while count < ; = 15 do begin a[count] : = num ; count : = count + 1 ; num : = num + 3 ; end ; while count_odd < ; = 15 do begin sum : = sum + a[count_odd] ; mult : = mult * a[count_odd] ; count_odd : = count_odd + 2 ; end ; writeln('Массив из 15 элементов : 3, 6, 9, .

, 45') ; writeln('Сумма элементов с нечетными индексами : ', sum) ; writeln('Произведение элементов с нечетными индексами : ', mult) ;

end.

Kashetay 27 февр. 2020 г., 07:31:35 | 5 - 9 классы

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры?

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры.

Подсчитать среднее арифметическое элементов с нечетными номерами.

Кокушка 30 янв. 2020 г., 18:15:18 | 5 - 9 классы

Дан двухмерный массив, из четных элементов кратных 5 сформировать массив А, из нечетных элементов кратных 3 сформировать массив Б?

Дан двухмерный массив, из четных элементов кратных 5 сформировать массив А, из нечетных элементов кратных 3 сформировать массив Б.

Помогите пожалуйста).

Kris169 13 июл. 2020 г., 16:37:52 | 10 - 11 классы

Помогите?

Помогите!

Срочно!

Составить программу.

Сформировать массив из 8 элементов, вывести количество отрицательных чисел.

Составить программу.

Создать массив из 10 элементов случайным образом, найти сумму нечетных чисел.

Писать на языке Паскаль, одномерный массив.

Vitaly198703 11 сент. 2020 г., 05:36:00 | 10 - 11 классы

Ввести два целочисленныхмассива − по 10 элементов в каждом?

Ввести два целочисленныхмассива − по 10 элементов в каждом.

Сформировать новый массив, на четных местах которого будут элементы с нечетными индексами из первого массива, а нанечетных – с четными индексами из второго.

Написать программу на паскале.

Privedenie7 2 июл. 2020 г., 15:21:42 | 10 - 11 классы

Помогите решить задачу?

Помогите решить задачу.

Решить через паскаль.

Дан массив В(50) целых чисел.

Подсчитать сумму тех элементов массива, которые нечетны и отрицательны.

DarkLordanus 25 мая 2020 г., 05:41:08 | 10 - 11 классы

Сформировать массив из 10 произвольных чисел?

Сформировать массив из 10 произвольных чисел.

Определить сумму положительных, произведение отрицательных и количество нулевых элементов этого массива.

Arinapalamarchu 2 янв. 2020 г., 08:46:49 | 5 - 9 классы

Составьте програму : Дан целочисленный одномерный массив, состоящий из n элементов?

Составьте програму : Дан целочисленный одномерный массив, состоящий из n элементов.

Найти сумму нечетных элементов, кратных 3.

Hsmjh 3 февр. 2020 г., 20:38:40 | 5 - 9 классы

Дан целочисленный массив X(N, M) ?

Дан целочисленный массив X(N, M) .

Среди нечетных строк массива найти сумму четных элементов.

Fatima101 9 окт. 2020 г., 22:52:32 | 5 - 9 классы

1) Дан массив целых чисел?

1) Дан массив целых чисел.

Подсчитать сумму элементов с четными индексами.

2)Дан одномерный массив, состоящий из 20 элементов.

Подсчитать количество элементов, превышающих по значению его среднее арифметическое.

Kourov 6 окт. 2020 г., 22:33:10 | 10 - 11 классы

Cоставить программу в паскале?

Cоставить программу в паскале.

В одномерном массиве произвольных чисел вычислить произведение четных и нечетных элементов.

Вы открыли страницу вопроса 4. Сформировать целочисленный массив их 15 произвольных чисел?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.