При каком наибольшем n программа выведет на экран сначала 2, а потом 12?

Информатика | 10 - 11 классы

При каком наибольшем n программа выведет на экран сначала 2, а потом 12?

Var n, a, b, c : integer ; begin readln(n) ; a : = 0 ; b : = 0 ; while n > ; 0 do begin a : = a + 1 ; b : = b + (n mod 100) ; n : = n div 100 ; end ; writeln(a) ; write(b) ; end.

Ответить на вопрос
Ответы (1)
ALSY05555 23 янв. 2020 г., 16:01:59

В переменной a вычисляется количество пар цифр в числе.

Так как значение a должно быть равно 2, то число четырехзначное.

В переменной b вычисляется сумма чисел, определяемых как остатки от деления на 100.

Четырехзначные числа, соответствующие этому требованию - это 1002, 1101 и 1200.

Наибольшее из них - 1200.

Hdbvd 26 мая 2020 г., 01:21:08 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа, L и M.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 ; if (M< ; x) and (x mod 2 = 0) then begin M : = x mod 10 ; end ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Учени10101010101010 15 дек. 2020 г., 09:59:59 | 5 - 9 классы

Прошу вас, помогите?

Прошу вас, помогите!

Решается оценка!

Найдите ошибки в программе 1)Program z1 ; var a : integer ; begin a : = 10 ; while a< ; 5 do writeln(a) ; a : = a + 1 ; End.

2)Program z2 ; var a, s : integer ; begin a : = 1 ; s : = 0 ; while a< ; 10 do begin s : = s + a / 2 ; end ; writeln(s) ; end.

Antonharitonov0 28 янв. 2020 г., 01:46:32 | 10 - 11 классы

Помогите Срочно?

Помогите Срочно!

Чему будет равен результат выполнения программы, если ввести значения для a = 2468?

Program c22 ; var a, b : integer ; k : integer ; begin K : = 0 ; readln(a) ; while (a< ; > ; 0) do begin b : = a mod 10 ; if b mod 2 = 0 then inc(k) ; a : = a div 10 ; end ; writeln(k) ; end.

A) 9 Б)3 В)0 Г)4.

Аовл 16 июл. 2020 г., 16:45:17 | 10 - 11 классы

Чему будет равен результат выполнения программы, если ввести значения для a = 169?

Чему будет равен результат выполнения программы, если ввести значения для a = 169?

Program c22 ; var a : integer ; k : integer ; begin k : = 0 ; readln(a) ; while (a< ; > ; 0) do begin a : = a div 10 ; inc(k) ; end ; writeln(k) ; end.

А) 9 Б) 3 В) 0 Г) 1.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

Алтуша97 1 мар. 2020 г., 11:25:29 | 5 - 9 классы

Помогитеvar k, s : integer ;begins : = 0k : = 0while k < ; 30 do begink : = k + 3 ;s : = s + k ;end ;write(s) ;end?

Помогите

var k, s : integer ;

begin

s : = 0

k : = 0

while k < ; 30 do begin

k : = k + 3 ;

s : = s + k ;

end ;

write(s) ;

end.

Дулетол3 31 окт. 2020 г., 09:13:31 | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

11111109 26 июн. 2020 г., 15:33:09 | 10 - 11 классы

При каком наибольшем введенном числе d после выполнения программы будет напечатано 55?

При каком наибольшем введенном числе d после выполнения программы будет напечатано 55?

Var n, s, d : integer ; begin readln(d) ; n : = 0 ; s : = 0 ; while s < ; = 365 do begin s : = s + d ; n : = n + 5 end ; write(n) end.

Spasibo123 5 февр. 2020 г., 18:45:06 | 10 - 11 классы

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End?

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End.

Arlekino2106 21 авг. 2020 г., 18:55:06 | 10 - 11 классы

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4?

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 If M< ; (x mod 5) then Begin M : = x mod 5 End X : = x div 5 ; End.

Writeln (L) ; write(M) ; End.

На этой странице вы найдете ответ на вопрос При каком наибольшем n программа выведет на экран сначала 2, а потом 12?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.