Модифицированный алгоритм Евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так : нужно заменять большее число на остаток от деления большего на меньшее до тех п?

Информатика | 10 - 11 классы

Модифицированный алгоритм Евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так : нужно заменять большее число на остаток от деления большего на меньшее до тех пор, пока остаток не станет равно нулю ; тогда второе число и есть НОД.

Напишите программу, которая реализует этот алгоритм.

Входные данные : Входная строка содержит два числа, разделённые пробелом – a и b .

Выходные данные : Программа должна вывести в одной строке два числа : сначала наибольший общий делитель двух введённых чисел, а затем – количество шагов цикла, которые были выполнены.

Примеры : Входные данные : 21 14 Выходные данные : 7 2 Входные данные : 121 136 Выходные данные : 1 3.

Ответить на вопрос
Ответы (1)
ЭлИнОчК 16 мая 2020 г., 04:19:09

Var a, b, nod, k : integer ;

begin

readln(a, b) ;

k : = 0 ;

while (a< ; > ; 0)and(b< ; > ; 0) do

begin

if a> ; b then a : = a mod b else b : = b mod a ;

k : = k + 1 ;

end ;

nod : = a + b ;

writeln(nod, ' ', k) ;

end.

Пример :

21 14

7 2.

Nastyaepta 10 нояб. 2020 г., 01:33:15 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N ?

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N !

= 1·2·{.

}· N .

Входные данные Входная строка содержит одно натуральное число N .

Выходные данные Программа должна вывести одно число – факториал введённого числа N .

Borodyha123 28 дек. 2020 г., 21:12:44 | 10 - 11 классы

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу ?

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .

Формат входных данных

Входной файл содержит числа , ().

Формат выходных данных

Выведите искомые делители.

Примеры :

Вход6 3

Выход3 6.

Netepluk36 6 мая 2020 г., 13:32:28 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания?

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания.

Входные данные : Входная строка содержит одно натуральное число N .

Выходные данные : Программа должна вывести в одну строчку через пробел чётные положительные степени числа 2, не большие, чем N , в порядке убывания.

Если таких нет, программа должна вывести число 0.

Варя81 7 окт. 2020 г., 00:35:35 | 5 - 9 классы

Напишите программу, которая заменяет расширение у заданного имени файла?

Напишите программу, которая заменяет расширение у заданного имени файла.

Входные данные Первая строка содержит имя файла, которое нужно изменить.

Во второй строке записано нужное расширение.

Выходные данные Программа должна вывести изменённое имя файла с заданным расширением.

Примеры входные данные qwerty exe выходные данные qwerty.

Exe входные данные qwetry.

Old. pas html выходные данные qwetry.

Old. html.

Balashovamarin 2 июл. 2020 г., 18:04:30 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное?

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное.

Входные данные : Входная строка содержит единственное натуральное число.

Выходные данные : Если введённое число – трёхзначное, нужно вывести ответ YES, если нет, то вывести ответ NO.

Serjana 9 окт. 2020 г., 05:42:28 | 10 - 11 классы

Уровень B?

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

ЛизаПоняша 25 дек. 2020 г., 09:24:13 | 10 - 11 классы

Напишите программу, которая возводит натуральное число A в натуральную степень B ?

Напишите программу, которая возводит натуральное число A в натуральную степень B .

Входные данные

Входная строка содержит два числа, A и B , разделённые пробелом.

Гарантируется, что 1 ≤ A , B ≤ 1000 .

Выходные данные

Программа должна вывести одно число : A в степени B .

Примеры

входные данные

2 6

выходные данные

64.

Паскаль ABC 1.

8.

Маша133 31 окт. 2020 г., 06:11:15 | 10 - 11 классы

Напишите программу, которая удаляет из строки все повторяющиеся символы?

Напишите программу, которая удаляет из строки все повторяющиеся символы.

Входные данные

На вход программы подаётся строка, содержащая символы таблицы ASCII.

Выходные данные

Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Примеры

входные данные

abc13a1b2z3c

выходные данные

abc132z

входные данные

QWasd123

выходные данные

QWasd123

Pascal ABC 1.

8.

Oklubkova 10 дек. 2020 г., 09:26:25 | 5 - 9 классы

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел?

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.

Входные данные

Входная строка содержит 5 целых чисел, разделённых пробелами.

Выходные данные

В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное.

Примеры

входные данные

1 2 3 4 5

выходные данные

1

5

На паскале.

Jamilya456 27 дек. 2020 г., 04:26:34 | 10 - 11 классы

Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата?

Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата.

Например, 25 ^ 2 = 625 .

Напишите программу, которая находит все автоморфные числа на отрезке [ a , b ] .

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все автоморфные числа на отрезке [ a , b ] , разделив их пробелами.

Если таких чисел нет, программа должна вывести число - 1.

Примеры

входные данные

20 100

выходные данные

25 76

На паскале, через циклы, пожалуйста.

Вы открыли страницу вопроса Модифицированный алгоритм Евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так : нужно заменять большее число на остаток от деления большего на меньшее до тех п?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.