Напишите программу, которая находит сумму цифр введённого пятизначного натурального числа?

Информатика | 5 - 9 классы

Напишите программу, которая находит сумму цифр введённого пятизначного натурального числа.

Ответить на вопрос
Ответы (1)
777666 20 мая 2020 г., 16:45:16

Var A, S, k : integer ;

begin

S : = 0 ;

write('Введите A = ') ; Readln(A) ;

while (A> ; 0) do begin If (k< ; 5) then begin k : = k + 1 ; S : = S + A mod 10 ; A : = A div 10 ; end else begin k : = 100 ; A : = 0 ; end ; end ;

f(k = 5) then write(S)

else write('не пятизнач') ;

end.

Stoki 20 мая 2020 г., 07:03:28 | 5 - 9 классы

Напишите программу, которая находит все числа Армстронга из диапазона от A до B?

Напишите программу, которая находит все числа Армстронга из диапазона от A до B.

Натуральное число из n цифр называется числом Армстронга, если сумма его цифр, возведенных в степень n, равна самому числу.

Галка1976 14 дек. 2020 г., 00:28:26 | 5 - 9 классы

Напишите программу, которая по введенному целому числу А (0≤ А ≤ 999999) находит сумму цифр этого числа S?

Напишите программу, которая по введенному целому числу А (0≤ А ≤ 999999) находит сумму цифр этого числа S.

Alexhenderson 9 мар. 2020 г., 04:46:11 | 5 - 9 классы

Составьте программу которая определяет являеться ли сумма цифр введённого целого трёхзначного числа чётным числом?

Составьте программу которая определяет являеться ли сумма цифр введённого целого трёхзначного числа чётным числом.

Нгдшнф 9 июн. 2020 г., 15:46:22 | 5 - 9 классы

Напишите программу, которая выводит сумму цифр числа 123?

Напишите программу, которая выводит сумму цифр числа 123.

Ilnazmutin2 16 дек. 2020 г., 07:48:32 | 5 - 9 классы

Напишите программу, которая считает сумму цифр введённого числа?

Напишите программу, которая считает сумму цифр введённого числа.

Входная строка содержит одно натуральное число.

Программа должна вывести сумму цифр введённого числа.

НА ЯЗЫКЕ PYTHON !

ТОЛЬКО PYTHON !

Тупой3 18 нояб. 2020 г., 15:43:53 | 10 - 11 классы

Напишите программу, которая вводит натуральное число и находит все числа на отрезке [0, N], сумма цифр которых не меняется при умножении числа на 2, 3, 4, 5, 6, 7, 8 и 9 (например, число 9)?

Напишите программу, которая вводит натуральное число и находит все числа на отрезке [0, N], сумма цифр которых не меняется при умножении числа на 2, 3, 4, 5, 6, 7, 8 и 9 (например, число 9).

Используйте функцию для вычисления суммы цифр числа.

Ilia777777 17 июн. 2020 г., 20:16:59 | 5 - 9 классы

Напишите программу которая считает количество чётных цифр введённого числа?

Напишите программу которая считает количество чётных цифр введённого числа.

Ская 29 июл. 2020 г., 09:39:30 | 10 - 11 классы

Напишите программу, которая находит среднее из трёх введённых чисел?

Напишите программу, которая находит среднее из трёх введённых чисел.

Предполагается, что все три числа различные.

Алина12532 27 авг. 2020 г., 07:19:39 | 5 - 9 классы

Составьте программу, которая определяет, является ли сумма цифр введённого целого трёхзначного числа чётным числом?

Составьте программу, которая определяет, является ли сумма цифр введённого целого трёхзначного числа чётным числом.

Jesdasd 20 окт. 2020 г., 23:54:53 | 5 - 9 классы

Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр данного числа Пример ввода 12345 Пример вывода 55 С + + ПРОГРАММА?

Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр данного числа Пример ввода 12345 Пример вывода 55 С + + ПРОГРАММА.

На этой странице находится вопрос Напишите программу, которая находит сумму цифр введённого пятизначного натурального числа?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.