1. Дана целочисленная матрица А(N, N)?

Информатика | 10 - 11 классы

1. Дана целочисленная матрица А(N, N).

Определите, будет ли сумма всех элементов, расположенных выше главной диагонали при делении на три нечётным числом.

Ответить на вопрос
Ответы (1)
Кристина1996мтс 28 февр. 2020 г., 10:54:07

/ / Pascal ABC.

NET v3.

1 сборка 1172

Var

ma : array of array of integer ;

i, j, n, r : integer ;

begin

readln(n) ;

setlength(ma, n + 1) ;

for i : = 1 to n do

setlength(ma[i], n + 1) ;

writeln('Matrix : ') ;

for i : = 1 to n do

begin writeln ; for j : = 1 to n do begin ma[i, j] : = random(n) ; write(ma[i, j] : 4) ; end ;

end ;

for i : = 1 to n do for j : = i + 1 to n do r : = r + ma[i, j] ;

r : = r div 3 ;

writeln ;

if odd(r) then writeln('Да') else writeln('Нет') ;

end.

Пример ввода :

4

Пример вывода :

Matrix : 0 1 3 3 3 0 0 3 2 3 0 2 3 0 2 3

Нет.

Madina7182 23 мар. 2020 г., 19:46:19 | 10 - 11 классы

Составить программу на языке паскаль задание : дана матрица А(N, N)?

Составить программу на языке паскаль задание : дана матрица А(N, N).

Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали.

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

Jenny0919 7 нояб. 2020 г., 17:49:00 | 10 - 11 классы

Паскаль?

Паскаль.

Дана квадратная матрица(случайные числа от - 10 до 10) организовать вывод в виде матрицы.

Подсчитать количество чётных и нечётных элементов главной диагонали.

Yarima 12 окт. 2020 г., 14:59:23 | 10 - 11 классы

Дана целочисленная квадратная матрица найти сумму элементов, стоящих выше главной диагонали на языке Turbo Pascal?

Дана целочисленная квадратная матрица найти сумму элементов, стоящих выше главной диагонали на языке Turbo Pascal.

Metelkinakristina 19 нояб. 2020 г., 08:56:07 | 10 - 11 классы

Дана квадратная матрица действительных чисел?

Дана квадратная матрица действительных чисел.

Найти сумму модулей элементов , расположенных выше главной диагонали.

Salvatore210 17 апр. 2020 г., 11:31:23 | 10 - 11 классы

Программирование C + + ?

Программирование C + + .

Дана целочисленная прямоугольная матрица.

Найти разность сумм элементов на главной и побочной диагоналях.

ПуФФысТиК19 23 окт. 2020 г., 11:48:40 | 10 - 11 классы

Дана целочисленная матрица 5 на 5 ?

Дана целочисленная матрица 5 на 5 .

Определить положительные элементы на побочной диагонали.

(В Паскале).

Лиза231001 14 окт. 2020 г., 12:10:52 | 10 - 11 классы

Дана целочисленная матрица 5 на 5?

Дана целочисленная матрица 5 на 5.

Определить положительные элементы на побочной диагонали.

(Паскаль).

Babinababina 5 февр. 2020 г., 02:02:02 | 10 - 11 классы

4. Дана целочисленная матрица А(N, N)?

4. Дана целочисленная матрица А(N, N).

Определите, будет ли сумма всех элементов, расположенных ниже вспомогательной (побочной) диагонали при делении на два четным числом.

Лыоадыо 13 сент. 2020 г., 02:44:29 | 5 - 9 классы

С + + ?

С + + .

Определить максимальный элемент матрицы на главной диагонали и сумму элементов этой диагонали.

Размер матрицы вводить с клавиатуры, элементы, а также результат, разместить в памяти динамически.

Если вам необходимо получить ответ на вопрос 1. Дана целочисленная матрица А(N, N)?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.