Pascal ABC?

Информатика | 10 - 11 классы

Pascal ABC.

Для двумерного массива 9 * 9 найдите элемент, который расположен «по центру» (т.

Е. от него до левого края и до правого края, до верхнего края и до нижнего края одинаковое расстояние).

Какая у него координата?

Ответить на вопрос
Ответы (1)
Лиля219 17 окт. 2020 г., 21:54:19

/ / PascalABC.

NET 3.

1 сборка 1219

procedure PrintMatrix(a : array[, ] of integer) ;

begin for var i : = a.

GetLowerBound(0) to a.

GetUpperBound(0) do begin writeln ; for var j : = a.

GetLowerBound(1) to a.

GetUpperBound(1) do write(a[i, j], ' ') ; end ; writeln ;

end ;

begin var a : = MatrixRandom(9, 9, 10, 99) ; PrintMatrix(a) ; var i : = (a.

GetLowerBound(0) + a.

GetUpperBound(0)) div 2 + (a.

GetLowerBound(0) + a.

GetUpperBound(0)) mod 2 ; var j : = (a.

GetLowerBound(1) + a.

GetUpperBound(1)) div 2 + (a.

GetLowerBound(1) + a.

GetUpperBound(1)) mod 2 ; writeln('A[', i, ', ', j, '] = ', a[i, j]) ;

end.

Marlenkulmatov 21 янв. 2020 г., 09:23:00 | 10 - 11 классы

Текст что значит родной край в твоей жизни?

Текст что значит родной край в твоей жизни.

Lena99553 12 авг. 2020 г., 12:29:39 | 5 - 9 классы

Полезные комбинации клавиш для форматирования ( напишите как можно скорее?

Полезные комбинации клавиш для форматирования ( напишите как можно скорее!

)

Выравнивание по левому краю

Выравнивание по правому краю

Выравнивание по центру

Выравнивание по ширине

Жирный

Курсив

Подчеркнутый

Верхний индекс

Нижний индекс

Изменение регистра символов.

Алинчик1212 14 янв. 2020 г., 12:21:48 | 10 - 11 классы

Почему край ткани имеет кромку?

Почему край ткани имеет кромку.

Аришка77 12 февр. 2020 г., 06:38:11 | 5 - 9 классы

Упорядочите элементы массива А в порядке убывания В Pascal ABC?

Упорядочите элементы массива А в порядке убывания В Pascal ABC.

ЛанаЛо 18 июл. 2020 г., 14:36:57 | 10 - 11 классы

Даны два массива?

Даны два массива.

Получить третий массив который на четных номерах элементы второго массива на нечетных элементы первого массива.

Решите пожалуйста через pascal ABC и опишите программу.

Snzr16 1 окт. 2020 г., 01:03:31 | 10 - 11 классы

У чому полягає форматування абзаців?

У чому полягає форматування абзаців?

1. вирівнювання лівого і правого краю текста 2.

Встановлення лівого і правого відступів 3.

Встановлення міжабзацних і міжрядкових інтервалів 4.

Вирівнювання верхнього і нижньго краю текста 5.

Введення імені файла для зберігання.

Vika19973 10 февр. 2020 г., 04:51:12 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Akinkvv 3 июн. 2020 г., 16:34:14 | 5 - 9 классы

Начальное состояние : исполнитель находится в нижнем правом углу и смотрит вверх?

Начальное состояние : исполнитель находится в нижнем правом углу и смотрит вверх.

Где будет исполнитель после выполнения следующих программ?

А) ПРОХОД 1 нач пока впереди не край повторять кц поворот поворот пока впереди не край повторять кц прыжок кц 2) ПРОГРАММА ПРОХОД 2 нач пока вперед не край повторят кц прыжок поворот прыжок поворот поворот поворот кц кон.

Tatyanaosokina2 11 сент. 2020 г., 12:35:12 | 5 - 9 классы

Напишите, пожалуйста программу которая демонстрирует движение закрашенного прямоугольника из левого верхнего угла в правый нижний, а затем из правого верхнего в левый нижний?

Напишите, пожалуйста программу которая демонстрирует движение закрашенного прямоугольника из левого верхнего угла в правый нижний, а затем из правого верхнего в левый нижний.

Shalimovavika 28 окт. 2020 г., 12:51:47 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Помогите, пожалуйста!

Напишите программу, которая двигает квадрат из левого верхнего угла в правый верхний.

В качестве ответа загрузите текст программы и скомпилированный exe - файл.

Вы зашли на страницу вопроса Pascal ABC?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.