3. Даны три целых числа?

Информатика | 10 - 11 классы

3. Даны три целых числа.

Определить, сумма цифр которого из них больше.

Подсчет суммы цифр организовать через подрограмму.

4. Определить площадь выпуклого четырехугольника по заданным координатам вершин.

Использовать подпрограмму - функцию вычисления длины отрезка и подпрограмму - процедуру вычисления площади треугольника по формуле Герона.

Срочно, пожалуйста.

Ответить на вопрос
Ответы (1)
Saidid99 10 авг. 2020 г., 07:36:57

/ / 4)

var x1, y1, x2, y2, x3, y3, x4, y4 : integer ; s, sc : real ;

function linelength(x1, y1, x2, y2 : integer) : real ;

begin linelength : = sqrt(sqr(x2 - x1) + sqr(y2 - y1)) ;

end ;

procedure ger(a, b, c : real) ;

var p : real ;

begin p : = (a + b + c) / 2 ; sc : = sqrt(p * (p - a) * (p - b) * (p - c)) ;

end ;

begin write('1 : ') ; readln(x1, y1) ; write('2 : ') ; readln(x2, y2) ; write('3 : ') ; readln(x3, y3) ; write('4 : ') ; readln(x4, y4) ; ger(linelength(x1, y1, x2, y2), linelength(x2, y2, x3, y3), linelength(x1, y1, x3, y3)) ; s : = s + sc ; ger(linelength(x1, y1, x4, y4), linelength(x4, y4, x3, y3), linelength(x1, y1, x3, y3)) ; s : = s + sc ; writeln(s) ;

end.

/ / 3)

var a, b, c : integer ;

function sce(var a : integer) : integer ;

var sc, c : integer ;

begin while a < ; > ; 0 do begin c : = a mod 10 ; a : = a div 10 ; sc : = sc + c ; end ; sce : = sc ;

end ;

begin read(a, b, c) ; if (sce(a) > ; sce(b)) and (sce(a) > ; sce(c)) then writeln(a) else if (sce(b) > ; sce(a)) and (sce(b) > ; sce(c)) then writeln(b) else if (sce(c) > ; sce(a)) and (sce(c) > ; sce(b)) then writeln(c) else if (sce(c) = sce(a)) and (sce(a) = sce(b)) then writeln('Равны') ;

end.

Полина2373 21 мар. 2020 г., 00:32:38 | 10 - 11 классы

Программа вычисления площади кольца, используя подпрограмму вычисления площади круга?

Программа вычисления площади кольца, используя подпрограмму вычисления площади круга.

Gatsaevanatali 21 янв. 2020 г., 12:56:01 | 10 - 11 классы

Для решения задачи сделать вариант программы с реализацией указанной подпрограммы в виде функции или в виде процедуры?

Для решения задачи сделать вариант программы с реализацией указанной подпрограммы в виде функции или в виде процедуры.

Даны координаты трех точек определить между какими из пар точек самое большое расстояние используя подпрограмму вычисления длины отрезка между двумя точками.

Karap2015 26 авг. 2020 г., 23:45:11 | 10 - 11 классы

Написать программу на Pascal для вычисления площади треугольника по его координатам(стороны вычисляются как L1 = )Площадь по формуле Герона?

Написать программу на Pascal для вычисления площади треугольника по его координатам

(стороны вычисляются как L1 = )

Площадь по формуле Герона.

Пожалуйста помогите (сделайте screen если можно).

Dari050398 8 апр. 2020 г., 06:56:14 | 10 - 11 классы

Напишите программу вычисления площади и гипотенузы прямоугольного треугольника , если известны его катеты?

Напишите программу вычисления площади и гипотенузы прямоугольного треугольника , если известны его катеты.

Нужно оформить эту программу в виде подпрограммы функция!

Плииззззззззззз помогите : ).

Z89221257576 17 сент. 2020 г., 19:48:00 | 5 - 9 классы

Информатики?

Информатики!

Помогите, срочно надо!

ВОТ ЗАДАЧА : Пользователь вводит с клавиатуры 3 числа a, b, c , являющиеся сторонами треугольника.

Написать программу использующую подпрограмму функцию для вычисления площади треугольника по формуле Герона.

(В паскале) Напишите пожалуйста программу Формула Герона : S = p * (p - a)(p - b)(p - c) (все под корнем).

P = a + b + c / 2.

Loverich 6 мая 2020 г., 12:55:02 | 10 - 11 классы

Составьте программу для вычисления площади четырехугольника с координатами вершин (x1, y1) , (x2, y2), (x3, y3), (x4, y4) площадь четырехугольника вычислите как сумму площадей двух треугольников?

Составьте программу для вычисления площади четырехугольника с координатами вершин (x1, y1) , (x2, y2), (x3, y3), (x4, y4) площадь четырехугольника вычислите как сумму площадей двух треугольников.

Pascal ABC.

Bentlii 21 нояб. 2020 г., 04:16:15 | 5 - 9 классы

Даны два натуральных числа?

Даны два натуральных числа.

Выяснить в каком из них сумма цифр больше.

(Определить функцию для расчета суммы цифр натурального числа).

Каринка0Ясинская 17 сент. 2020 г., 11:09:46 | 5 - 9 классы

Написать подпрограмму, которая ищет а четырехзначном числе минимальную четную цифру?

Написать подпрограмму, которая ищет а четырехзначном числе минимальную четную цифру.

Если таких цифр нет, то вернуть - 1.

Требования к подпрограмме : Процедура должна называться "search" и иметь два параметра : первый - четырехзначное натуральное число.

Второй - результат работы подпрограммы.

(Паскаль абц (Pascal abc)).

Vahf 11 дек. 2020 г., 23:51:04 | 10 - 11 классы

Используя подпрограмму - функцию написать алгоритм решения задачи : Написать функцию, которая находит сумму цифр целого числа?

Используя подпрограмму - функцию написать алгоритм решения задачи : Написать функцию, которая находит сумму цифр целого числа.

Vikaviktoriya10 18 окт. 2020 г., 11:00:50 | 10 - 11 классы

Задачу решить двумя способами : с использованием подпрограммы - функции и подпрограммы - процедуры?

Задачу решить двумя способами : с использованием подпрограммы - функции и подпрограммы - процедуры.

Обязательно построение блок - схем алгоритмов!

1. Треугольник задан координатами своих вершин.

Вычислить площадь треугольника по формуле Герона с использованием подпрограммы нахождения расстояния между двумя точками на координатной плоскости.

Полезные формулы :

1.

Формула Герона : S = sqrt((p - a)(p - b)(p - c)) , где p = a + b + c / 2 (полупериметр треугольника со сторонами a, b и c)

2.

Расстояние между двумя точками на координатной плоскости : d = sqrt(sqr(x2 - x1) + sqr(y2 - y1)) , где (x1, y1) и (x2, y2) – координаты первой и второй точек соответственно.

На этой странице сайта вы найдете ответы на вопрос 3. Даны три целых числа?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.