Помогите, срочно?

Информатика | 5 - 9 классы

Помогите, срочно!

Задача на двумерный массив в Pascal!

Вводится массив n * n и число k.

Вывести номер строки, сумма элементов которой равна или наиболее близка к сумме элементов столбца с номером k.

Ответить на вопрос
Ответы (1)
Dolzhenkonataly 10 апр. 2020 г., 06:46:27

Const n = 8 ;

var

a : array[1.

N, 1.

N] of integer ;

i, j, k, s, s1, si, dmin, smin : integer ;

begin

Randomize ;

writeln('Исходный массив : ') ;

for i : = 1 to n do

begin

for j : = 1 to n do begin a[i, j] : = random(50) ; write(a[i, j] : 4) ; end ; writeln ;

end ;

write('k = ') ; readln(k) ;

s : = 0 ;

for j : = 1 to n do s : = s + a[k, j] ;

writeln('s = ', s) ;

dmin : = 999999 ; smin : = 999999 ;

for i : = 1 to n do

if i< ; > ; k then begin s1 : = 0 ; for j : = 1 to n do s1 : = s1 + a[i, j] ; writeln('s', i, ' = ', s1) ; if abs(s1 - s)< ; dmin then begin dmin : = abs(s1 - s) ; smin : = s1 ; si : = i ; end ; end ;

writeln('Номер строки = ', si, ', smin = ', smin) ;

end.

Пример :

Исходный массив : 9 0 22 40 20 35 2 25 23 30 22 35 41 0 9 40 1 15 6 18 43 47 34 33 26 5 2 45 13 46 40 2 26 39 7 31 3 43 20 8 25 15 24 6 10 16 3 25 47 0 27 35 14 15 36 11 16 38 14 14 33 7 11 26

k = 5

s = 177

s1 = 153

s2 = 200

s3 = 197

s4 = 179

s6 = 124

s7 = 185

s8 = 159

Номер строки = 4, smin = 179.

Alexkem42 24 мая 2020 г., 22:28:12 | 5 - 9 классы

Pascal ABC?

Pascal ABC.

Двухмерный массив.

1)вычислить количество чётных элементов 2) сумму элементов столбца по его введённому номеру.

Zhantonina 13 янв. 2020 г., 02:03:15 | 5 - 9 классы

(Pascal) Задача : Ввести массив из 5 элементов с клавиатуры?

(Pascal) Задача : Ввести массив из 5 элементов с клавиатуры.

Вывести элементы на экран и найти их сумму.

РЕШИТЕ ПОЗЯЗЯ!

Alesha19983 7 нояб. 2020 г., 08:01:10 | 10 - 11 классы

Помогите с задачей на двумерные массивы в Pascal?

Помогите с задачей на двумерные массивы в Pascal.

Для каждого столбца нужно подсчитать сумму отрицательных элементов и записать данные в новый массив.

Ciklomen151 2 июл. 2020 г., 22:39:18 | 10 - 11 классы

Заполнить двумерный массив N * N числами с клавиатуры и найти сумму элементов массива нечётных столбцов?

Заполнить двумерный массив N * N числами с клавиатуры и найти сумму элементов массива нечётных столбцов.

Gaptrahmanova19 27 дек. 2020 г., 17:04:59 | 5 - 9 классы

Задача по информатике 11 класс, тема двумерный массив?

Задача по информатике 11 класс, тема двумерный массив.

Сформировать двумерный массив с случайными числами и найти сумму всех элементов.

Помогите!

Kultychevasony 22 мая 2020 г., 09:32:48 | 10 - 11 классы

Дан двумерный квадратный массив?

Дан двумерный квадратный массив.

Найти номера строк, все элементы которых равны нулю.

Ldinka73 2 нояб. 2020 г., 21:12:06 | 10 - 11 классы

Задан двумерный массив Y из 4 - х строк и 4 - х столбцов?

Задан двумерный массив Y из 4 - х строк и 4 - х столбцов.

Составить программу, которая вычисляет S – сумму элементов побочной диагонали и значение суммы всех элементов массива

На с + + подробне пожалуйста эту задачу я не понял что то.

Seregaarhipov20 23 окт. 2020 г., 02:59:02 | 5 - 9 классы

Задан двумерный массив В из 4 - х строк и 5 - и столбцов?

Задан двумерный массив В из 4 - х строк и 5 - и столбцов.

Составить программу, которая организует одномерный массив, каждый элемент которого есть сумма элементов в столбце.

Вычислить произведение элементов полученного массива.

Сладкая897 20 авг. 2020 г., 06:33:45 | 10 - 11 классы

Помогите пожалуйста решить задачи 1?

Помогите пожалуйста решить задачи 1.

Найти сумму элементов двумерного массива у которых номер строки не четный 2.

Вывести на экран элементы двумерного массива у которых n столбца нечетный.

Катя16445236 21 янв. 2020 г., 08:42:38 | 5 - 9 классы

Дан двумерный массив, который содердит не более 10 строк и 10 столбцов?

Дан двумерный массив, который содердит не более 10 строк и 10 столбцов.

Найти сумму тех элементов, которые больше элемента стоящего на главной диагонали в данной строке.

На этой странице вы найдете ответ на вопрос Помогите, срочно?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.