Заполнить матрицу А 5х5 случайными числами до 20 и далее выполнить задание : 1?

Информатика | 10 - 11 классы

Заполнить матрицу А 5х5 случайными числами до 20 и далее выполнить задание : 1.

Найти максимальный элемент на побочной диагонали ; 2.

Составить одномерный массив В из минимальных элементов каждой строки ; 3.

В одномерном массиве В найти среднее арифметическое и вывести на экран элементы массива В, которые больше среднего арифметического.

Ответить на вопрос
Ответы (1)
MrFanta 4 нояб. 2020 г., 05:05:41

Const n = 5 ;

var

a : array[1.

N, 1.

N] of integer ;

b : array[1.

N] of integer ;

i, j, max, min, s : integer ;

begin

Randomize ;

writeln('Исходный массив : ') ;

for i : = 1 to n do

begin

for j : = 1 to n do begin a[i, j] : = random(21) ; write(a[i, j] : 4) ; end ; writeln ;

end ;

max : = a[1, n] ;

for i : = 2 to n do if a[i, n - i + 1]> ; max then max : = a[i, n - i + 1] ;

writeln('1.

Max = ', max) ;

for i : = 1 to n do

begin

min : = a[i, 1] ;

for j : = 2 to n do if a[i, j]< ; min then min : = a[i, j] ;

b[i] : = min ;

end ;

s : = 0 ;

writeln('2.

Массив B') ;

for i : = 1 to n do

begin

write(b[i] : 4) ;

s : = s + b[i] ;

end ;

writeln ;

writeln('3.

Среднее = ', s / n) ;

for i : = 1 to n do

if b[i]> ; s / n then write(b[i] : 4) ;

writeln ;

end.

Пример :

Исходный массив : 10 19 15 17 10 12 12 10 1 5 17 8 8 14 15 12 11 8 0 13 2 2 4 10 6

1.

Max = 11

2.

Массив B 10 1 8 0 2

3.

Среднее = 4.

2 10 8.

Leto7707 19 апр. 2020 г., 12:39:50 | 5 - 9 классы

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО?

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!

1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от - 15 до 35.

Найти сумму элементов данного массива.

2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от - 15 до 35.

Найти значение максимального элемента массива.

Saalaus 17 апр. 2020 г., 21:09:47 | 10 - 11 классы

Найти среднее арифметическое всех положительных элементов одномерного массива?

Найти среднее арифметическое всех положительных элементов одномерного массива.

В Delphi.

Vikavizsa 13 сент. 2020 г., 02:37:20 | 10 - 11 классы

В одномерном массиве от нуля до 10 заполненный случайным образом найти среднее арифметическое элементов массива?

В одномерном массиве от нуля до 10 заполненный случайным образом найти среднее арифметическое элементов массива.

Akchalova1998 23 мая 2020 г., 10:27:12 | 10 - 11 классы

Сформировать одномерный массив из 10 случайных элементов в диапазонеот 0 до 100?

Сформировать одномерный массив из 10 случайных элементов в диапазоне

от 0 до 100.

Найти количество элементов массива, больших среднего арифметического

всех его элементов.

Если это количество чѐтное, то увеличить каждый элемент массива на

величину индекса ; иначе поменять местами центральные элементы.

Вывести исходный и

итоговый массивы на экран.

Krimordvinova8 29 янв. 2020 г., 05:06:08 | 10 - 11 классы

Найти среднее арифметическое элементов одномерного массива А10?

Найти среднее арифметическое элементов одномерного массива А10.

Составить программу.

Ovsyanikovanas 28 мар. 2020 г., 18:53:34 | 5 - 9 классы

Дан одномерный массив чисел?

Дан одномерный массив чисел.

Определить среднее арифметическое элементов массива.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Аааааа53 6 дек. 2020 г., 11:35:41 | 10 - 11 классы

1. Заполнить одномерный массив B вещественными числами из промежутка от - 20 до 5?

1. Заполнить одномерный массив B вещественными числами из промежутка от - 20 до 5.

Найти сумму и среднее положительных и четных элементов массива.

Найти произведение отрицательных элементов массива.

Найти минимальный элемент массива.

Отсортировать массив по убыванию.

2. Заполнить одномерный массив А целыми числами из промежутка от - 12 до 7.

Вывести элементы массива, значения которых больше заданного числа Н и кратны числу К.

Найти максимальный элемент массива.

Отсортировать массив по возрастанию.

На паскале.

Помогать1 6 нояб. 2020 г., 19:51:15 | 5 - 9 классы

Pascal 1?

Pascal 1.

Найти среднее арифметическое положительных элементов одномерного массива.

2. Найти минимальный элемент одномерного массива.

На этой странице находится ответ на вопрос Заполнить матрицу А 5х5 случайными числами до 20 и далее выполнить задание : 1?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.