Как исправить программу что бы выдовал что знаки чередуются?

Информатика | 5 - 9 классы

Как исправить программу что бы выдовал что знаки чередуются?

Ответить на вопрос
Ответы (1)
Ankasinovskaya 23 июл. 2020 г., 22:38:41

Булевская переменная говорит о том, чередуются ли символы.

Если в какой - нибудь момент произведение текущего и предыдущего числа будет больше нуля (a * b > ; 0 только если знаки совпадают), то присваиваем переменной ложь.

Var

a, b : integer ; c : boolean ;

begin b : = 0 ; c : = true ; read(a) ; while a < ; > ; 0 do begin if a * b > ; 0 then c : = false ; b : = a ; read(a) ; end ; if c then writeln('Знаки чередуются') else writeln('Знаки не чередуются')

end.

Petrochinina 10 нояб. 2020 г., 10:39:08 | 5 - 9 классы

Составить программу устанавливающую одного ли знака два числа вводимые с клавиатуры?

Составить программу устанавливающую одного ли знака два числа вводимые с клавиатуры.

Sofyadog 25 мая 2020 г., 07:21:44 | 10 - 11 классы

Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел?

Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел.

Написать в паскале.

Salaevizzat 15 апр. 2020 г., 13:35:03 | 10 - 11 классы

Написать программу которая запрашивает два слова а и б одинаковой длины и формирует новое слово в котором буквы первого чередуется с буквами второго?

Написать программу которая запрашивает два слова а и б одинаковой длины и формирует новое слово в котором буквы первого чередуется с буквами второго.

В паскале *

ПОМОГИТЕ ПОЖАЛУЙСТАААА.

Kot000000 10 дек. 2020 г., 18:14:40 | 5 - 9 классы

Составьте программу, позволяющую найти долю согласных букв в строке, не содержащей знаков препинания?

Составьте программу, позволяющую найти долю согласных букв в строке, не содержащей знаков препинания.

Izon836 24 февр. 2020 г., 01:30:25 | 1 - 4 классы

Написать программу, которая меняет знак у значения переменной R?

Написать программу, которая меняет знак у значения переменной R.

Orxan92 13 мая 2020 г., 20:00:01 | 10 - 11 классы

Составить программу, устанавливающую одного ли знака два числа, вводимые клавиатуры?

Составить программу, устанавливающую одного ли знака два числа, вводимые клавиатуры.

Элиночка5566 22 нояб. 2020 г., 05:27:25 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Как исправить ошибку в коде программы?

(чтобы программа распознавала IOResult ).

Целуйкиса 2 авг. 2020 г., 12:14:05 | 5 - 9 классы

Напишите программу, которая строит "линию" из знаков ' - ' заданной длины?

Напишите программу, которая строит "линию" из знаков ' - ' заданной длины.

Используйте процедуру.

Входные данные Входная строка содержит единственное натуральное число – длину линии N .

Выходные данные Программа должна вывести N знаков ' - '.

ПРОГРАММА - PYTHON !

Только PYTHON !

Индира41 29 нояб. 2020 г., 15:53:03 | 10 - 11 классы

ПОМОГИТЕ ИСПРАВИТЬ КОД, ЯЗЫК СИ Напишите программу поиска максимального из четырех чисел с использованием функции поиска большего из двух?

ПОМОГИТЕ ИСПРАВИТЬ КОД, ЯЗЫК СИ Напишите программу поиска максимального из четырех чисел с использованием функции поиска большего из двух.

Diana161228 13 сент. 2020 г., 03:52:55 | 10 - 11 классы

Напишите программу, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет, верно ли, что знаки элементов этой последовательности чередуются?

Напишите программу, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет, верно ли, что знаки элементов этой последовательности чередуются.

На этой странице сайта вы найдете ответы на вопрос Как исправить программу что бы выдовал что знаки чередуются?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.