Написать программу, которая выведет все числа кратные 3 в диапазоне от 26 до 87?

Информатика | 5 - 9 классы

Написать программу, которая выведет все числа кратные 3 в диапазоне от 26 до 87.

Ответить на вопрос
Ответы (2)
Sеvиlьka 24 февр. 2020 г., 12:26:02

Решение №1 (через целочисленное деление)

var a : integer ;

begin a : = 26 ; repeat if a mod 3 = 0 then write(a : 3) ; a : = a + 1 ; until a > ; 87 ;

end.

Решение №2 (без целочисленного деления)

Заметим, что первое число в данном диапазоне кратное 3 равно 27.

Тогда каждое следуещее число на 3 больше предыдущего :

var a : integer ;

begin a : = 27 ; repeat write(a : 3) ; a : = a + 3 ; until a > ; 87 ;

end.

Xumi 24 февр. 2020 г., 12:26:09

/ / Pascal ABC.

NET v3.

1 сборка 1172

begin

range(26, 87).

Where(x - > ; x mod 3 = 0).

Println(', ') ;

end.

Alex201500464749 23 февр. 2020 г., 05:01:17 | 5 - 9 классы

Написать программу которая 20 раз выведет слово информатика на экран?

Написать программу которая 20 раз выведет слово информатика на экран.

Arina464646 3 нояб. 2020 г., 06:13:30 | 10 - 11 классы

Составьте программу в Pascal ABC которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150?

Составьте программу в Pascal ABC которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150.

Спасибо заранее.

Даниил19992001 27 нояб. 2020 г., 03:48:34 | 5 - 9 классы

Помогите пожалуйста составить программу?

Помогите пожалуйста составить программу.

Дано целое положительное число n.

Составить программу, которая, если число четное, выведет последнюю цифру этого числа.

Средия 23 янв. 2020 г., 15:36:50 | 5 - 9 классы

Напишите процедуру, которая выведет на экран в столбик все цифры переданного ей числа, начиная с первой нужно полностью написать программу?

Напишите процедуру, которая выведет на экран в столбик все цифры переданного ей числа, начиная с первой нужно полностью написать программу.

Annasuper62 21 сент. 2020 г., 23:24:49 | 5 - 9 классы

Написать программу, которая выводит на экран все числа кратные 4 в промежутке от a до и?

Написать программу, которая выводит на экран все числа кратные 4 в промежутке от a до и.

11luybov22 17 янв. 2020 г., 17:04:21 | 5 - 9 классы

Помогите?

Помогите!

Написать программу, которая определяет кратна ли числу А сумма цифр двухзначного числа.

Altunyashegeno 18 февр. 2020 г., 09:25:44 | 5 - 9 классы

Написать программу на PascalABC которая при выполнение выведет на экран 10 слов привет?

Написать программу на PascalABC которая при выполнение выведет на экран 10 слов привет.

Protegemarie 6 янв. 2020 г., 05:39:47 | 10 - 11 классы

Написать программу, которая выводит двоичное представление введенного с клавиатуры десятичного числа в диапазоне от 0 до 255?

Написать программу, которая выводит двоичное представление введенного с клавиатуры десятичного числа в диапазоне от 0 до 255.

В паскале.

Rail233737 11 сент. 2020 г., 20:53:11 | 10 - 11 классы

Написать программу проверки попадания введенного числа в диапазон от - 2 до 2?

Написать программу проверки попадания введенного числа в диапазон от - 2 до 2.

Vladislavsurkovich 23 окт. 2020 г., 02:13:09 | 5 - 9 классы

Написать программу которая выводит квадраты всех четных чисел в диапазоне от а до б?

Написать программу которая выводит квадраты всех четных чисел в диапазоне от а до б.

Вопрос Написать программу, которая выведет все числа кратные 3 в диапазоне от 26 до 87?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.