№1. Дан массив из 30 - ти элементов?

Информатика | 10 - 11 классы

№1. Дан массив из 30 - ти элементов.

Каждый элемент может принимать целочисленные значения от - 100 до 100.

Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива.

№2. Дан массив из 40 элементов.

Каждый элемент может принимать целочисленные значения от 0 до 200.

Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива.

Ответить на вопрос
Ответы (1)
Anyamayor2015 8 нояб. 2020 г., 18:37:36

Var a : array[1.

40] of integer ;

i, j, cou, coumax, amax : integer ;

begin coumax : = 0 ; for i : = 1 to 40 do readln(a[i]) ; for i : = 1 to 40 do begin cou : = 0 ; for j : = 1 to 40 do if(a[i] = a[j]) then inc(cou) ; if(cou> ; coumax) then begin coumax : = cou ; amax : = a[i] ; end ; writeln(amax, 'is the most repeated value') ;

end.

Var a1, temp, cou, i, sum : integer ;

begin read(a1) ; if (a1> ; = 0) then cou : = 1 else cou : = 0 ; if (cou> ; 0) then sum : = a1 else sum : = 0 ; for i : = 2 to 40 do begin read(temp) ; if (temp> ; 0) and (temp mod a1 = 0) then begin inc(cou) ; inc(sum, temp) ; end ; end ; writeln(sum / cou)

end.

Maxim12003 28 мая 2020 г., 13:08:15 | 5 - 9 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать произвольные значения.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.

Но лучше на языке Паскаль.

Alsuska18 11 апр. 2020 г., 04:10:32 | 5 - 9 классы

Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не деля?

Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не делятся на 3.

Drdr0984 15 дек. 2020 г., 04:50:15 | 5 - 9 классы

Написать программу на языке си + + Дан массив из 10 целочисленных элементов?

Написать программу на языке си + + Дан массив из 10 целочисленных элементов.

Посчитать сумму всех элементов массива.

Zhjkckfdf 3 авг. 2020 г., 13:42:16 | 10 - 11 классы

Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000?

Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000.

Напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3 на языке Pascal желательно.

Bog100 12 мая 2020 г., 16:05:02 | 5 - 9 классы

Дан целочисленный массив из 30 элементов?

Дан целочисленный массив из 30 элементов.

Элементы массива могут принимать значения от 0 до 1000.

Напишите программу, позволяющую найти и вывести количество элементов массива, кратных трём, запись которых заканчивается цифрой 1.

Паскаль АБС.

Alinapolskaya 3 июн. 2020 г., 06:42:23 | 10 - 11 классы

Дан массив из 40 элементов ?

Дан массив из 40 элементов .

Каждый элемент может принимать целочисленные значения от 0 до 300.

Опишите на русском языкке или на паскале алгоритм, который позволит найти произведение тех элементов массива , которые имеют нечётный индекс и кратны трем.

Гарантируется , что хотя бы один элемент массива удовлетворяет этому условию.

4yBAK4 28 окт. 2020 г., 14:55:27 | 5 - 9 классы

Дан целочисленный массив из 10 элементов?

Дан целочисленный массив из 10 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

Yankaru 28 сент. 2020 г., 03:54:42 | 10 - 11 классы

1. Вывести ряд чисел 5, 14, 41, 122, 365 учитывая, что первый элемент массива равен 2 3?

1. Вывести ряд чисел 5, 14, 41, 122, 365 учитывая, что первый элемент массива равен 2 3.

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от - 10000 до 10000 включительно.

Напишите программу, позволяющую найти и вывести количество пар элементов, в которых сумма элементов делится на 3, но не делится на 9.

В данной задаче под парой подразумеваются два соседних элемента массива.

Эльвиркин1 18 авг. 2020 г., 17:18:38 | 5 - 9 классы

Ребят помогите пожалуйста решить задачу по Паскалю?

Ребят помогите пожалуйста решить задачу по Паскалю.

Дан целочисленный массив из 30 элементов, элементы массива могут принимать значения от 0 до 100.

Напишите эффективную программу которая позволит найти и вывести на печать сумму элементов делющихся на 5 без остатка.

Известно, что в массиве есть хотябы один элемент делящийся на 5 без остатка.

Формачет 13 дек. 2020 г., 21:33:43 | 10 - 11 классы

Дан целочисленный массив А из 100 элементов?

Дан целочисленный массив А из 100 элементов.

Написать программу, которая выдает на экран элементы массива, встречающиеся более одного раза.

Вы перешли к вопросу №1. Дан массив из 30 - ти элементов?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.