Pascal только?

Информатика | 5 - 9 классы

Pascal только!

Помогите!

Даю 30 баллов Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

Входные данные В первой строке вводятся через пробел координаты первой точки (сначала x - координата, потом y - координата), во второй строке в том же порядке – координаты второй точки.

Все координаты – вещественные числа.

Выходные данные Программа должна вывести одно число : расстояние между точками с тремя знаками в дробной части.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - входные данные 1.

1. 2.

2. выходные данные 1.

414.

Ответить на вопрос
Ответы (1)
DashaPotor180603 6 сент. 2020 г., 22:35:13

Var x1, y1, x2, y2, d : real ;

begin write('первая точка : x y') ; readln(x1, y1) ; write('вторая точка : x y') ; readln(x2, y2) ; d : = sqrt(sqr(x2 - x1) + sqr(y2 - y1)) ; writeln('расстояние : ', d) ;

end.

Superfilatov20 26 нояб. 2020 г., 11:55:52 | 10 - 11 классы

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними?

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

(Программа должна вывести одно число : расстояние между точками с тремя знаками в дробной части.

) совсем не получается решить , помогите пожалуйста.

Yxtbl2013 7 июн. 2020 г., 09:09:14 | 5 - 9 классы

Dev_c + + Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними?

Dev_c + + Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

МиланаКлещёва 10 нояб. 2020 г., 09:24:55 | 10 - 11 классы

Напишите программу которая вводит координаты двух точек на числовой оси и выводит расстояние между ними?

Напишите программу которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

Учитывайте , что первой может быть введена меньшая координата.

ЮLьчa 15 февр. 2020 г., 04:54:58 | 5 - 9 классы

Помогите пожалуйста решить?

Помогите пожалуйста решить!

Даны две точки в плоской прямоугольной системе координат.

Напишите программу, определяющую, которая из точек находится ближе к началу координат!

Пример входных данных Координаты 1 - й точки > ; > ; 1 2 Координаты 2 - й точки > ; > ; 3 4 1 ая точка ближе Пожалуйста с примером!

Заранее большое спасибо!

Jgf 26 мая 2020 г., 04:32:04 | 10 - 11 классы

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними?

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

(Программа должна вывести одно число : расстояние между точками с тремя знаками в дробной части.

) совсем не получается решить , помогите пожалуйста.

123нога 9 авг. 2020 г., 13:09:19 | 10 - 11 классы

С4 информатика?

С4 информатика.

Вам дано n точек на плоскости.

Выведите все исходные точки в порядке возрастания их расстояний от начала координат.

Формат ввода Программа получает на вход набор точек на плоскости.

Сначала задано количество точек n, затем идет последовательность из n строк, каждая из которых содержит два числа : координаты точки.

Величина n не превосходит 100, все исходные координаты – целые числа, по модулю не превосходящие 10 ^ 3.

Karolina197 30 дек. 2020 г., 11:02:39 | 5 - 9 классы

Даны две точки в плоской прямоугольной системе координат?

Даны две точки в плоской прямоугольной системе координат.

Напишите программу, определяющую, которая из точек находится ближе к началу координат.

Netepluk36 6 мая 2020 г., 13:32:28 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания?

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания.

Входные данные : Входная строка содержит одно натуральное число N .

Выходные данные : Программа должна вывести в одну строчку через пробел чётные положительные степени числа 2, не большие, чем N , в порядке убывания.

Если таких нет, программа должна вывести число 0.

Анютка355 21 янв. 2020 г., 02:55:58 | 10 - 11 классы

Входные данные Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата)?

Входные данные Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата).

Выходные данные Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.

Маша133 31 окт. 2020 г., 06:11:15 | 10 - 11 классы

Напишите программу, которая удаляет из строки все повторяющиеся символы?

Напишите программу, которая удаляет из строки все повторяющиеся символы.

Входные данные

На вход программы подаётся строка, содержащая символы таблицы ASCII.

Выходные данные

Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Примеры

входные данные

abc13a1b2z3c

выходные данные

abc132z

входные данные

QWasd123

выходные данные

QWasd123

Pascal ABC 1.

8.

На странице вопроса Pascal только? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.