Дан массив 5x5 заполнить двухзначными числами и вывести его?

Информатика | 5 - 9 классы

Дан массив 5x5 заполнить двухзначными числами и вывести его.

А ниже вывести массив поменяв первую и последнюю строчки.

Помогите пожалуйста.

Ответить на вопрос
Ответы (1)
Valentino201558 3 дек. 2020 г., 08:35:33

Const n = 5 ;

var

a : array[1.

N, 1.

N] of integer ;

i, j, c : integer ;

begin

Randomize ;

writeln('Исходный массив : ') ;

for i : = 1 to n do

begin

for j : = 1 to n do begin a[i, j] : = random(50) ; write(a[i, j] : 4) ; end ; writeln ;

end ;

for j : = 1 to n do begin c : = a[1, j] ; a[1, j] : = a[n, j] ; a[n, j] : = c ; end ;

writeln('Полученный массив : ') ;

for i : = 1 to n do

begin

for j : = 1 to n do write(a[i, j] : 4) ;

writeln ;

end ;

end.

Пример :

Исходный массив : 47 36 39 31 0 843 31 16 17 24 12 18 18 39 17 19 0 28 8 1610 18 6 28

Полученный массив : 16 10 18 6 28 8 43 31 16 17 24 12 18 18 39 17 19 0 28 8 47 36 39 31 0.

Juliacom667 27 авг. 2020 г., 09:34:59 | 10 - 11 классы

Заполнить массив из 8 элементов числами с клавиатуры найти и вывести их минимальный элемент?

Заполнить массив из 8 элементов числами с клавиатуры найти и вывести их минимальный элемент.

Sailencn 21 дек. 2020 г., 06:20:09 | 5 - 9 классы

В виде программ : 1 Заполнить массив N числами(N< ; = 1000), введенными с клавиатуры?

В виде программ : 1 Заполнить массив N числами(N< ; = 1000), введенными с клавиатуры.

Вывести числа в строку в прямом и обратном порядке.

2 Ввести число.

Заполнить массив цифрами числа.

Вывести цифры числа в строку.

3 Заполнить массив четными числами из интервала [a, b].

Вывести числа в строку в обратном порядке.

Popoi 17 апр. 2020 г., 01:20:08 | 5 - 9 классы

Решите срочно дан массив B15 поменять элементы на противоположные по знаку и вывести массив на экран?

Решите срочно дан массив B15 поменять элементы на противоположные по знаку и вывести массив на экран.

Tusha06 28 июн. 2020 г., 17:36:54 | 5 - 9 классы

Помогите, пожалуйста, СРОЧНО?

Помогите, пожалуйста, СРОЧНО!

Составить программу : Заполнить массив из 10 элементов с клавиатуры целыми положительными и отрицательными числами и вывести на экран в строчку только отрицательные числа.

Ulia026 12 мар. 2020 г., 22:54:59 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

Срочно нужно.

Дан одномерный массив, состоящий из 10 элементов.

Вывести на экран в строчку.

Поменять местами значения от 6 - 10 элементов массива элементов массива и снова вывести на экран!

Helz 21 июл. 2020 г., 13:49:40 | 10 - 11 классы

Дан массив из 50 чисел?

Дан массив из 50 чисел.

Заполните его случайными числами.

Вывести на экран сначала все положительные его элементы, а затем все отрицательные.

Mkeler 28 окт. 2020 г., 12:37:18 | 10 - 11 классы

Заполнить массив произвольными числами?

Заполнить массив произвольными числами.

Вывести полученный массив на экран.

( Delphi7).

Fvfvfv333333333 10 мая 2020 г., 23:32:14 | 10 - 11 классы

Сформировать одномерный целочисленный массив размерностью N?

Сформировать одномерный целочисленный массив размерностью N.

Поменять местами первый элемент с последним, второй с предпоследним.

Вывести на экран исходный и итоговый массивы.

Маша999910 26 мар. 2020 г., 23:07:43 | 5 - 9 классы

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале)?

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале).

XT9 9 сент. 2020 г., 16:59:24 | 5 - 9 классы

Дан массив все элементы уменьши на число С?

Дан массив все элементы уменьши на число С.

Число С вывести с клавиатуры.

Перед вами страница с вопросом Дан массив 5x5 заполнить двухзначными числами и вывести его?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.