Найти значения минимального элемента одномерного целочисленного массива?

Информатика | 10 - 11 классы

Найти значения минимального элемента одномерного целочисленного массива.

Ответить на вопрос
Ответы (2)
130781 13 янв. 2021 г., 21:22:08

/ / PascalABC.

NET 3.

1, сборка 1218 от 12.

04. 2016

begin var a : = ArrRandom(ReadInteger('n = '), 10, 50) ; a.

Println ; var m : = a.

Min ; Write('Номера минимальных элементов (', m, ') : ') ; a.

Select((x, i) - > ; Rec(x, i + 1)).

Where(x - > ; x.

Item1 = m) .

Select(x - > ; x.

Item2).

Println(', ') ;

end.

Тестовое решение :

n = 20

34 15 12 31 38 43 12 24 13 49 25 33 16 12 25 33 46 16 38 34

Номера минимальных элементов (12) : 3, 7, 14.

Олег1979 13 янв. 2021 г., 21:22:13

/ / Pascal ABC.

NET v3.

1 сборка 1172

Const

n = 5 ;

Var

ar : array[1.

N] of integer ;

i, min : integer ;

sa : set of integer ;

begin

min : = MaxInt ;

for i : = 1 to n do begin readln(ar[i]) ; if ar[i]< ; = min then begin if ar[i] = min then sa : = sa + [i] else sa : = [i] ; min : = ar[i] ; end ; end ;

writeln('Min = ', min) ;

writeln('Index : ', sa) ;

end.

Пример ввода :

98777

Пример вывода :

Min = 7Index : {5, 4, 3}.

Iluha515 1 янв. 2021 г., 15:40:10 | 10 - 11 классы

Дан одномерный целочисленный массив?

Дан одномерный целочисленный массив.

Найти : сумму элементов массива, расположенных между первым и последним нулевыми элементами.

Помогите написать код на Delphi.

Elena135 2 июл. 2021 г., 16:51:21 | 1 - 4 классы

PASCALВ одномерном целочисленном массиве из n - элементов, вычислить сумму элементов, кратных 5?

PASCAL

В одномерном целочисленном массиве из n - элементов, вычислить сумму элементов, кратных 5.

VADC23 28 июл. 2021 г., 12:35:01 | 10 - 11 классы

Разработать алгоритм и программу поиска в одномерном массиве минимального и максимального числа?

Разработать алгоритм и программу поиска в одномерном массиве минимального и максимального числа.

На экран выдать исходный массив, значения и индексы всех чисел, равных максимальному и минимальному элементам массива.

Maxim000099 13 февр. 2021 г., 22:07:07 | 10 - 11 классы

Создать программу получения и обработки одномерного массива – вектора :Вычислить значения 35 элементов одномерного целочисленного массива F в интервале ( - 6, 10) с использованием генератора случайных?

Создать программу получения и обработки одномерного массива – вектора :

Вычислить значения 35 элементов одномерного целочисленного массива F в интервале ( - 6, 10) с использованием генератора случайных чисел.

GroundZero 15 мая 2021 г., 16:39:36 | 5 - 9 классы

Известны значения элементов одномерного целочисленного массива a, состоящего из 5 элементов?

Известны значения элементов одномерного целочисленного массива a, состоящего из 5 элементов.

Sad3000 31 окт. 2021 г., 07:08:14 | 5 - 9 классы

Дан одномерный целочисленный массив ?

Дан одномерный целочисленный массив .

Найти произведение элементов массива , меньших 10( срочно пожалуйста ).

Тяьвьв 12 июн. 2021 г., 08:24:37 | 10 - 11 классы

Дан одномерный массив T 12?

Дан одномерный массив T 12.

Найти разность между максимальным и минимальным элементом массива.

Len46 4 июл. 2021 г., 22:23:57 | 5 - 9 классы

Одномерный целочисленный массив из 15 элементов задан случайным образом на отрезке от 0 до 200 найдите минимальный элемент этого массива?

Одномерный целочисленный массив из 15 элементов задан случайным образом на отрезке от 0 до 200 найдите минимальный элемент этого массива!

MikkyMauss 26 сент. 2021 г., 09:31:57 | 5 - 9 классы

Составить программу , позволяющую найти номер минимального элемента среди элементов одномерного числового массива , имеющих четные индексы ?

Составить программу , позволяющую найти номер минимального элемента среди элементов одномерного числового массива , имеющих четные индексы .

Kenizorova 25 июн. 2021 г., 06:57:17 | студенческий

Для одномерного целочисленного массива из 20 элементов решить задачу поиска номера первого нечетного элемента?

Для одномерного целочисленного массива из 20 элементов решить задачу поиска номера первого нечетного элемента.

PASCAL

Плесс.

Если вам необходимо получить ответ на вопрос Найти значения минимального элемента одномерного целочисленного массива?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.