1) Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then c : = b div (a mod c) else c : = a div?

Информатика | 5 - 9 классы

1) Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then c : = b div (a mod c) else c : = a div (b mod c) 2) Укажите результат выполнения программы var a, b : integer ; procedure proc(var a : integar ; b : integar) ; begin b : = 4 ; a : = 6 ; b : = a + b ; end ; begin a : = 2 ; b : = 3 ; proc(a, b) ; writeIn(a, ' ', b) ; end.

Пожалуйста!

Хотя бы одну!

Ответить на вопрос
Ответы (1)
Ddmitriisaferov 20 апр. 2020 г., 14:42:59

1) c = 12

2) a = 6, b = 3.

Taniafilippova 4 нояб. 2020 г., 01:39:16 | 10 - 11 классы

Чему будет равно значение переменной c в результате выполнения фрагмента программы a : = 1257 ; c : = 0 ; while a> ; 0 do begin if a mod 2< ; > ; 0 then b : = a mod 10 ; c : = c + b ; a : = a di?

Чему будет равно значение переменной c в результате выполнения фрагмента программы a : = 1257 ; c : = 0 ; while a> ; 0 do begin if a mod 2< ; > ; 0 then b : = a mod 10 ; c : = c + b ; a : = a div 10 ; end ; 1) 5 ; 2) 13 ; 3) 16 ; 4) 18.

Vip93miha 17 нояб. 2020 г., 10:43:52 | 5 - 9 классы

Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then?

Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then.

C : = b div (a mod c) else c : = a div (b mod c) 1) 0 ; 2) 1 ; 3) 12 ; 4) 125.

Богдана1231 16 нояб. 2020 г., 18:57:11 | 10 - 11 классы

Чему будет равно значение переменной "С" в результате выполнения фрагмента программы a : = 1257 ; c : = 0 ; while a> ; 0 do begin if a mod 2< ; > ; 0 then b : = a mod 10 ; c : = c + b ; a : = a ?

Чему будет равно значение переменной "С" в результате выполнения фрагмента программы a : = 1257 ; c : = 0 ; while a> ; 0 do begin if a mod 2< ; > ; 0 then b : = a mod 10 ; c : = c + b ; a : = a div 10 ; end ; 1) 5 ; 2) 13 ; 3) 16 ; 4) 18.

Antonharitonov0 28 янв. 2020 г., 01:46:32 | 10 - 11 классы

Помогите Срочно?

Помогите Срочно!

Чему будет равен результат выполнения программы, если ввести значения для a = 2468?

Program c22 ; var a, b : integer ; k : integer ; begin K : = 0 ; readln(a) ; while (a< ; > ; 0) do begin b : = a mod 10 ; if b mod 2 = 0 then inc(k) ; a : = a div 10 ; end ; writeln(k) ; end.

A) 9 Б)3 В)0 Г)4.

Vlasova123 1 авг. 2020 г., 00:14:42 | 5 - 9 классы

Что будет выведено на экран в результате выполнения следующей программы, если ввести число x = 521?

Что будет выведено на экран в результате выполнения следующей программы, если ввести число x = 521?

Var x, c1, c2, c3, c4 : integer ; Begin writeln(“введите трехзначное число”) ; Readln(x) ; c1 : = x mod 10 ; c2 : = x div 10 ; c3 : = c2 mod 10 ; c4 : = x div 100 ; Writeln(c1, c2, c3, c4) ; End.

Amo1244 13 янв. 2020 г., 21:02:10 | 5 - 9 классы

Пожалуйста помогите решить инфознайку 2015г?

Пожалуйста помогите решить инфознайку 2015г.

Чему будет равно значение переменной c в результате выполнения фрагмента программы a = 125 ; b = 25 ; c = 12 ; if a div 25 = 0 then if a mod 12 = 0 then c : = div (a mod c) else c : = a div (b mod c) варианты ответов : 1)0 2)1 3)12 4)125.

ArtDaviant 27 мая 2020 г., 10:44:45 | 10 - 11 классы

Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд?

Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд.

В чем ошибка?

Program upr4 ; var n, m, i : longint ; a, b, c, e, f, k : integer ; begin m : = 0 ; for i : = 100000 to 999999 do begin k : = n mod 10 ; f : = (n div 10) mod 10 ; e : = (n div 100) mod 10 ; c : = (n div 1000) mod 10 ; b : = (n div 10000) mod 10 ; a : = (n div 100000) mod 10 ; if k + f + e = a + b + c then m : = m + 1 else m : = m ; end ; writeln (m) ; end.

FencerLV 22 июл. 2020 г., 19:36:33 | 5 - 9 классы

Чему будет равно значение переменной c в результате выполнения фрагмента программы a : = 1257 ; c : = 0 ; while a> ; 0 do begin if a mod 2< ; > ; 0 then b : = a mod 10 ; c : = c + b ; a : = a di?

Чему будет равно значение переменной c в результате выполнения фрагмента программы a : = 1257 ; c : = 0 ; while a> ; 0 do begin if a mod 2< ; > ; 0 then b : = a mod 10 ; c : = c + b ; a : = a div 10 ; end ; 1) 5 ; 2) 13 ; 3) 16 ; 4) 18.

Daniil200499 21 февр. 2020 г., 14:44:47 | 5 - 9 классы

Чему будет равно значение переменной c в результате выполнения фрагмента программы a : = 125, b : = 25, c : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then c : = b div (a mod c) else c : = a div (b m?

Чему будет равно значение переменной c в результате выполнения фрагмента программы a : = 125, b : = 25, c : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then c : = b div (a mod c) else c : = a div (b mod c) 1) 0 ; 2)1 ; 3)12 ; 4)125.

Огре 1 июн. 2020 г., 11:16:37 | 5 - 9 классы

Помогите пожалуйста 1?

Помогите пожалуйста 1.

Чему будет равна переменная «c» после выполнения этой программы : a : = 28 ; b : = 7 ; b : = a div b + b ; c : = a mod b + a ; Ответ : 2.

Чему будет равна переменная «c» после выполнения этой программы : a : = 26 ; b : = 6 ; c : = a mod b + b ; Ответ : 3.

Чему будет равна переменная «c» после выполнения этой программы : a : = 28 ; b : = 7 ; c : = a div b + a ; Ответ : 4.

Чему будет равна переменная «c» после выполнения этой программы : a : = 22 ; b : = 4 ; b : = a div b ; c : = a div b ; Ответ : 5.

Чему будет равна переменная «c» после выполнения этой программы : a : = 26 ; b : = 6 ; b : = a mod b + 4 ; c : = a mod b + 1 ; Ответ : 6.

Чему будет равна переменная «c» после выполнения этой программы : a : = 20 ; b : = 3 ; b : = a div b ; c : = a mod (b + 1) ; Ответ : 7.

Чему будет равна переменная «c» после выполнения этой программы : a : = 28 ; b : = 7 ; b : = a mod b ; c : = a div (b + 1) ; Ответ :

На этой странице находится вопрос 1) Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then c : = b div (a mod c) else c : = a div?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.