Создайте программы на языке PascalABC : 1) Введите два числа (например A = 5 и В = 8) и найдите их произведение, используя цикл с постусловием и только операцию сложения?

Информатика | 5 - 9 классы

Создайте программы на языке PascalABC : 1) Введите два числа (например A = 5 и В = 8) и найдите их произведение, используя цикл с постусловием и только операцию сложения.

2) Введите два числа (например A = 45 и В = 8) и найдите их остаток от деления нацело, используя цикл с постусловием и только операцию вычитания.

3) Определить значение переменной S после выполнения следующих операторов : S : = 6 ; i : = 3 ; Repeat S : = S + 5 div i ; i : = i – 1 ; Until i.

Ответить на вопрос
Ответы (1)
Владка2005 31 окт. 2020 г., 02:32:45

Var

a, b, i, r : integer ;

begin

writeln('введите значения для A и B') ;

readln(a, b) ;

i : = 0 ;

r : = 0 ;

repeat

r : = r + b ;

i : = i + 1 ;

until i = a ;

writeln('ответ ', r)

end.

Var

a, b, i, r : integer ;

begin

writeln('введите значения для A и B') ;

readln(a, b) ;

i : = a ;

r : = 0 ;

repeat

i : = i - b ;

r : = i ;

until i< ; b ;

writeln('ответ ', r) ;

end.

Cat1818 15 сент. 2020 г., 20:55:54 | 10 - 11 классы

На языке программирования Turbo Pascal, используя цикл с предусловием, цикл с постусловием и цикл с счетчиком, напишите программы, вычисляющую факториал числа, введённого с клавиатуры?

На языке программирования Turbo Pascal, используя цикл с предусловием, цикл с постусловием и цикл с счетчиком, напишите программы, вычисляющую факториал числа, введённого с клавиатуры.

Факториал : N!

= 1 * 2 * 3 * … * N Например : 4!

= 1 * 2 * 3 * 4 = 24.

Dayana03200307 7 мая 2020 г., 02:08:04 | 5 - 9 классы

Составить программу , используя цикл с постусловием : Вывести на экран все четные числа от 16 до 24?

Составить программу , используя цикл с постусловием : Вывести на экран все четные числа от 16 до 24!

Только пожалуйста в паскале.

Gladchenko20104 22 окт. 2020 г., 22:32:05 | 5 - 9 классы

Ведите два числа например А = 45 и B = 8 и найдите их частное от деления нацело в переменной А, используя только операцию вычитания?

Ведите два числа например А = 45 и B = 8 и найдите их частное от деления нацело в переменной А, используя только операцию вычитания.

Помогитеее!

Настя123999 15 мар. 2020 г., 18:41:35 | 10 - 11 классы

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием»?

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием».

Найти сумму и произведение первых n натуральных чисел.

Йысцвсйычцвс 7 авг. 2020 г., 20:55:56 | 5 - 9 классы

Даны целые положительные числа N и K?

Даны целые положительные числа N и K.

Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.

Gevork65 8 июл. 2020 г., 03:50:21 | 10 - 11 классы

Циклы с постусловиями?

Циклы с постусловиями.

Разработать схему алгоритма и написать программный код на языке Паскаль.

Используя оператор Repeat Until.

Настя695 3 июн. 2020 г., 22:58:21 | 10 - 11 классы

Написать программу, которая вычисляет факториал числа, введенного с клавиатуры, используя цикл с постусловием?

Написать программу, которая вычисляет факториал числа, введенного с клавиатуры, используя цикл с постусловием.

Язык - pascal.

Nelli034 5 сент. 2020 г., 19:21:15 | 5 - 9 классы

Написать программу, которая вычисляет произведение чисел, введенных с клавиатуры, пока не введено «0»?

Написать программу, которая вычисляет произведение чисел, введенных с клавиатуры, пока не введено «0».

Использовать цикл с постусловием.

Pascal.

Павлуша11 9 нояб. 2020 г., 15:14:11 | 10 - 11 классы

Цикл с постусловием ( Repeat, ДО) Требуется ввести двузначное число, если пользователь вводит число не удовлетворяющее условию, то ему предлагается вновь вводить число, до тех пор пока нужное число не?

Цикл с постусловием ( Repeat, ДО) Требуется ввести двузначное число, если пользователь вводит число не удовлетворяющее условию, то ему предлагается вновь вводить число, до тех пор пока нужное число не будет введено.

Egorovalex91 5 окт. 2020 г., 02:31:01 | 5 - 9 классы

Даны целые положительные числа N и K?

Даны целые положительные числа N и K.

Используя только операции сложения и вычитания, найдите частное от деления нацело N на K, а также остаток от этого деления.

ОЧЕНЬ СРОЧНО, прошу!

Вопрос Создайте программы на языке PascalABC : 1) Введите два числа (например A = 5 и В = 8) и найдите их произведение, используя цикл с постусловием и только операцию сложения?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.