7. 4?

Информатика | 10 - 11 классы

7. 4.

Описать массив из тридцати записей—точек на плоско - сти.

Заполнить его случайно выбранными координатами—числами в диапазоне от −10 до 100.

Написать функцию, которая получает две точки и возвращает расстояние между этими точками.

Используя написанную функцию определить, какая из точек находится на наибольшем расстоянии от начала координат.

Вывести на экран номер точки в массиве и ее координаты.

Если решений несколько, вывести все.

Помогите написать программу не пойму как сделать.

Ответить на вопрос
Ответы (1)
Nikoletta0 4 авг. 2020 г., 19:58:12

Var

K : array[1.

2, 1.

13] of integer ;

i, j, ind, x, y : integer ;

MAX : real ;

function RAST(x1, x2, y1, y2 : integer) : real ;

begin RAST : = sqrt(sqr(x2 - x1) + sqr(y2 - y1)) ; end ;

begin

MAX : = - 2 * sqr( - 10 - 1) ;

randomize ;

writeln('Исходные точки : ') ;

for j : = 1 to 13 do begin writeln('Точка №', j, ', с координатами(X, Y)') ; for i : = 1 to 2 do begin K[i, j] : = random(110) - 10 ; write(K[i, j], ' ') ; end ; writeln ; end ;

for i : = 1 to 13 do if RAST(0, K[1, i], 0, K[2, i])> ; MAX then begin MAX : = RAST(0, K[1, i], 0, K[2, i]) ; x : = K[1, i] ; y : = K[2, i] ; ind : = i ; end ;

writeln('Номер точки : ', ind, ' Координаты : ', x, ' ; ', y) ;

end.

12233435454656576878 8 мар. 2020 г., 23:44:24 | 5 - 9 классы

Помогите, пожалуйста, срочно, информатика 9 класс?

Помогите, пожалуйста, срочно, информатика 9 класс!

Написать программу, которая выводит на экран сообщение, в какую четверть координатной плоскости попала точка с заданными координатами.

Координаты точки вводятся с клавиатуры.

Например, X = 4, Y = 6 она должна вывести "точка лежит в 1 четверти".

Superfilatov20 26 нояб. 2020 г., 11:55:52 | 10 - 11 классы

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними?

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

(Программа должна вывести одно число : расстояние между точками с тремя знаками в дробной части.

) совсем не получается решить , помогите пожалуйста.

Jgf 26 мая 2020 г., 04:32:04 | 10 - 11 классы

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними?

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

(Программа должна вывести одно число : расстояние между точками с тремя знаками в дробной части.

) совсем не получается решить , помогите пожалуйста.

Shhekochikhinas 16 авг. 2020 г., 01:31:20 | 10 - 11 классы

Из окна формы вводятся координаты точки на плоскости (x, y)?

Из окна формы вводятся координаты точки на плоскости (x, y).

Вычислить и вывести в окно формы полярные координаты точки по формулам.

Написать на паскале.

Karolina197 30 дек. 2020 г., 11:02:39 | 5 - 9 классы

Даны две точки в плоской прямоугольной системе координат?

Даны две точки в плоской прямоугольной системе координат.

Напишите программу, определяющую, которая из точек находится ближе к началу координат.

Katykornouhova 7 дек. 2020 г., 00:57:20 | 10 - 11 классы

Массив из 15 элементов заполнить случайным образом в диапазоне [0?

Массив из 15 элементов заполнить случайным образом в диапазоне [0.

100].

Вывести на экран все элементы массива меньшие 33.

Aleksa250804 14 нояб. 2020 г., 09:47:07 | 5 - 9 классы

Написать программу, на Pascal, которая определяет принадлежит ли точка плоскости A отрезку с конечными точками B и С?

Написать программу, на Pascal, которая определяет принадлежит ли точка плоскости A отрезку с конечными точками B и С.

Программа получает на вход координаты точек А, В и С, и выводит ответ (да или нет).

Bakunova02 10 февр. 2020 г., 16:22:07 | 5 - 9 классы

Написать программу, которая вводит массив из N вещественных случайных чисел, лежащих в диапазоне от - 10 до 10?

Написать программу, которая вводит массив из N вещественных случайных чисел, лежащих в диапазоне от - 10 до 10.

Вывести на экран полученный массив и массив, составленный только из нечётных элементов исходного.

Протестировать программу.

Anagra333 11 окт. 2020 г., 21:29:57 | 5 - 9 классы

Пожалуйста?

Пожалуйста!

Помогите написать код для программы с процедурой!

Составьте процедуру, которая определяет точки, расстояние между которыми максимально и минимально.

Координаты точек заданы в массивах X(n), Y(n), n< ; = 20.

Использовать составленную процедуру для массивов X1, Y1, вывести номера найденных точек, а также расстояние между ними.

Язык С.

Starsarms 23 окт. 2020 г., 19:05:02 | 5 - 9 классы

Введите с клавиатуры координаты точки на плоскости(целочисленные)?

Введите с клавиатуры координаты точки на плоскости(целочисленные).

Выведите на экран квадрат расстояния от начала координат до этой точки.

Перед вами страница с вопросом 7. 4?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.