Дан массив из 40 элементов ?

Информатика | 10 - 11 классы

Дан массив из 40 элементов .

Каждый элемент может принимать целочисленные значения от 0 до 300.

Опишите на русском языкке или на паскале алгоритм, который позволит найти произведение тех элементов массива , которые имеют нечётный индекс и кратны трем.

Гарантируется , что хотя бы один элемент массива удовлетворяет этому условию.

Ответить на вопрос
Ответы (1)
Nastya21980 3 июн. 2020 г., 06:42:26

Uses crt ;

const n = 40 ;

var a : array[1.

N] of integer ;

i : integer ;

pr : longint ;

begin

randomize ;

pr : = 1 ;

for i : = 1 to n do

begin

a[i] : = random(300) ;

write(a[i] : 4) ;

if (i mod 2< ; > ; 0) and (a[i] mod 3 = 0) then

pr : = pr * a[i] ;

end ;

writeln(pr) ;

end.

Maxim12003 28 мая 2020 г., 13:08:15 | 5 - 9 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать произвольные значения.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.

Но лучше на языке Паскаль.

Alsuska18 11 апр. 2020 г., 04:10:32 | 5 - 9 классы

Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не деля?

Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не делятся на 3.

Karinka1984 7 авг. 2020 г., 17:21:14 | 10 - 11 классы

Дан массив из 30 элементов, принимающих значения от 0 до 100?

Дан массив из 30 элементов, принимающих значения от 0 до 100.

Найти произведение двузначных чётных элементов массива, которые начинаются с цифры 5, 6 или 7.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Bog100 12 мая 2020 г., 16:05:02 | 5 - 9 классы

Дан целочисленный массив из 30 элементов?

Дан целочисленный массив из 30 элементов.

Элементы массива могут принимать значения от 0 до 1000.

Напишите программу, позволяющую найти и вывести количество элементов массива, кратных трём, запись которых заканчивается цифрой 1.

Паскаль АБС.

4yBAK4 28 окт. 2020 г., 14:55:27 | 5 - 9 классы

Дан целочисленный массив из 10 элементов?

Дан целочисленный массив из 10 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

DaryverRUZ 8 нояб. 2020 г., 18:37:35 | 10 - 11 классы

№1. Дан массив из 30 - ти элементов?

№1. Дан массив из 30 - ти элементов.

Каждый элемент может принимать целочисленные значения от - 100 до 100.

Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива.

№2. Дан массив из 40 элементов.

Каждый элемент может принимать целочисленные значения от 0 до 200.

Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива.

Elenashmeleva1 14 апр. 2020 г., 00:10:59 | 5 - 9 классы

Дан целочисленный массив из 50 элементов?

Дан целочисленный массив из 50 элементов.

Элементы массива могут приннимать целые значения от 0 до 1000.

Найти и вывести номер элемента массива, имеющего максимальное значение среди элементов массива, которые больше, чем 4 и меньше , чем 9.

Гарантируется , что в исходном массиве есть хотя бы один такой элемент.

На паскале , помогите пожалуйста.

Gffghvd 8 окт. 2020 г., 19:16:16 | 5 - 9 классы

Дан массив А целых чисел, состоящий из 25 элементов?

Дан массив А целых чисел, состоящий из 25 элементов.

Заполнить с клавиатуры.

3)Найти элемент массива кратный 12 и его индекс.

4)Найти сумму положительных элементов, значения которых меньше 10.

5)Вывести индексы тех элементов, которых кратн.

Sidorovakatyus 23 нояб. 2020 г., 14:56:40 | 5 - 9 классы

Дан целочисленный массив из 20 элементов?

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно.

Опишите на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, в которых сумма элементов делится на 2, но не делится на 4.

В данной задаче под парой подразумеваются два соседних элемента массива.

GrafAleksandr1 7 дек. 2020 г., 19:21:13 | 10 - 11 классы

Дан целочисленный массив из 20 элементов?

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от 0 до 10000 включительно.

Опишите алгоритм, позволяющий найти и вывести максимальное значение среди трёхзначных элементов массива, не делящихся на 7.

Если в исходном массиве нет элемента, значение которого является трёхзначным числом и при этом кратно 7, то вывести сообщение «Не найдено».

На языке PHP.

Вопрос Дан массив из 40 элементов ?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.