Вычислите среднее арифметическое наибольшего и наименьшего из n чисел?

Информатика | 5 - 9 классы

Вычислите среднее арифметическое наибольшего и наименьшего из n чисел.

Язык программирования Паскаль.

Ответить на вопрос
Ответы (1)
Vloud 26 окт. 2020 г., 12:07:53

Var

s, a, n, i, min, max : integer ;

begin

min : = 32767 ;

max : = - 32768 ;

readln(n) ;

for i : = 1 to n do

begin

readln(a) ;

if a< ; min then min : = a ;

if a> ; max then max : = a ;

end ;

s : = (min + max) / 2 ;

writeln(s) ;

end.

Annadonovskaya 11 мар. 2020 г., 21:16:57 | 5 - 9 классы

Программирование на языке паскаль?

Программирование на языке паскаль.

Вычислить у = 3х² + 5, для х заданного с клавиатуры.

Armada22 1 нояб. 2020 г., 15:55:30 | 10 - 11 классы

Паскаль язык программирования?

Паскаль язык программирования.

Vudi 27 июн. 2020 г., 21:21:09 | 5 - 9 классы

Программа для вычисления среднего арифметического из двух чисел в паскале?

Программа для вычисления среднего арифметического из двух чисел в паскале.

Пост1 28 мая 2020 г., 06:34:10 | 10 - 11 классы

Сосчитать сумму и количество двухзначных чисел, кратных 7?

Сосчитать сумму и количество двухзначных чисел, кратных 7.

Язык программирования - Паскаль.

Арьнюшка 19 апр. 2020 г., 15:23:39 | 5 - 9 классы

Язык программирования PascalСреди всех трёхназчных чисел посчитать количество кратных 5?

Язык программирования Pascal

Среди всех трёхназчных чисел посчитать количество кратных 5.

Найти их среднее арифметическое.

DONikita 4 окт. 2020 г., 17:29:13 | 10 - 11 классы

Программирование на паскале?

Программирование на паскале.

Найти среднее арифметическое положительных чётных чисел натурального ряда до N.

(Использование цикличного оператора for).

СоняРыбакова 16 апр. 2020 г., 22:47:36 | 10 - 11 классы

Опишите на русском языке или на одном из языков программирования алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элемент?

Опишите на русском языке или на одном из языков программирования алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элементов главной диагонали.

Язык Паскаль.

Sofia20077115 19 апр. 2020 г., 14:45:18 | 5 - 9 классы

Для массива из 10 целых чисел?

Для массива из 10 целых чисел.

Найти сумму всех элементов, среднее арифметическое, наибольшее и наименьшее значение.

Изувита 27 нояб. 2020 г., 19:41:05 | 5 - 9 классы

Найдите среднее арифметическое отрицательных чисел из n введенных?

Найдите среднее арифметическое отрицательных чисел из n введенных.

(в паскале).

Timakovanatalya 4 янв. 2020 г., 11:52:06 | 5 - 9 классы

Составить программу нахождения среднего арифметического таблицы ( на языке Паскаль )?

Составить программу нахождения среднего арифметического таблицы ( на языке Паскаль ).

Вопрос Вычислите среднее арифметическое наибольшего и наименьшего из n чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.