Ввести строку из текстового файла?

Информатика | 10 - 11 классы

Ввести строку из текстового файла.

Продублировать в ней все цифры.

Остальные символы оставить без изменения.

PascalABC.

Net.

Ответить на вопрос
Ответы (2)
MarinkaM 19 мар. 2020 г., 14:40:05

Var

f : text ; i, n : integer ; s, s1 : string ;

begin ;

assign(f, 'text.

Txt') ;

reset(f) ; while not(Eof(f)) do read(f, s) ;

close(f) ;

n : = 0 ;

while n< ; > ; length(s) do

begin ; inc(n) ; for i : = 0 to 9 do begin ; str(i, s1) ; if s[n] = s1 then begin ; delete(s, n, 1) ; s1 : = s1 + s1 ; insert(s1, s, n) ; inc(n) ; end ; end ;

end ;

writeln(s) ;

end.

Nnikittich56 19 мар. 2020 г., 14:40:11

/ / PascalABC.

NET 3.

0, сборка 1128

begin var s : = ReadAllText('input.

Txt') ; Writeln(s) ; var so : = '' ; for var i : = 1 to s.

Length do if s[i] in ['0'.

'9'] then so + = s[i] + s[i] else so + = s[i] ; Writeln(so) ;

end.

Тестовое решение :

Сегодня 15 января 2016 года, московское время 19 часов 18 минут.

Сегодня 1155 января 22001166 года, московское время 1199 часов 1188 минут.

Den9898 18 апр. 2020 г., 15:54:24 | 10 - 11 классы

Дан текстовый файл содержащий вещественные числа по одному в каждой строке?

Дан текстовый файл содержащий вещественные числа по одному в каждой строке.

Поместить эти числа в другой файл по 6 в строку перед десятичной точкой оставить 5 знаков после точки 8 знаков.

Т - паскаль.

Jennifer121 22 мая 2020 г., 14:36:43 | 10 - 11 классы

Определить количество строк в текстовом файле, в которых есть символ «?

Определить количество строк в текстовом файле, в которых есть символ «!

». напишите плз код на Паскале.

= 3.

Leokat61 30 апр. 2020 г., 08:50:41 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Вывести на экран самую длинную строку из файла.

Через паскале.

Katringn 20 июн. 2020 г., 00:49:15 | 10 - 11 классы

(Код паскаль)Дан текстовый файл?

(Код паскаль)Дан текстовый файл.

Латинские буквы из него поместить в текущем каталоге в файл file.

Lat, русские – в file.

Rus, все остальные символы – в file.

Oth.

6104 30 янв. 2020 г., 02:22:46 | 10 - 11 классы

Написать программу, которая записывает в файл все слова, начинающиеся с задаваемой с клавиатуры буквы из исходного текстового файла?

Написать программу, которая записывает в файл все слова, начинающиеся с задаваемой с клавиатуры буквы из исходного текстового файла.

Словом считать набор символов, не содержащий пробелов, знаков препинания и ограниченный пробелами, знаками препинания или началом / концом строки.

Если исходный файл не содержит подходящих слов, то оставить результирующий файл пустым.

AndrievskyVita 11 июн. 2020 г., 15:53:52 | 10 - 11 классы

Имеется текстовый файл?

Имеется текстовый файл.

Напечатать : символы с s1 - го по s2 - й в первой строке.

Camal111 4 мая 2020 г., 15:15:19 | 5 - 9 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество символов в каждой строке.

Даринка30 15 мар. 2020 г., 15:53:47 | 5 - 9 классы

Создать текстовый документ с помощью Паскаля, в котором N строк и M символов в строке, и символы - цифры 1, 2?

Создать текстовый документ с помощью Паскаля, в котором N строк и M символов в строке, и символы - цифры 1, 2.

Lemai2005 19 сент. 2020 г., 16:16:29 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество строк, в которых вторым стоит символ « + », а предпоследним « - ».

Sashokgorshkov 13 окт. 2020 г., 04:26:03 | 5 - 9 классы

Как писать в начале pascalABC?

Как писать в начале pascalABC.

Net.

На этой странице находится вопрос Ввести строку из текстового файла?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.