Определить количество строк в текстовом файле, в которых есть символ «?

Информатика | 10 - 11 классы

Определить количество строк в текстовом файле, в которых есть символ «!

». напишите плз код на Паскале.

= 3.

Ответить на вопрос
Ответы (1)
Lrdh 22 мая 2020 г., 14:36:44

/ / Pascal ABC.

NET Версия 2.

2 Сборка 790

var f : text ;

a, i, n : integer ;

ars : array of string ;

begin ;

assign(f, 'text.

Txt') ;

reset(f) ;

while not Eof(f) do

begin ;

inc(n) ;

setlength(ars, n + 1) ;

readln(f, ars[n]) ;

end ;

close(f) ;

for i : = 1 to n do

if pos('!

', ars[i])< ; > ; 0 then a : = a + 1 ;

writeln(a) ;

end.

Пример text.

Txt :

890 823 23 232 23

436434!

346643

21

Пример вывода :

1.

Leokat61 30 апр. 2020 г., 08:50:41 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Вывести на экран самую длинную строку из файла.

Через паскале.

Katringn 20 июн. 2020 г., 00:49:15 | 10 - 11 классы

(Код паскаль)Дан текстовый файл?

(Код паскаль)Дан текстовый файл.

Латинские буквы из него поместить в текущем каталоге в файл file.

Lat, русские – в file.

Rus, все остальные символы – в file.

Oth.

Rothuu 26 дек. 2020 г., 03:34:29 | 10 - 11 классы

8. Моделирование текстового редактора?

8. Моделирование текстового редактора.

Паскаль АВС Напишите процедуру Save с параметрами : сохраняемый массив, количество строк в массиве, имя файла для сохранения.

Перед вызовом процедуры обеспечьте диалог с пользователем для выбора имени файла.

AndrievskyVita 11 июн. 2020 г., 15:53:52 | 10 - 11 классы

Имеется текстовый файл?

Имеется текстовый файл.

Напечатать : символы с s1 - го по s2 - й в первой строке.

Julis1 4 янв. 2020 г., 16:00:42 | 10 - 11 классы

Написать программу, которая запишет в текстовый файл 6 разных строк?

Написать программу, которая запишет в текстовый файл 6 разных строк.

Строки вводятся с клавиатуры.

Паскаль.

13Vlad 19 янв. 2020 г., 12:29:54 | 5 - 9 классы

Во введенной строке подсчитайте количество символов " * " и символов "?

Во введенной строке подсчитайте количество символов " * " и символов "!

". Информатика.

Паскаль.

Строки.

Camal111 4 мая 2020 г., 15:15:19 | 5 - 9 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество символов в каждой строке.

Даринка30 15 мар. 2020 г., 15:53:47 | 5 - 9 классы

Создать текстовый документ с помощью Паскаля, в котором N строк и M символов в строке, и символы - цифры 1, 2?

Создать текстовый документ с помощью Паскаля, в котором N строк и M символов в строке, и символы - цифры 1, 2.

Lemai2005 19 сент. 2020 г., 16:16:29 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество строк, в которых вторым стоит символ « + », а предпоследним « - ».

Karinakardanov 14 дек. 2020 г., 17:30:24 | 5 - 9 классы

Как определить количество символов во втором слове введённой строки в паскале?

Как определить количество символов во втором слове введённой строки в паскале?

На этой странице сайта размещен вопрос Определить количество строк в текстовом файле, в которых есть символ «? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.