Какую задачу решает данная программа ?

Информатика | 5 - 9 классы

Какую задачу решает данная программа .

Что нужно изменить в программе , чтобы она решила задачу нахождения утроенного частного двух чисел .

Program pr3 ; var a, b , c : integer ; begin readln(a, b) ; c : = sqr (a) + sqr (b) ; writeln('c = ' , c) ; end.

Ответить на вопрос
Ответы (1)
Yakivmitkevuch 27 февр. 2020 г., 19:51:30

Программа находит сумма квадратов двух чисел, чтоб уьроенного меняешь только строку c = и пишешь c = a * 3 + b * 3.

MikaEpt 27 апр. 2020 г., 10:34:15 | 5 - 9 классы

ЧТО НЕ ПРАВИЛЬНО?

ЧТО НЕ ПРАВИЛЬНО?

Program p_1 ;

var x, y : real ;

begin

read(x) ;

if 0< ; x< ; 2 then begin y : = sqr(cos(x)) ;

else begin y : = 1 - sin(sqr(x)) ;

end ;

writeln(y) ;

end.

Учени10101010101010 15 дек. 2020 г., 09:59:59 | 5 - 9 классы

Прошу вас, помогите?

Прошу вас, помогите!

Решается оценка!

Найдите ошибки в программе 1)Program z1 ; var a : integer ; begin a : = 10 ; while a< ; 5 do writeln(a) ; a : = a + 1 ; End.

2)Program z2 ; var a, s : integer ; begin a : = 1 ; s : = 0 ; while a< ; 10 do begin s : = s + a / 2 ; end ; writeln(s) ; end.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

Kiritakun 19 авг. 2020 г., 08:58:45 | 5 - 9 классы

Составить программу вычисления значения функции (при любом значении x) :y = sin(3, 2 + (sqr(1 + x)) : (sqrt(sqr(5 * x)))Что не правильно?

Составить программу вычисления значения функции (при любом значении x) :

y = sin(3, 2 + (sqr(1 + x)) : (sqrt(sqr(5 * x)))

Что не правильно?

Program N15b ;

var x : integer ; y : real ;

begin

writeln('Введите x') ;

readln(x) ;

y : = sin(3, 2 + (sqrt(1 + x)) : (sqrt(sqr(5 * x))) ;

write(y) ;

end.

Fendoriys 24 апр. 2020 г., 11:49:56 | 5 - 9 классы

Составить программу для вычисления суммы квадратов чисел от 1 до 15?

Составить программу для вычисления суммы квадратов чисел от 1 до 15.

Функция возведения в квадрат sqr() ; Var , , : ; Begin : = 0 ; For : = to do Begin ; ; End ; Writeln(' = ', ) ; End.

Там, где пробелы, вставить что нужно.

T85gordeeva 18 сент. 2020 г., 00:59:32 | 10 - 11 классы

ПОМОГИТЕ ПО ПАСКАЛЮ, нужно продолжить программуЕсть задача : Проверьте можно ли построить треугольник из отрезков с длинами сторон x, y и z, и, если можно, то является ли он тупоугольнымВот примерная ?

ПОМОГИТЕ ПО ПАСКАЛЮ, нужно продолжить программу

Есть задача : Проверьте можно ли построить треугольник из отрезков с длинами сторон x, y и z, и, если можно, то является ли он тупоугольным

Вот примерная программа

var a, b, c : real ;

BEGIN

writeln('Введите значения a, b, c') ;

readln(a, b, c) ;

if (a + b < ; = c) or (b + c < ; = a) or (c + a < ; = b) then writeln('Треугольника с такими сторонами не существует!

')

else begin

if (sqr(a) + sqr(b)< ; sqr(c))and(sqr(b) + sqr(c)> ; sqr(a))and(sqr(c) + sqr(a)> ; sqr(b)) then writeln('Треугольник остроугольный')

else if (sqr(a) + sqr(b) = sqr(c))and(sqr(b) + sqr(c) = sqr(a))and(sqr(c) + sqr(a) = sqr(b)) then writeln('Треугольник прямоугольный')

else writeln('Треугольник тупоугольный') ;

end ;

END.

Но мне нужна именно формула ТУПОУГОЛЬНОГО треугольника, помогите вывести ее пожалуйста!

Lyaschenko 29 мар. 2020 г., 06:07:37 | 5 - 9 классы

Какая задача решается по следующей программе?

Какая задача решается по следующей программе?

Program Test var A, B, C : integer ; begin readln ( A, B) ; C : (A + B) * (B - A) writeln(C) end.

Задача связана с программой паскаль.

Ema999 27 апр. 2020 г., 17:11:38 | 5 - 9 классы

Как записать программу сложения чисел 2 + 3 в Паскаль ?

Как записать программу сложения чисел 2 + 3 в Паскаль ?

Program summa ; var a, b, c : integer ; begin Что нужно дальше ?

Spasibo123 5 февр. 2020 г., 18:45:06 | 10 - 11 классы

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End?

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End.

Galina50286 13 дек. 2020 г., 16:46:22 | 5 - 9 классы

Найдите ошибки в следующих программах :Program int_r ;Var a, x : integer ;b, c : real ;Begina : = 10 ;b : = 5?

Найдите ошибки в следующих программах :

Program int_r ;

Var a, x : integer ;

b, c : real ;

Begin

a : = 10 ;

b : = 5.

2 ;

x : = b div 2 ;

c : = round(x) ;

End.

Program int_r1 ;

Var a, c : integer ;

b, d : real ;

Begin

a : = 25 ;

b : = a / 2 ;

c : = sqr(a) ;

d : = a mod 10 ;

End.

Вы находитесь на странице вопроса Какую задачу решает данная программа ? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.