Если 1 буква твоего имени и, то все остальные поменять на * помоги пожааааааалуууйстаа программу составиитьстроковый тип данныхпаскаль абс?

Информатика | 10 - 11 классы

Если 1 буква твоего имени и, то все остальные поменять на * помоги пожааааааалуууйстаа программу составиить

строковый тип данных

паскаль абс.

Ответить на вопрос
Ответы (1)
Ахчи1 6 июн. 2020 г., 01:35:59

1. Решение для "школьников" / / PascalABC.

NET 3.

0, сборка 1073

var i, n : integer ; s : string ;

begin Write('Введите свое имя : ') ; Readln(s) ; if s[1] = 'И' then begin n : = Length(s) - 1 ; s : = s[1] ; for i : = 1 to n do s : = s + ' * ' end ; Writeln('Результат работы : ', s)

end.

Тестовое решение :

Введите свое имя : Игорь

Результат работы : И * * * *

Введите свое имя : Сергей

Результат работы : Сергей

2.

Решение, каким оно должно быть, но этому не учат / / PascalABC.

NET 3.

0, сборка 1073

begin var s : = ReadString('Введите свое имя : ') ; if s[1] = 'И' then s : = s[1] + StringOfChar(' * ', Length(s) - 1) ; Writeln('Результат работы : ', s)

end.

Serg1587 8 нояб. 2020 г., 03:17:48 | 10 - 11 классы

Используя операции и функции для строковых типов данных, написать программу, где из слова РАДОСТЬ получиться слово ССОРА?

Используя операции и функции для строковых типов данных, написать программу, где из слова РАДОСТЬ получиться слово ССОРА.

Nik1998shch 25 авг. 2020 г., 10:22:53 | 10 - 11 классы

Строковый тип паскаль : Дана строка?

Строковый тип паскаль : Дана строка.

Определить сколько в ней слов оканчиваются на букву «н».

Skyline241 5 нояб. 2020 г., 05:20:51 | 10 - 11 классы

Даны натуральное число n, символы S1?

Даны натуральное число n, символы S1.

Sn, определить число вхождений группы букв abc.

Символьный и строковый тип.

Помогите пожалуйста.

Очень прошу.

В паскале.

Peach1432 17 сент. 2020 г., 22:45:46 | 5 - 9 классы

Составьте программу на языке паскаль для подсчета суммарного числа букв "е" и "о" в строковой величине?

Составьте программу на языке паскаль для подсчета суммарного числа букв "е" и "о" в строковой величине.

Dano4kA96 29 сент. 2020 г., 05:33:06 | 10 - 11 классы

Помогите пожалуйста составить программу паскаль и объясните ее дано четырехзначное число, получить новое поменяв местами первую и последнюю цифру?

Помогите пожалуйста составить программу паскаль и объясните ее дано четырехзначное число, получить новое поменяв местами первую и последнюю цифру.

Leeeraaaaaaaaa 30 июл. 2020 г., 05:06:32 | 10 - 11 классы

Даны две строковые величины?

Даны две строковые величины.

Написать программу подсчета букв 'в' в меньшей по длине величина.

В случае равенства длин напечатать значение количества букв 'в' в каждой строковой величине.

Anna20031407 8 июн. 2020 г., 13:09:02 | 10 - 11 классы

Помогите написать программу на паскале абс "Файловый тип данных?

Помогите написать программу на паскале абс "Файловый тип данных.

" Дан целочисленный файл А.

Записать в файл В все положительные числа.

Macho216 28 февр. 2020 г., 08:57:07 | 10 - 11 классы

Задание в Паскале?

Задание в Паскале.

Ввести фамилию, имя и отчество как одно данное строкового типа.

Определить длину строки и количество букв "а" в ней ; вывести три буквы (свои инициалы) с точкам.

Викатарина 30 янв. 2020 г., 10:28:39 | 10 - 11 классы

Составить программу, печатающую все простые числа, не превосходящие данного числа?

Составить программу, печатающую все простые числа, не превосходящие данного числа.

Паскаль абс.

Salyahovlinar 25 окт. 2020 г., 10:59:50 | 5 - 9 классы

Программа Паскаль абс?

Программа Паскаль абс.

Дано значение угла.

Угл смежный.

Составить алгоритм нахождения 2 - го угла.

На этой странице вы найдете ответ на вопрос Если 1 буква твоего имени и, то все остальные поменять на * помоги пожааааааалуууйстаа программу составиитьстроковый тип данныхпаскаль абс?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.