Вводится последовательность ненулевых чисел?

Информатика | 10 - 11 классы

Вводится последовательность ненулевых чисел.

0 - конец последовательности.

Подсчитать, сколько в ней отрицательных чисел, и сумму положительных чисел.

Ответить на вопрос
Ответы (1)
Ryun74 4 июн. 2020 г., 06:13:04

Var

a, k, s : integer ;

begin

repeat

write (' = > ; ') ; readln(a) ;

if a< ; 0 then k : = k + 1 else s : = s + a ;

until a = 0 ;

writeln ('Summa : ', s) ;

writeln ('Kol - vo : ', k) ;

readln ;

end.

Lindasayfutdin1 17 окт. 2020 г., 00:46:28 | 5 - 9 классы

Программа в Паскале нужна, пожалуйста?

Программа в Паскале нужна, пожалуйста!

Даю 60 баллов!

С клавиатуры вводится последовательность из N чисел, положительных и отрицательных.

Какая сумма чисел по модулю больше, положительных или отрицательных?

Dasha1074 9 февр. 2020 г., 15:44:52 | 10 - 11 классы

Вводится последовательность ненулевых чисел, 0 — конец последовательности?

Вводится последовательность ненулевых чисел, 0 — конец последовательности.

Определить сумму положительных элементов последовательности.

( нужна блог - схема).

Настьюша 25 сент. 2020 г., 06:15:22 | 10 - 11 классы

Дан массив действительных чисел, размерность которого N?

Дан массив действительных чисел, размерность которого N.

Подсчитать, сколько в нём отрицательных, положительных и ненулевых элементов.

Юки4 15 июн. 2020 г., 22:49:09 | 10 - 11 классы

В простую переменную последовательно вводятся N чисел, отличных от нуля?

В простую переменную последовательно вводятся N чисел, отличных от нуля.

Положительные или отрицательные числа завершают последовательность и сколько их.

Katena95 15 дек. 2020 г., 21:42:29 | 10 - 11 классы

Дана последовательность из М чисел?

Дана последовательность из М чисел.

Подсчитать, сколько в ней отрицательных, положительных и нулевых элементов на basic.

1klass2rtt 2 авг. 2020 г., 10:32:43 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

С клавиатуры вводится последовательность чисел, 0 конец последовательности.

Посчитать сколько введено четных чисел.

Нужно составить программу для Паскаль.

Rjrjhtdf84 7 мая 2020 г., 23:26:52 | 5 - 9 классы

Дана последовательность чисел, заканчивающаяся нулем?

Дана последовательность чисел, заканчивающаяся нулем.

Найти сумму отрицательных и произведение положительных чисел.

Напишите в паскале.

Zenkova929 24 июл. 2020 г., 13:36:47 | 10 - 11 классы

Pascal?

Pascal.

Дана последовательность чисел .

Вывести на экран суммы положительных и отрицательных чисел данной последовательности.

Киса315 19 апр. 2020 г., 17:02:37 | 10 - 11 классы

Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел?

Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел.

Вводится число N, а затем N чисел.

Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.

C + +.

1Демон1 31 дек. 2020 г., 04:01:46 | 10 - 11 классы

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем?

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем.

Найти количество отрицательных чисел и сумму чисел кратных 4.

Перед вами страница с вопросом Вводится последовательность ненулевых чисел?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.