А)Напишите процедуру(или через глобальные переменные), которая вычесляет произведение отрицательных элементов вектора?

Информатика | 10 - 11 классы

А)Напишите процедуру(или через глобальные переменные), которая вычесляет произведение отрицательных элементов вектора.

Б)Напишите процедуру которая находит и заносит в массив простые числа меньше чем заданного(любого числа)натурального числа.

Ответить на вопрос
Ответы (1)
Zulika2003 8 дек. 2020 г., 06:36:46

/ / PascalABC.

NET 3.

1, сборка 1179 от 29.

02. 2016

procedure GetProdNeg(a : array of integer ; var p : real) ; / / произведение отрицательных элементов

begin p : = a.

Where(x - > ; x< ; 0).

Aggregate(1.

0, (p, e) - > ; p * e)

end ;

function IsPrime(n : integer) : boolean : = Range(2, Round(sqrt(n))).

All(i - > ; n mod i< ; > ; 0) ;

procedure ArrPrime(n : integer ; var a : array of integer) ; / / массив простых чисел не больших n

begin a : = Range(2, n).

Where(i - > ; IsPrime(i)).

ToArray

end ;

begin var n : = ReadInteger('n = ') ; var a : = ArrRandom(n, - 50, 50) ; a.

Println ; var r : real ; GetProdNeg(a, r) ; Writeln('Произведение ', r) ; n : = ReadInteger('n = ') ; var b : array of integer ; ArrPrime(n, b) ; b.

Println

end.

Тестовое решение :

n = 15

27 - 7 - 36 40 - 15 - 21 - 47 - 28 - 12 45 3 - 38 - 15 1 - 39

Произведение 27866837980800

n = 300

2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 127 131 137 139 149 151 157 163 167 173 179 181 191 193 197 199 211 223 227 229 233 239 241 251 257 263 269 271 277 281 283 293.

Asema198448 6 авг. 2020 г., 09:32:32 | 5 - 9 классы

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран?

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран.

Avdieienko1976 20 авг. 2020 г., 21:00:43 | 5 - 9 классы

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными (паскаль авс).

Super010600 6 июл. 2020 г., 06:56:58 | 5 - 9 классы

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения?

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Через цикл WHILE!

Нурайым1 24 мар. 2020 г., 04:54:37 | 5 - 9 классы

Информатика?

Информатика.

Тема глобальные и локальные переменные.

Задача : написать глобальный массив из 10 элементов.

В паскале, через процедуру.

Леруська1401 3 июл. 2020 г., 12:11:32 | 10 - 11 классы

Даны массив А(13), состоящий из элементов, среди которых есть положительные, отрицательные и равные нулю?

Даны массив А(13), состоящий из элементов, среди которых есть положительные, отрицательные и равные нулю.

Напечатать те числа из массива, которые меньше предыдущего числа.

Vehshk 21 февр. 2020 г., 23:43:43 | 10 - 11 классы

А)Напишите процедуру(или через глобальные переменные), которая вычесляет произведение отрицательных элементов вектора?

А)Напишите процедуру(или через глобальные переменные), которая вычесляет произведение отрицательных элементов вектора.

Б)Напишите процедуру которая находит и заносит в массив простые числа меньше чем заданного(любого числа)натурального числа.

(РЕШИТЕ НА БАЗЕ Turbo Pascal 7.

0).

Киря1321 1 апр. 2020 г., 09:32:43 | 5 - 9 классы

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отрицательными?

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отрицательными.

(надо в c + + ).

Дарила1 13 дек. 2020 г., 01:25:55 | 5 - 9 классы

Помогите составить программу, которая заполняет массив a [ 1?

Помогите составить программу, которая заполняет массив a [ 1.

10] случайными целыми числами в диапозоне от 1 да 10 и вычесляет произведения элементов массива с нечетными значениями.

Shavak 18 сент. 2020 г., 15:43:59 | 5 - 9 классы

Используя стек, написать процедуру или функцию, которая заменяет все отрицательные элементы на их абсолютные значения?

Используя стек, написать процедуру или функцию, которая заменяет все отрицательные элементы на их абсолютные значения.

Vahe774411 22 нояб. 2020 г., 12:44:56 | 5 - 9 классы

Составьте программу, которая заполняет массив а 1?

Составьте программу, которая заполняет массив а 1.

0 случайными целыми числами в диапазоне от 1 до 10 и вычесляет сумму элементов массива с четными значениями.

Перед вами страница с вопросом А)Напишите процедуру(или через глобальные переменные), которая вычесляет произведение отрицательных элементов вектора?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.