Кто - нибудь кто хорошо разбирается в Pascal ABC, помогите, пожалуйста?

Информатика | 5 - 9 классы

Кто - нибудь кто хорошо разбирается в Pascal ABC, помогите, пожалуйста!

1. Нарисовать круг, разделённый на N одинаковых частей, окрашенных в разный цвет.

Количество частей N вводится с клавиатуры.

2. Нарисовать пирамиду из разноцветных прямоугольников.

Количество прямоугольников вводится с клавиатуры.

3. С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует) Вычислить произведение максимального и минимального числа.

4. С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует).

Известно, что среди первых двух чисел нуля нет.

Найти сумму двух наибольших чисел.

5. С клавиатуры вводятся целые числа, пока не встретится ноль (ноль служит только для ограничения ввода и в дальнейших подсчётах не участвует).

Известно, что среди первых трех чисел нуля нет.

Найти среднее арифметическое трёх наименьших чисел.

Ответить на вопрос
Ответы (1)
Pinkie22222222222 22 дек. 2020 г., 17:35:40

1)

Uses crt, graphABC ;

var a, c : real ;

N, i, r, g, b : integer ;

begin

circle(100, 100, 80) ;

read(N) ;

a : = 0 ;

c : = 360 ;

r : = 5 ; g : = 5 ; b : = 5 ;

for i : = 1 to N do begin

pie(100, 100, 80, a, c) ;

FloodFill(145, 97, RGB(r, g, b)) ;

c : = c - 360 / N ;

r : = r + 30 ;

g : = g + 10 ;

b : = b + 45 ;

end ;

end.

2)

Uses crt, graphABC ;

var N, i, x1, y1, x2, y2 : integer ;

begin

read(N) ;

x1 : = 350 ;

y1 : = 10 ;

x2 : = 360 ;

y2 : = 15 ;

for i : = 1 to N do begin

randomize ;

SetBrushColor(RGB(random(256), random(256), random(256))) ;

rectangle(x1, y1, x2, y2) ;

FillRect(x1, y1, x2, y2) ;

x1 : = x1 - 5 * i ;

y1 : = y2 - 1 ;

x2 : = x2 + 5 * i ;

y2 : = y2 + i * 5 ;

end ;

end.

3)

var a, min, max, f : integer ;

begin

f : = 0 ;

Repeat

read(a) ;

if a< ; > ; 0 then begin

if f = 0 then begin

min : = a ;

max : = a ;

end else begin

if a< ; min then min : = a ;

if a> ; max then max : = a ;

end ;

f : = f + 1 ;

end ;

UNTIL a = 0 ;

Writeln(max * min) ;

end.

4)

var a, max1, max2, f : integer ;

begin

f : = 0 ;

Repeat

read(a) ;

if a< ; > ; 0 then begin

if f = 0 then begin

max1 : = a ;

end else

if f = 1 then begin

if a< ; max1 then max2 : = a else begin

max2 : = max1 ;

max1 : = a ;

end ;

end else begin

if a> ; max1 then max1 : = a ;

if (a> ; max2) and (a< ; = max1) then max2 : = a ;

end ;

f : = f + 1 ;

end ;

UNTIL a = 0 ;

Writeln(max1 + max2) ;

end.

5)

var a, min1, min2, min3, f : integer ;

begin

f : = 0 ;

Repeat

read(a) ;

if a< ; > ; 0 then begin

if f = 0 then begin

min1 : = a ;

end else

if f = 1 then begin

if a> ; min1 then min2 : = a else begin

min2 : = min1 ;

min1 : = a ;

end ;

end else

if f = 2 then begin

if (a> ; min1) and (a> ; min2) then min3 : = a else if (a> ; = min1) and (a< ; = min2) then begin

min3 : = min2 ;

min2 : = a ;

end else begin

min3 : = min2 ;

min2 : = min1 ;

min1 : = a ;

end ;

end else begin

if a< ; min1 then begin

min3 : = min2 ;

min2 : = min1 ;

min1 : = a ; end else

if (a< ; min2) and (a> ; = min1) then begin

min3 : = min2 ;

min2 : = a ;

end else

if (a> ; = min2) and(a< ; min3) then min3 : = a ;

end ;

f : = f + 1 ;

end ;

UNTIL a = 0 ;

Writeln((min1 + min2 + min3) / 3 : 3 : 3) ;

end.

Egorov0404 1 сент. 2020 г., 08:21:09 | 5 - 9 классы

Написать программу ввода целых чисел до тех пор, пока не будет введен ноль, посчитать сумму введеных чисел и их среднее арифметическое?

Написать программу ввода целых чисел до тех пор, пока не будет введен ноль, посчитать сумму введеных чисел и их среднее арифметическое.

Помогите пожалуйста!

Диана171717 30 июн. 2020 г., 22:04:50 | 5 - 9 классы

С клавиатуры вводятся числа до тех пор пока не введено число - 5?

С клавиатуры вводятся числа до тех пор пока не введено число - 5.

Найти количество четных чисел из веденных.

Wiktorya331 14 сент. 2020 г., 05:01:19 | 5 - 9 классы

С клавиатуры вводятся числа до сих пор пока не введено число - 5?

С клавиатуры вводятся числа до сих пор пока не введено число - 5.

Найти количество чисел кратных 13 из введенных.

Bikovaanastasi 20 мая 2020 г., 02:58:53 | 5 - 9 классы

Решите задачу по Free Pascal IDE?

Решите задачу по Free Pascal IDE.

С клавиатуры вводится два вещественных числа.

Найти целую часть от произведения двух вещественных чисел.

Yurvaz 13 авг. 2020 г., 09:37:33 | 5 - 9 классы

С клавиатуры вводятся числа пока их сумма меньше 300?

С клавиатуры вводятся числа пока их сумма меньше 300.

Найти произведение отрицательных чисел делящихся на 3.

ROMSIS2013 24 окт. 2020 г., 03:11:07 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального ( наибольшего) из введённых чисел?

Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального ( наибольшего) из введённых чисел.

Используйте оператор repeat.

Natali20103 25 авг. 2020 г., 11:35:43 | 5 - 9 классы

Составьте программу для ввода с клавиатуры 10 чисел и вывода количества нулей среди них?

Составьте программу для ввода с клавиатуры 10 чисел и вывода количества нулей среди них.

Yuliyaplavskay 30 апр. 2020 г., 13:30:11 | 5 - 9 классы

С клавиатуры вводятся числа, определить сумму и количество, пока не введено 98?

С клавиатуры вводятся числа, определить сумму и количество, пока не введено 98.

1Демон1 31 дек. 2020 г., 04:01:46 | 10 - 11 классы

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем?

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем.

Найти количество отрицательных чисел и сумму чисел кратных 4.

ИраИлюхина2006 16 дек. 2020 г., 20:49:45 | 5 - 9 классы

Помогите, пожалуйста, написать программы?

Помогите, пожалуйста, написать программы!

Очень нужно!

Язык - паскаль!

1) вычислить количество введенных с клавиатуры чисел.

Окончанием служит ввод значения x.

2) вывести максимальное из чисел, вводимых с клавиатуры.

Окончанием служит ввод значения x.

3) вывести произведение 20 чисел вводимых с клавиатуры.

4) вычислить произведение чисел, вводимых с клавиатуры.

Окончанием служит ввод значения x.

Если вам необходимо получить ответ на вопрос Кто - нибудь кто хорошо разбирается в Pascal ABC, помогите, пожалуйста?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.