В ПАСКАЛЕ?

Информатика | 5 - 9 классы

В ПАСКАЛЕ!

111)1)Определить какое из двухзначных чисел имеет наибольшую сумму цифр 2)Пользователь ввёл двузнч числа.

Поменяйте цифры данного числа местами 3)Проверить есть ли в трёхзначном числе два одинаковых цифры.

Ответить на вопрос
Ответы (1)
Ventanabc 2 янв. 2020 г., 21:23:16

1)

var a, b : integer ;

begin readln(a, b) ; if (a div 10 + a mod 10) > ; (b div 10 + b mod 10) then writeln('сумма цифр ', a, ' больше') else writeln('сумма цифр ', b, ' больше') ;

end.

2)

var a : integer ;

begin readln(a) ; writeln((a mod 10) * 10 + a div 10) ;

end.

3)

var a : integer ;

begin readln(a) ; if ((a div 100) = (a mod 100) div 10) or ((a div 100) = (a mod 10)) or ((a mod 100) div 10 = (a mod 10)) then writeln('есть 2 одинаковые цифры') else writeln('нет 2 - х одинаковых цифр') ;

end.

Dashamahanyok 24 мар. 2020 г., 20:02:32 | 10 - 11 классы

Дано 4 значное число, поменять местами первую и последнюю цифру?

Дано 4 значное число, поменять местами первую и последнюю цифру.

Программирование, составить в Паскале.

Zhuzhechko 28 авг. 2020 г., 06:24:19 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

Fff555 23 окт. 2020 г., 01:29:44 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Определить : является ли сумма его цифр двузначным числом.

Kovanov2014 27 окт. 2020 г., 02:37:24 | 10 - 11 классы

Дано трёхзначное число?

Дано трёхзначное число.

Найти среди цифр этого числа, максимальное.

Программа в Паскале.

Дашенька144 20 нояб. 2020 г., 10:15:13 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Верно ли что оно состоит из одинаковых цифр.

Решите через паскаль.

Муська2487 12 июл. 2020 г., 17:12:54 | 5 - 9 классы

Дано трёхзначное число, проверить делится ли произведение его цифр на 5?

Дано трёхзначное число, проверить делится ли произведение его цифр на 5?

Любимаямоя 10 февр. 2020 г., 09:47:00 | 10 - 11 классы

Составить программу на Паскале?

Составить программу на Паскале.

Дано двухзначное число N.

Проверить, меньше ли сумма цифр числа N заданного числа К.

Вывести об этом сообщение и значения числа N и К.

Cherhan76 8 янв. 2020 г., 17:55:41 | 5 - 9 классы

Дано двухзначное число, поменять местами цифры блок схема и паскаль?

Дано двухзначное число, поменять местами цифры блок схема и паскаль.

ПОМОГИТЕ.

Lanabuklova 28 нояб. 2020 г., 16:38:07 | 10 - 11 классы

Решить в паскале : дано двузначное число, определить : а) кратно ли 3 сумма его цифр ; б) кратно ли сумма его цифр числу a?

Решить в паскале : дано двузначное число, определить : а) кратно ли 3 сумма его цифр ; б) кратно ли сумма его цифр числу a.

Nrodionov2000 22 нояб. 2020 г., 21:15:29 | 5 - 9 классы

Если трёхзначное число равно сумме кубов цифр, образующихэто число, то такое число называется «магическим»?

Если трёхзначное число равно сумме кубов цифр, образующих

это число, то такое число называется «магическим».

Найти и вывести все

«магические числа».

(Написать функцию вычисления суммы кубов цифр

трёхзначного числа).

Паскаль, через функции пользователя.

На этой странице находится вопрос В ПАСКАЛЕ?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.